Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - No power
Thread: No power
View Single Post
Old 06-10-2019, 11:19 PM   #1
IdkBut#RACECAR
Focus Rookie
 
Join Date: Feb 2019
Fan#: 410293
Posts: 10
Points 47, Level 1
Points: 47, Level: 1 Points: 47, Level: 1 Points: 47, Level: 1
Level Up 94% Completed
Level up: 94% Level up: 94% Level up: 94%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 IdkBut#RACECAR Good Standing Member
Buy-Sell-Trade Rating: (0)
I’ve been trying to figure what’s going on with my 01 ZX3 Zetec. I was driving it the other day and it just died when I tried to take off. I checked the battery and it’s fully charged. The weird thing is that the doors lock and the interior lights turn on but the dash lights won’t and the radio only works when I push in the volume button but no sounds comes out. Someone told me it could be the ignition relay and I bought the part but when I took out the old one it’s different from the one that I bought. Next move is to remove the starter and the alternator. Also the car would rev a little higher randomly when I would drive and the battery light would come on. I also added a photo of the one I took out of the car and the one I got at autozone but it looks like it fits the spot next to the relay that I took out


Attached Thumbnails
No power-image_1560228366442.jpg  


Last edited by IdkBut#RACECAR; 06-10-2019 at 11:46 PM. Reason: Need to add a photo
IdkBut#RACECAR is offline  
    Reply With Quote