Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - water pump?
Thread: water pump?
View Single Post
Old 05-15-2019, 10:04 AM   #6
Livens
Focus Enthusiast
 
Join Date: Dec 2007
Fan#: 52547
Location: Kentucky, United States
What I Drive: 2015 Silver SE 2.0/DCT

Posts: 150
Points 868, Level 15
Points: 868, Level: 15 Points: 868, Level: 15 Points: 868, Level: 15
Level Up 68% Completed
Level up: 68% Level up: 68% Level up: 68%
Forum Activity 9%
Activity: 9% Activity: 9% Activity: 9%
FF Reputation: 2 Livens Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Myooh Lah View Post
Ok, the sound isn't until the car is warmed up, and there's no change in it with or without the a/c on, so I'm on to it just being the tensioner. My temp was running closer to 3/4 of the way to red during the wet cool weather the past couple of weeks, but is now running just below half, like you described. Maybe I need to get a new set of belts on it. Thanks!
Not sure about the noise, worth checking all the pulley's and tentioners.

However, your temp gauge readings would have me worried. Both of my Foci (a MKI and a MKIII) have never went above the half way point. Even in 105F heat, stop n go on the freeway, idling for hours... That needle never budges.

I would at minimum replace your thermostat. I didn't see your mileage, maybe its due anyway? Not sure if there is a way to check your water pump without removing it... and if you go to the trouble of pulling it off you might as well replace it. But that would be the last thing on my list to do.
Livens is online now  
    Reply With Quote