Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - 2004 focus 2.3 pzev electrical issue
View Single Post
Old 04-09-2019, 07:38 AM   #5
Drew0427
Focus Enthusiast
 
Drew0427's Avatar
 
Join Date: Apr 2019
Fan#: 411801
Location: Worcester, MA
What I Drive: 2004 grey focus zx3 2.3 pzev

Posts: 59
Points 42, Level 1
Points: 42, Level: 1 Points: 42, Level: 1 Points: 42, Level: 1
Level Up 84% Completed
Level up: 84% Level up: 84% Level up: 84%
Forum Activity 25%
Activity: 25% Activity: 25% Activity: 25%
FF Reputation: 1 Drew0427 Good Standing Member
Buy-Sell-Trade Rating: (0)
Alright so I bought the car about a month ago with 48,000 miles and it's been garage kept all it's life till now. Everything on the car works an after a bit of visual inspection there is no signs of wear on the electrical components in the car but as previously stated the lights on the interior and exterior of the car flicker while at idle once the car is in motion the flickering goes away. I understand the idea the alternator could be going but under load, example(radio on high,heater blowing, windshield wiper on) there is no flicker at any point untill I'm at a light idleing. Now there is no dimming of the lights an I've tested my battery on many occasions in which I start each day at 12.7v an it goes up to 14v so there is no point in which the battery has dropped below that so that also makes it seem that the alternator should be just fine.

I should include I've had alternator fail in the past on a few other vehicles , again this car (2004 Ford focus) it is old but in like new condition. There should be no issue with the alternator.

Hope this description is a bit easier to rap your minds around, I will work on my Grammer an punctuation.

Last edited by Drew0427; 04-09-2019 at 07:42 AM.
Drew0427 is offline  
    Reply With Quote