Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Engine Slows down and turns off while Driving
View Single Post
Old 03-14-2019, 08:27 PM   #1
FunSVTFocus
Focus Rookie
 
FunSVTFocus's Avatar
 
Join Date: Dec 2018
Fan#: 407779
Location: Concord, NC
What I Drive: 2002 Ford SVT Focus

Posts: 16
Points 84, Level 1
Points: 84, Level: 1 Points: 84, Level: 1 Points: 84, Level: 1
Level Up 68% Completed
Level up: 68% Level up: 68% Level up: 68%
Forum Activity 38%
Activity: 38% Activity: 38% Activity: 38%
FF Reputation: 1 FunSVTFocus Good Standing Member
Buy-Sell-Trade Rating: (0)
Engine Slows down and turns off while Driving

Hello, Currently I have an 02 SVT Focus and i had an issue this afternoon coming home from work. Let me place you the setting for it. It is about 72 degrees out side about 4:35 in the afternoon, and as im cruising at about 60mph, the car starts to slow down as if you are putting on the brakes, and then it died as i had the clutch pushed in and in neutral trying to get it safely to the side of the road, as I started to come to a stop at the side of the road, the steering wheel wouldnt turn, it was locked. Once I got it to the side of the road the engine turned itself off throwing a check engine light, Oil light and battery light. I popped the hood and saw i had plenty of Coolant, Oil was just changed last Saturday at my local Ford Dealership, tires rotated. Nothing was leaking from the car. So I tried starting the Car back up, and it fired right up with no delay. When it cranked back up, no lights were on, on the Instrament Cluster, weird. So I was only about 15 min from home, so I decided to try to limp it home. it lasted about 5 min down the road and got stopped by a stoplight and noticed it was trying to idle rough at about 800rpm. then made it a half mile and it started acting up again, this time I noticed it only really happened around 3000rpm. The car shut itself off again and then I waited about 2 minutes and started it up again, but when I started it up again this time there was a check engine light displayed and stayed on. I limped it the rest of the way home, but have nothing to check the code with here at my house so i will have to get an auto parts store tell me what the code is. I have already replaced the Fuel pump twice, so it shouldnt be that. Anyone else experiencing the same issue I have? Anyone know the answer? I live In NC, so any thoughts would be great.


__________________
Cars/Trucks owned:
2002 SVT Focus (call her the Common Death Adder)
2017 Tuned F-150 Ecoboost 3.5L
FunSVTFocus is offline  
    Reply With Quote