Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Quick electric question.
View Single Post
Old 09-25-2017, 09:52 AM   #16
Magus2727
Thats What She Said
 
Magus2727's Avatar
 
Join Date: Feb 2009
Fan#: 62897
Location: Salt Lake City, UT
What I Drive: 2001 MB ZX3, 2004 SY SVT ZX5

Posts: 10,641
Points 21,249, Level 91
Points: 21,249, Level: 91 Points: 21,249, Level: 91 Points: 21,249, Level: 91
Level Up 80% Completed
Level up: 80% Level up: 80% Level up: 80%
Forum Activity 17%
Activity: 17% Activity: 17% Activity: 17%
FF Reputation: 24 Magus2727 Great Standing Member
Buy-Sell-Trade Rating: (2)
Then work the path of easiest to check.

Double check all cables on the battery. Just because you bought it even yesterday it could be bad. Also if it is your alt, it could have killed your new battery also.

So just blower, headlights, and wipers? Nothing else extricate like radio, engine shutting down (no spark), gauge cluster?

Try to pay attention to the gauge cluster next time. If the gauge reset or go wonky as in the display shows - - - - where the trip and Odometer are. Or if lights come on.

Sounds like it could still be an isolated problem if you are not having wide spread electrical drop out.

Look in the engine bay fuse box, smell for burning plastic smell. Check fuses, check relays. Clean and tighten down the battery posts. Check the wire crimp on the posts, that usualy starts fraying and braking strands.
__________________
2001 ZX3 Zetec - Rebuild "The TICK" (
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2004 ZX5 SVT - Restoration "Code Name Rocket" (http://www.focusfanatics.com/forum/showthread.php?t=722698&referrerid=62897)
Magus2727 is online now  
    Reply With Quote