Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - View Single Post - Quick electric question.
View Single Post
Old 09-25-2017, 08:36 AM   #14
Magus2727
Thats What She Said
 
Magus2727's Avatar
 
Join Date: Feb 2009
Fan#: 62897
Location: Salt Lake City, UT
What I Drive: 2001 MB ZX3, 2004 SY SVT ZX5

Posts: 10,473
Points 20,697, Level 90
Points: 20,697, Level: 90 Points: 20,697, Level: 90 Points: 20,697, Level: 90
Level Up 70% Completed
Level up: 70% Level up: 70% Level up: 70%
Forum Activity 100%
Activity: 100% Activity: 100% Activity: 100%
FF Reputation: 23 Magus2727 Great Standing Member
Buy-Sell-Trade Rating: (2)
That does sound possibly like Alternator then. Not that it's your blower fan it has nothing to do with the A/C as I blows with heat, vent, A/C...

Sorry for nit picking but when trying to diagnose over the internet....

You might have a bad battery also. Would recommend it to get tested. Your battery should be able to maintain voltage to run all the components. With Alternator drop out. My Alternator burnt out and started having some weird gauge behavior. Don't recall if any other electrics went out but belive it was isolated to the gauge cluster and possibly the radio.
__________________
2001 ZX3 Zetec - Rebuild "The TICK" (
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2004 ZX5 SVT - Restoration "Code Name Rocket" (http://www.focusfanatics.com/forum/showthread.php?t=722698&referrerid=62897)
Magus2727 is online now  
    Reply With Quote