Snapped off O2 Sensors - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 03-26-2004, 10:43 AM   #1
Focus Enthusiast
 
Join Date: Mar 2004
Fan#: 4805
Location: Denver, PA
What I Drive: 2003 Sonic Blue 5-Door

Posts: 78
FF Reputation: 1 Sonic SVT Good Standing Member
Buy-Sell-Trade Rating: (1)
Snapped off O2 Sensors

Hit a pothole in New York City(going about 10 miles per hour) and....
Bent my exhaust back enough to snap off both O2 sensors and bend some brackets.

FYI: It's Not covered under warrantee due to this being caused by a road hazard.

Why the hell don't these things have a skid plate !?


Sonic SVT is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-26-2004, 10:46 AM   #2
Focus Enthusiast
 
Join Date: Dec 2003
Fan#: 1999
Location: Virginia Beach
What I Drive: 04 Mazda 3 hatch 2.3 mtx

Posts: 245
FF Reputation: 1 sixty9oz Good Standing Member
Buy-Sell-Trade Rating: (0)
Man that sucks. Only 10 miles per hour. Geez.
sixty9oz is offline  
    Reply With Quote Quick reply to this message
Old 03-26-2004, 11:00 AM   #3
Focus Fanatic
 
smoknzx3's Avatar
 
Join Date: Jan 2004
Fan#: 2599
Location: Mountain Home ID
What I Drive: you crazy!

Posts: 1,900
FF Reputation: 1 smoknzx3 Good Standing Member
Buy-Sell-Trade Rating: (0)
that must have been some pot hole!
__________________
Some people are like slinkies... They are not really good for anything, but... They still bring a smile to your face when you push them down a flight of stairs.
smoknzx3 is offline  
    Reply With Quote Quick reply to this message
Old 03-26-2004, 11:01 AM   #4
Focus Fanatic
 
smoknzx3's Avatar
 
Join Date: Jan 2004
Fan#: 2599
Location: Mountain Home ID
What I Drive: you crazy!

Posts: 1,900
FF Reputation: 1 smoknzx3 Good Standing Member
Buy-Sell-Trade Rating: (0)
It's all stock? If it is won't hurt to bring it to the dealer and tell them "I"m not sure what happened" MIght get it fixed
__________________
Some people are like slinkies... They are not really good for anything, but... They still bring a smile to your face when you push them down a flight of stairs.
smoknzx3 is offline  
    Reply With Quote Quick reply to this message
Old 03-27-2004, 07:46 AM   #5
Focus Enthusiast
 
Join Date: Mar 2004
Fan#: 4805
Location: Denver, PA
What I Drive: 2003 Sonic Blue 5-Door

Posts: 78
FF Reputation: 1 Sonic SVT Good Standing Member
Buy-Sell-Trade Rating: (1)
Well, I had both sensors in and exhaust put back where it should be, cleared the codes and my check engine light is still on?
This is getting old quick.
It's going in for a re-flash Monday. If this doesn't fix my problem with the check engine light and my continuing surging/sputtering problem , I don't know what I'm gonna do.
The car only has 9,000 miles on it.
I still regret getting rid of my Cobra
__________________
03 Sonic Blue 5-Door
Mods:
Steeda Short Ram, Steeda Tri-ax,
1FUNSVT license plate,Ford Racing Tails, Full Bra and Hood Mask, OBX Clear Corners,Custom Grill Lights, 17" DR-4's w/Toyo FZR 225/45/17
Sonic SVT is offline  
    Reply With Quote Quick reply to this message
Old 03-27-2004, 07:54 PM   #6
Focus Rookie
 
Join Date: Mar 2004
Fan#: 5411
Location: Houston,Tx
Posts: 14
FF Reputation: 1 lurk Good Standing Member
Buy-Sell-Trade Rating: (0)
I had the same problem and I have replaced my o2's myself but they clearance is a little close to the tranny now, i'm thinking I bent the header up toward the oil pan. Ford would not do any type of reflash to the ecu unless the cel has been fixed, i'm thinking I blew the header gasket or the flange gasket and have a nice little leak. That might be your problem also.
lurk is offline  
    Reply With Quote Quick reply to this message
Old 03-27-2004, 09:51 PM   #7
Focus Enthusiast
 
Join Date: Mar 2004
Fan#: 4805
Location: Denver, PA
What I Drive: 2003 Sonic Blue 5-Door

Posts: 78
FF Reputation: 1 Sonic SVT Good Standing Member
Buy-Sell-Trade Rating: (1)
The header was removed and re-bent to it's original shape. All of the gaskets were replaced.
I told dealership I do NOT want the car back until all of my problems are fixed.
The sputter/ surging problem has been on going since a week after I got the car. The check engine light has been on for over a month.
__________________
03 Sonic Blue 5-Door
Mods:
Steeda Short Ram, Steeda Tri-ax,
1FUNSVT license plate,Ford Racing Tails, Full Bra and Hood Mask, OBX Clear Corners,Custom Grill Lights, 17" DR-4's w/Toyo FZR 225/45/17
Sonic SVT is offline  
    Reply With Quote Quick reply to this message
Old 03-27-2004, 11:24 PM   #8
Focus Rookie
 
Join Date: Mar 2004
Fan#: 5411
Location: Houston,Tx
Posts: 14
FF Reputation: 1 lurk Good Standing Member
Buy-Sell-Trade Rating: (0)
Have you checked what code you are threwing? Did ford bend it back for you? I would think that they would just replace it. I really need to get this done soon because I can't get rid of my 02 codes
lurk is offline  
    Reply With Quote Quick reply to this message
Old 04-02-2004, 06:37 AM   #9
Focus Enthusiast
 
Join Date: Mar 2004
Fan#: 4805
Location: Denver, PA
What I Drive: 2003 Sonic Blue 5-Door

Posts: 78
FF Reputation: 1 Sonic SVT Good Standing Member
Buy-Sell-Trade Rating: (1)
Good news!
Got the car back last night and it feels completely different. Turns out the Check engine thing was a fuse that burnt when both O2 sensors went. Got the re-flash and now there is absolutely no sputter, surging or hesitation even when cold.
__________________
03 Sonic Blue 5-Door
Mods:
Steeda Short Ram, Steeda Tri-ax,
1FUNSVT license plate,Ford Racing Tails, Full Bra and Hood Mask, OBX Clear Corners,Custom Grill Lights, 17" DR-4's w/Toyo FZR 225/45/17
Sonic SVT is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2004, 12:54 AM   #10
Focus Rookie
 
Join Date: Mar 2004
Fan#: 5411
Location: Houston,Tx
Posts: 14
FF Reputation: 1 lurk Good Standing Member
Buy-Sell-Trade Rating: (0)
Did they say which fuse? I think I have the same problem because I can't get rid of my cel. You were throwing the code for the 02's right? not a fuse? Let me know cuz I really want to get rid of that cel.
lurk is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Timing / Knock sensors /Engine Failure 1turbofocus Focus-Power Tuning 25 01-05-2008 12:44 PM
Sensors Data stream Logger for Ford Focus 2007 mbadarna General Technical Chat 0 12-03-2007 06:18 AM
Pinpointing an O2 Sensor problem DerekNJND General Technical Chat 17 03-16-2007 10:07 AM
'03 ZTS Fails OBDII state inspection- 5 sensors not ready- NO CEL or issues-- HELP! Me1Magoo General Technical Chat 2 12-17-2006 02:22 PM
Got both o2 Sensors Replaced Today... TheWevel SVT Performance (2002-2004) 9 10-22-2004 02:13 AM


All times are GMT -5. The time now is 05:00 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1