Broken DSI Clip Society Poll - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

View Poll Results: Broken DSI Clip Society Poll
Yes - Just replaced clip with Ford part 7 7.14%
Yes - Had intake replaced 11 11.22%
Yes - Replaced with aftermarket clip 17 17.35%
No - No problems I'm aware of 63 64.29%
Voters: 98. You may not vote on this poll

Reply




 
LinkBack Thread Tools Display Modes
Old 01-27-2006, 06:42 AM   #1
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 390
Location: Clearwater, FL
What I Drive: '02 SVTF #4241

Posts: 30
Points 185, Level 3
Points: 185, Level: 3 Points: 185, Level: 3 Points: 185, Level: 3
Level Up 70% Completed
Level up: 70% Level up: 70% Level up: 70%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 mchedd Good Standing Member
Buy-Sell-Trade Rating: (0)
Broken DSI Clip Society Poll

Now that I've joined the ranks of the dreaded Broken DSI Clip Society, I'd like to see how many of us are members and what 1st prompted you to realize the clip was broken.

Also please indicate if the clip was the only part replaced.

If you're not sure what the DSI clip is please see this post: "How To" Broken DSI Clip Fix
Thanks Sleestack for the great post


__________________
Mike
'02 SVTF #4241
mchedd is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-27-2006, 03:59 PM   #2
Focus Enthusiast
 
Join Date: Jul 2004
Fan#: 10259
Location: Ohio
What I Drive: 02 SVTF

Posts: 114
FF Reputation: 1 quicksilver Good Standing Member
Buy-Sell-Trade Rating: (0)
Mine broke, but I made one to replace it.
I suspected something when I didn't here my DSI kick over when I 1st started the car. It also seemed abnormally quiet when at idle.
quicksilver is offline  
    Reply With Quote Quick reply to this message
Old 01-27-2006, 05:48 PM   #3
on thin air
 
..:: sleestak ::..'s Avatar
 
Join Date: Apr 2005
Fan#: 22528
Location: The Lou, MO
What I Drive: 04 Forester XTi

Posts: 3,619
Points 14,891, Level 79
Points: 14,891, Level: 79 Points: 14,891, Level: 79 Points: 14,891, Level: 79
Level Up 9% Completed
Level up: 9% Level up: 9% Level up: 9%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 80 ..:: sleestak ::.. Excellent Standing Member
Buy-Sell-Trade Rating: (15)
I first read the post about the DSI clip breaking and started noticing the engine wasnt changing its tone at higher rpms, so I took a look and sure as sh!t, it was just hanging there.....the plastic post on that the clip hooks onto had broken off.

I read someones post about how they fixed it (no pics) and did the same myself, this time taking pics and making a how-to (now stickied). Since I fixed it, I have had no problems and beat on it regularly (my car you pervs).
__________________
..:: sleestak ::..

"Our mother of blessed accelleration, dont fail us now!" -- Elwood Blues
..:: sleestak ::.. is offline  
    Reply With Quote Quick reply to this message
Old 01-28-2006, 04:01 PM   #4
Focus Jr. Enthusiast
 
Join Date: Oct 2005
Fan#: 28397
Location: Quakertown, PA
What I Drive: 04 zx5 svt silver

Posts: 33
FF Reputation: 1 ajbeer-svt Good Standing Member
Buy-Sell-Trade Rating: (0)
I have an 04 svt with 40k on her. I dsi clip did not go yet. Should I expect it to break soon?
Andrew
ajbeer-svt is offline  
    Reply With Quote Quick reply to this message
Old 01-28-2006, 06:27 PM   #5
Focus Jr. Enthusiast
 
Join Date: Apr 2005
Fan#: 22205
Location: North Carolina
What I Drive: 2003 CD Silver SVT 4dr

Posts: 41
FF Reputation: 1 focusrocker Good Standing Member
Buy-Sell-Trade Rating: (0)
does a CEL com on when the clip breaks?
can you see if it is broken with out taking stuff apart?
focusrocker is offline  
    Reply With Quote Quick reply to this message
Old 01-28-2006, 06:27 PM   #6
Focus Enthusiast
 
davlafont's Avatar
 
Join Date: Dec 2004
Fan#: 16413
Location: Nawth Joisey
What I Drive: 2002 SVT Focus

Posts: 62
FF Reputation: 1 davlafont Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally posted by ..:: sleestak ::..
I first read the post about the DSI clip breaking and started noticing the engine wasnt changing its tone at higher rpms, so I took a look and sure as sh!t, it was just hanging there.....the plastic post on that the clip hooks onto had broken off.
Ditto.
__________________
Dave
2002 SVTFocus #2629
SVT Squad #106
Visit Dave's Daily Driver
davlafont is offline  
    Reply With Quote Quick reply to this message
Old 01-29-2006, 08:52 AM   #7
Focus Enthusiast
 
Join Date: Jul 2004
Fan#: 10259
Location: Ohio
What I Drive: 02 SVTF

Posts: 114
FF Reputation: 1 quicksilver Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
I have an 04 svt with 40k on her. I dsi clip did not go yet. Should I expect it to break soon?
That's a small miracle that it has lasted that long. It will happen. Unless you have an extended warantee, you should go buy the revised part and replace the old one when you have a chance to avoid any problems.


Quote:
does a CEL com on when the clip breaks?
I think for most it doesn't unless the "door" on the DSI gets stuck in a funky positions that screws up air flow so bad that the car won't run right. If that does happen you won't need a light to tell you something is up!

Yes you can see it w/o taking stuff apart, but it is tough to get the right view point.
quicksilver is offline  
    Reply With Quote Quick reply to this message
Old 01-29-2006, 07:24 PM   #8
Focus Enthusiast
 
roy-mikesvt's Avatar
 
Join Date: Feb 2004
Fan#: 4225
Location: dallas tx
What I Drive: 05 Mazdaspeed Miata

Posts: 288
FF Reputation: 1 roy-mikesvt Good Standing Member
Buy-Sell-Trade Rating: (0)
I checked mine today (again) and it looks intact ..Lets hope it stays what way...
__________________
05 Mazdaspeed MX-5 Black Mica Stock-Turbo
roy-mikesvt is offline  
    Reply With Quote Quick reply to this message
Old 01-30-2006, 07:30 AM   #9
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 390
Location: Clearwater, FL
What I Drive: '02 SVTF #4241

Posts: 30
Points 185, Level 3
Points: 185, Level: 3 Points: 185, Level: 3 Points: 185, Level: 3
Level Up 70% Completed
Level up: 70% Level up: 70% Level up: 70%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 mchedd Good Standing Member
Buy-Sell-Trade Rating: (0)
focusrocker - As far as I know- the CEL will not light up. My is lit now because the tech disconnected the DSI actuator so it wouldn't cycle.

ajbeer-svt I'm not sure if the '04's have the upgraded clip. I only have 31K on my '02 SVTF. I'd advise ordering one either thru your dealer's parts dept. or from CFM - http://focus.c-f-m.com/index.asp?Pag...ROD&ProdID=997

Thanks for all the input gang. Just hate it when alot of folks have the same problems but nothing is done to rectify the issue until a bunch of folks start complaining about mis-engineered parts.

Again - Kudos to Sleestak for the great pics.
__________________
Mike
'02 SVTF #4241
mchedd is offline  
    Reply With Quote Quick reply to this message
Old 01-30-2006, 08:51 PM   #10
Focus Enthusiast
 
Join Date: Jul 2004
Fan#: 10259
Location: Ohio
What I Drive: 02 SVTF

Posts: 114
FF Reputation: 1 quicksilver Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Just hate it when alot of folks have the same problems but nothing is done to rectify the issue until a bunch of folks start complaining about mis-engineered parts.
Ya, Ford wonders why they are losing market share. On most Honda's if they have a design defect they fix it no questions asked... even out of warantee!

I will say at least Ford isn't trying to bend us over on the part cost. If that is a die cast part, they aren't making much if any money in it for $9.
quicksilver is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:55 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1