I either screwed up or my car did - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 03-11-2005, 05:28 PM   #1
Focus Enthusiast
 
no_peg's Avatar
 
Join Date: Feb 2005
Fan#: 18993
Location: Flagstaff, AZ
What I Drive: '02 Sonic Blue SVT

Posts: 481
FF Reputation: 1 no_peg Good Standing Member
Buy-Sell-Trade Rating: (1)
Unhappy I either screwed up or my car did

Okay leaving for lunch today my car kind of studdered and the battery light came on, than everything was fine after that. I parked it right after the event and popped the hood to have a look. everything seemd in order so we drove off and everything has been fine since. I'm thinking I either eased off the clutch a little without noticing or something is wrong and i'm not sure what it is. This happen to anybody else? I'm really kind of paranoid about my car and this is still worrying me even though ever since then it's been fine. please help!


__________________
'02 Sonic Blue Focus SVT ZX3: 2 JLaudio 12" subs, RF 800 watt amp, RF 500 watt amp, MB Quart tweeters...WOOOOEEEE!
Performance: Custom catback exhaust, FS front strut bar, K&N Typhoon short ram intake, Eibach Pro Kit springs, Port and Polished head
no_peg is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-11-2005, 06:11 PM   #2
The Librarian
 
WD40's Avatar
 
Join Date: Mar 2004
Fan#: 5157
Location: Helena, MT
What I Drive: '04 Sonic Blue - SVT 3Door

Posts: 13,116
FF Reputation: 138 WD40 Excellent Standing Member WD40 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
At the least, check your battery cables and grounds.
It also wouldn't hurt to pull cables off the battery, and clean the posts to make sure they're getting a good connection.

Got a voltmeter?
Check out the voltage while it's running.
Should be around 13.8 volts at ~1,500rpm.
WD40 is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 06:15 PM   #3
Focus Enthusiast
 
no_peg's Avatar
 
Join Date: Feb 2005
Fan#: 18993
Location: Flagstaff, AZ
What I Drive: '02 Sonic Blue SVT

Posts: 481
FF Reputation: 1 no_peg Good Standing Member
Buy-Sell-Trade Rating: (1)
Ya I checked all the wires and connections (basic stuff, i'm not a complete idiot ) and everything seemed fine, great actually, nothing was even somewhat loose! Right after It happened I thought "oh *****, my alternator is going out!", and I expected it to die right there but it didn't. I pulled into a nearby parking spot and turned it off. Than I thought it was my batter but than I Restarted it after checking everything and it was back to normal. Thats why I think/ hope I let off of the clutch just a little and didn't realize, but I just want to be sure!

edit: Oh ya and no I don't have a voltmeter, but I could bring it into checker or autozone tomorrow.
__________________
'02 Sonic Blue Focus SVT ZX3: 2 JLaudio 12" subs, RF 800 watt amp, RF 500 watt amp, MB Quart tweeters...WOOOOEEEE!
Performance: Custom catback exhaust, FS front strut bar, K&N Typhoon short ram intake, Eibach Pro Kit springs, Port and Polished head

Last edited by no_peg; 03-11-2005 at 06:21 PM.
no_peg is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 06:23 PM   #4
The Librarian
 
WD40's Avatar
 
Join Date: Mar 2004
Fan#: 5157
Location: Helena, MT
What I Drive: '04 Sonic Blue - SVT 3Door

Posts: 13,116
FF Reputation: 138 WD40 Excellent Standing Member WD40 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Something I forgot to mention, and seeing your's is an '02....
Have you had any "flash" updates done at the Dealer?
What you're describing sounds like one of the symptoms.

Here's what the TSB says, and you would be looking at getting a YRF0 reflash at the Dealer.
Clicky
Note where it says:
"Low RPM/RPM Dips" and "Battery Lamp Flicker"
There's also a link in that post to the text of the TSB (03-19-11)
WD40 is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 06:30 PM   #5
Focus Enthusiast
 
svtfocus2k4's Avatar
 
Join Date: Nov 2004
Fan#: 15709
Location: Oklahoma, OK
What I Drive: 2004 SB SVTF 2003 DSG Cobra

Posts: 397
FF Reputation: 1 svtfocus2k4 Good Standing Member
Buy-Sell-Trade Rating: (10)
At times. When coming to a stop with my car out of gear it will stutter, the battery light will come on, and maybe even die. I dont know if it is due to the plugs being "gapped" too far or my custom tune.
svtfocus2k4 is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 06:31 PM   #6
Focus Enthusiast
 
no_peg's Avatar
 
Join Date: Feb 2005
Fan#: 18993
Location: Flagstaff, AZ
What I Drive: '02 Sonic Blue SVT

Posts: 481
FF Reputation: 1 no_peg Good Standing Member
Buy-Sell-Trade Rating: (1)
K cool thanks a lot man! My car doesn't do any of those other things thank god! I'm gonna wait another day or so and see if it happens again, if it doesn't than I can safely say that it was my stupid self. But in the meantime i'm gonna get the voltage checked on my battery. Thanks again!
__________________
'02 Sonic Blue Focus SVT ZX3: 2 JLaudio 12" subs, RF 800 watt amp, RF 500 watt amp, MB Quart tweeters...WOOOOEEEE!
Performance: Custom catback exhaust, FS front strut bar, K&N Typhoon short ram intake, Eibach Pro Kit springs, Port and Polished head
no_peg is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 06:48 PM   #7
Regulator...mount up
 
PapoSwing's Avatar
 
Join Date: Feb 2004
Fan#: 3062
Location: Zombieland, United States
What I Drive: 03 Pitch Black SVT

Posts: 3,025
Points 5,930, Level 49
Points: 5,930, Level: 49 Points: 5,930, Level: 49 Points: 5,930, Level: 49
Level Up 90% Completed
Level up: 90% Level up: 90% Level up: 90%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 28 PapoSwing Great Standing Member
Buy-Sell-Trade Rating: (10)
Mine did the exact same thing before I got the YRF0 flash. Hasn't done it since!
PapoSwing is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 07:30 PM   #8
Focus Enthusiast
 
no_peg's Avatar
 
Join Date: Feb 2005
Fan#: 18993
Location: Flagstaff, AZ
What I Drive: '02 Sonic Blue SVT

Posts: 481
FF Reputation: 1 no_peg Good Standing Member
Buy-Sell-Trade Rating: (1)
Can I get the flash done at the dealership?
__________________
'02 Sonic Blue Focus SVT ZX3: 2 JLaudio 12" subs, RF 800 watt amp, RF 500 watt amp, MB Quart tweeters...WOOOOEEEE!
Performance: Custom catback exhaust, FS front strut bar, K&N Typhoon short ram intake, Eibach Pro Kit springs, Port and Polished head
no_peg is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 09:16 PM   #9
Focus Enthusiast
 
OSSO002's Avatar
 
Join Date: Jun 2004
Fan#: 9731
Location: WA
What I Drive: 2003 Piranha (OS2i4)

Posts: 380
FF Reputation: 1 OSSO002 Good Standing Member
Buy-Sell-Trade Rating: (1)
That's the only place that will do the yrf0 I think
OSSO002 is offline  
    Reply With Quote Quick reply to this message
Old 03-11-2005, 10:51 PM   #10
HTPerformance
Guest
 
Fan#:
Posts: n/a
on a side not have any of you noticed the Odometer LCD flickering???

(specifically at night when lit up - the green twitches...)

Brian
 
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:54 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1