front O2 sensor (yes I searched) - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply
 
LinkBack Thread Tools Display Modes
Old 05-09-2013, 03:21 PM   #1
coooookie monster
 
wordyahurdd's Avatar
 
Join Date: Nov 2006
Fan#: 41401
Location: Novi / Auburn Hills, MI
What I Drive: 13'ST, 04'SVT, 03'XB9s

Posts: 7,021
Points 14,701, Level 78
Points: 14,701, Level: 78 Points: 14,701, Level: 78 Points: 14,701, Level: 78
Level Up 63% Completed
Level up: 63% Level up: 63% Level up: 63%
Forum Activity 18%
Activity: 18% Activity: 18% Activity: 18%
FF Reputation: 7 wordyahurdd Good Standing Member
Buy-Sell-Trade Rating: (16)
front O2 sensor (yes I searched)

Currently my Bosch sensor has gone bad after 3 years (rear has 02 cheater installed) so I ordered a new OEM sensor.

Motorcraft
5C5Z-9F472-BA
DY-1040

However I just tried to install and it was a few inches too short.
I have the CFM HFC installed, would that cause an issue?

Also I just hit a big pot hole a few weeks ago (bent a rim) and may have scrapped the cat on the ground during this event, would a slightly damaged CAT cause the O2 to go bad?


__________________
2013 ST(3)
2004 SVT : #55 STF (now racecar)
2003 Buell XB9S
wordyahurdd is online now  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-09-2013, 06:26 PM   #2
I used to drive this
 
macdiesel's Avatar
 
Join Date: Jan 2006
Fan#: 31579
Location: Chicago, IL
What I Drive: 2010 red mazdaspeed3 w/tech package

Posts: 3,332
Points 4,266, Level 41
Points: 4,266, Level: 41 Points: 4,266, Level: 41 Points: 4,266, Level: 41
Level Up 58% Completed
Level up: 58% Level up: 58% Level up: 58%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 22 macdiesel Great Standing Member
Buy-Sell-Trade Rating: (17)
It's probably because the 02 sensor is on the other side of the cat. You might be able to get a few more inches by pulling the wire harnass connected on the fan shroud to get few more inches. I think that's what I did and zip tied the harnass so it wouldn't contact the exhaust.
__________________
I now drive a Japanese Ford.
macdiesel is offline  
    Reply With Quote Quick reply to this message
Old 05-09-2013, 07:22 PM   #3
GT40 all the things!
 
disciplerocks's Avatar
 
Join Date: Sep 2008
Fan#: 59330
Location: Evansville, IN
What I Drive: 04 ZX3, 12 Hatch

Posts: 9,443
Points 13,460, Level 75
Points: 13,460, Level: 75 Points: 13,460, Level: 75 Points: 13,460, Level: 75
Level Up 53% Completed
Level up: 53% Level up: 53% Level up: 53%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 13 disciplerocks Great Standing Member
Buy-Sell-Trade Rating: (17)
When I replaced mine, the pigtail was a few inches too short as well. I just spliced a male and female pigtail together to make an extension.
__________________
04 ZX3 Mostly Stock ["Best Non-SVT" FITF '12][3/13 ROTM][7/14 ROTM][2014 ROTY]
12 SE Hatch Sport & Winter Package, ST Front End
94 F150 XLT 5.0 HO, OBDII Swap
89 Bronco II XLT Crawler
disciplerocks is offline  
    Reply With Quote Quick reply to this message
Old 05-10-2013, 04:12 PM   #4
Focus Enthusiast
 
Join Date: May 2005
Fan#: 23315
Location: SF Bay Area, CA
What I Drive: 04 SVT PWSC EAP

Posts: 270
Points 697, Level 13
Points: 697, Level: 13 Points: 697, Level: 13 Points: 697, Level: 13
Level Up 94% Completed
Level up: 94% Level up: 94% Level up: 94%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 5 shlbygt Good Standing Member
Buy-Sell-Trade Rating: (3)
That's odd, I've found just the opposite. My Bosch sensor wires were short and the Motorcraft sensor was the same as the original. This is on a CFM HFC as well.
shlbygt is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:52 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1