Electrical button related flicker - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply
 
LinkBack Thread Tools Display Modes
Old 11-21-2012, 02:15 AM   #1
Focus Jr. Enthusiast
 
Join Date: Jan 2012
Fan#: 93471
Location: Cincinnati, OH
What I Drive: 2002 SB SVT #3729

Posts: 44
FF Reputation: 1 SVT513 Good Standing Member
Buy-Sell-Trade Rating: (1)
Electrical button related flicker

My SVT's odometer area on the gauge cluster and headlights flicker if i click any of the electrical buttons inside the car. (horn, window buttons, etc)

I just recently realized it while i was parking and had the headlights on and clicked the window up buttons to make sure the windows were up before i got out of the car. That was when i saw the connection that every click of a button- resulted in a flicker of the headlights and gauge cluster area.

Little background- About 3 months ago, i bought a big 3 upgrade kit from Ray and installed the 2 grounds only. Still havent gotten around to doing the upgraded postive cable. Also, the car is still stock...nothing extra added to the electrical system that would pull more energy from the car/alternator/battery.

Before i bought the car, about a year and a half ago- the alternator was replaced.

My thoughts: BAD/defective alternator, bad ground connection, not installing the upgraded positive cable yet, or jacked up wiring.

What do you guys think?




Thanks guys as always!


SVT513 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-21-2012, 07:02 AM   #2
Focus Fanatic
 
jwill2489's Avatar
 
Join Date: Sep 2010
Fan#: 78236
Location: Dearborn Heights, MI
What I Drive: 2003 SVT JRSC w/BBK

Posts: 4,656
Points 3,488, Level 36
Points: 3,488, Level: 36 Points: 3,488, Level: 36 Points: 3,488, Level: 36
Level Up 92% Completed
Level up: 92% Level up: 92% Level up: 92%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 4 jwill2489 Good Standing Member
Buy-Sell-Trade Rating: (0)
mines been doing it for quite a while. had everything tested and its all fine. no idea
jwill2489 is offline  
    Reply With Quote Quick reply to this message
Old 11-26-2012, 09:08 AM   #3
Focus Enthusiast
 
smallblockfever's Avatar
 
Join Date: Feb 2012
Fan#: 95004
Location: Baton Rouge, LA
What I Drive: 2002 Sonic Blue SVT

Posts: 242
Points 2,550, Level 30
Points: 2,550, Level: 30 Points: 2,550, Level: 30 Points: 2,550, Level: 30
Level Up 67% Completed
Level up: 67% Level up: 67% Level up: 67%
Forum Activity 8%
Activity: 8% Activity: 8% Activity: 8%
FF Reputation: 0 smallblockfever Newbie
Buy-Sell-Trade Rating: (1)
I have a similar problem, i believe it is the volatge regulator. Im interested to see what it ends up being for you. Wish i could help.
smallblockfever is offline  
    Reply With Quote Quick reply to this message
Old 11-26-2012, 09:41 PM   #4
Focus Enthusiast
 
SWEGER's Avatar
 
Join Date: Aug 2011
Fan#: 88926
Location: Fort Leonard Wood, MO
What I Drive: 2003 Infra-Red ZX5 SVT

Posts: 193
Points 887, Level 15
Points: 887, Level: 15 Points: 887, Level: 15 Points: 887, Level: 15
Level Up 87% Completed
Level up: 87% Level up: 87% Level up: 87%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 SWEGER Good Standing Member
Buy-Sell-Trade Rating: (1)
Mine has been kind of going from bright to dim and back and forth for a while now. Had a new battery, alternator, and pigtail installed in January. No idea what is causing this. It seems to not do it at 3000+ RPMs, or after a while of driving.
__________________
2003 Infra-Red ZX5 SVT - Cheap Spectre intake (don't judge, was on there when I got it), Hawk HPS pads front/rear, Russell SS lines, Goodyear Eagle GT 215/45/17

"If guns cause violence, then all of mine are defective" - Ted Nugent
SWEGER is offline  
    Reply With Quote Quick reply to this message
Old 11-27-2012, 06:52 AM   #5
Focus Enthusiast
 
StephenElsbree1986's Avatar
 
Join Date: Sep 2012
Fan#: 104271
Location: BRightwood, VA
What I Drive: CD Silver 2003 SVT

Posts: 367
Points 1,199, Level 18
Points: 1,199, Level: 18 Points: 1,199, Level: 18 Points: 1,199, Level: 18
Level Up 99% Completed
Level up: 99% Level up: 99% Level up: 99%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 StephenElsbree1986 Good Standing Member
Buy-Sell-Trade Rating: (0)
Alternator related
StephenElsbree1986 is offline  
    Reply With Quote Quick reply to this message
Old 12-02-2012, 05:46 PM   #6
Focus Enthusiast
 
SWEGER's Avatar
 
Join Date: Aug 2011
Fan#: 88926
Location: Fort Leonard Wood, MO
What I Drive: 2003 Infra-Red ZX5 SVT

Posts: 193
Points 887, Level 15
Points: 887, Level: 15 Points: 887, Level: 15 Points: 887, Level: 15
Level Up 87% Completed
Level up: 87% Level up: 87% Level up: 87%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 SWEGER Good Standing Member
Buy-Sell-Trade Rating: (1)
Thanks. Good thing it has a lifetime warranty from Auto Zone then...I'll go have them check it. Too bad it was a pain in the butt (time consuming, and that damn serpentine belt) to change.
__________________
2003 Infra-Red ZX5 SVT - Cheap Spectre intake (don't judge, was on there when I got it), Hawk HPS pads front/rear, Russell SS lines, Goodyear Eagle GT 215/45/17

"If guns cause violence, then all of mine are defective" - Ted Nugent
SWEGER is offline  
    Reply With Quote Quick reply to this message
Old 12-07-2012, 10:35 AM   #7
Focus Jr. Enthusiast
 
Join Date: Jan 2012
Fan#: 93471
Location: Cincinnati, OH
What I Drive: 2002 SB SVT #3729

Posts: 44
FF Reputation: 1 SVT513 Good Standing Member
Buy-Sell-Trade Rating: (1)
Are you sure you can just point this this alternator related? I have a brand new alternator and it measures the correct voltages.

I think it has to be something else, my car is showing ZERO signs of a bad alternator...only has the above problems. (Original post)
SVT513 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:32 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1