Power Loss - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply
 
LinkBack Thread Tools Display Modes
Old 10-19-2004, 08:39 AM   #1
Focus Fanatic
 
jaykirs's Avatar
 
Join Date: Oct 2004
Fan#: 13947
Location: Houston, Texas
What I Drive: 2004 Infra-Red ZX3 SVT

Posts: 3,860
FF Reputation: 1 jaykirs Good Standing Member
Buy-Sell-Trade Rating: (1)
Power Loss

I did a search and didn't see where anyone else has mentioned this "problem". When I test drove my 04' SVTF, it had a lot of get-up-and-go, especially in the upper RPM range. However, after I took delivery of my vehicle (2 weeks ago) and I have been driving it around, it seems like it has no upper RPM power any more. For example, when I launch off the line at full throtle, I don't feel it pulling very hard and it seems to take a while to reach 7K RPM, and it doesn't feel very energetic at all. Has anyone else noticed this in their car?

The power is flat all the way up to red-line, I don't feel it pulling harder after, say, 4K RPM like I remember. Is it just me or is something wrong with the car? I am using premium fuel btw. Any info will be greatly appreciated, thanks everyone!!


jaykirs is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-19-2004, 09:24 AM   #2
Focus Enthusiast
 
Join Date: Jul 2004
Fan#: 10460
Location: Orange County Florida
What I Drive: 04 Infra-Red focus SVT 3 door #434 of 1978 Born November 11th 2003

Posts: 507
FF Reputation: 1 svt medic Good Standing Member
Buy-Sell-Trade Rating: (0)
Take it to the dealer and tell e'm what your telling us. I would bet,though not from experiance, your second stage runners are not activating or opening up, they do this for more power at 5000 rpm. i have noticed about 5250 on my car or its 5000 and I don't feel it till then.
__________________
With Great Power; Comes great Responsibility!
Drive it like you stole it.....
( V-tec this )
( VVTI This)
(SVT Squad # 198)
svt medic is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2004, 09:50 AM   #3
Focus Jr. Enthusiast
 
Join Date: Jul 2004
Fan#: 11110
Location: Somerset, Kentucky
What I Drive: 2004 Sonic Blue SVT

Posts: 47
FF Reputation: 1 Kyguy Good Standing Member
Buy-Sell-Trade Rating: (0)
Maybe your dsi clip broke?
__________________
2004 Sonic Blue SVT
Kyguy is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2004, 10:06 AM   #4
Focus Enthusiast
 
Join Date: Sep 2004
Fan#: 13118
Location: Lewiston, NY, United States
What I Drive: 2003 InfraRed SVT 5-door, loaded -

Posts: 524
FF Reputation: 1 Fordson Good Standing Member
Buy-Sell-Trade Rating: (0)
If the DSI clip breaks, the intake defaults to the short-runner (high-RPM) position, not the low-RPM position. You would have high-RPM power, but not at low RPM, which is the opposite of what you describe - so I don't know what is wrong with your car.

Another poster told you to take it to the dealer and tell them exactly what you told us. That will result in the dealer saying, "in a car you took delivery of two weeks ago, you're launching at full throttle? Have you ever heard of a break-in period?" They will find a way to blow you off, and this will flag you as a problem owner who is hard on the vehicle, which sounds about right.

This isn't the last issue you're going to be having with the car if you drive it like that.
Fordson is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2004, 10:37 AM   #5
Focus Fanatic
 
jaykirs's Avatar
 
Join Date: Oct 2004
Fan#: 13947
Location: Houston, Texas
What I Drive: 2004 Infra-Red ZX3 SVT

Posts: 3,860
FF Reputation: 1 jaykirs Good Standing Member
Buy-Sell-Trade Rating: (1)
I was using that scenario as an example, I should have said I notice it when I am trying to pass another vehicle on the highway, so no need to be judgementle, the car had almost 600 miles on it when I bought it and now has over 1500 so I think it is "broke in". Anyway, thanks for the help svt medic.
jaykirs is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2004, 11:13 AM   #6
Focus Enthusiast
 
Join Date: Sep 2004
Fan#: 13118
Location: Lewiston, NY, United States
What I Drive: 2003 InfraRed SVT 5-door, loaded -

Posts: 524
FF Reputation: 1 Fordson Good Standing Member
Buy-Sell-Trade Rating: (0)
Dunno - 1500 miles is kind of soon for full-throttle, and I still would not tell the dealer that because you're going to get blown off.

Anyway, what I said before I still maintain - it's not the DSI clip. You would have normal power from 5K to redline with a broken DSI clip, and you are saying that it's a dog at high RPM - so a busted DSI clip is probably not your issue.
Fordson is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2004, 11:21 AM   #7
Focus Enthusiast
 
Wailabod's Avatar
 
Join Date: Sep 2004
Fan#: 13499
Location: seattle
What I Drive: black 02 focus svt

Posts: 178
FF Reputation: 1 Wailabod Good Standing Member
Buy-Sell-Trade Rating: (1)
if it was teh dsi cable you would be hearing a god aweful sound, i just got mine fixed, do you hear any valve clutter, it might be something as simple as a timing problem
__________________
Mods- rear engine mount inserts, home made ground cables, custom exhaust, tri-axle short shifter, and halo projection lights.
Wailabod is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2004, 11:34 AM   #8
Focus Fanatic
 
jaykirs's Avatar
 
Join Date: Oct 2004
Fan#: 13947
Location: Houston, Texas
What I Drive: 2004 Infra-Red ZX3 SVT

Posts: 3,860
FF Reputation: 1 jaykirs Good Standing Member
Buy-Sell-Trade Rating: (1)
No, no valve clatter at all. The car runs just fine except for that issue. Any ideas on how I could find out myself if it is the second stage runners were not activating?
jaykirs is offline  
    Reply With Quote Quick reply to this message
Old 10-19-2004, 12:37 PM   #9
The Librarian
 
WD40's Avatar
 
Join Date: Mar 2004
Fan#: 5157
Location: Helena, MT
What I Drive: '04 Sonic Blue - SVT 3Door

Posts: 13,116
FF Reputation: 138 WD40 Excellent Standing Member WD40 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Any ideas on how I could find out myself if it is the second stage runners were not activating?

From FF member rollout; Clicky here
WD40 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOW TO: Interior swap with power window and locks (over 100 pics) focuzed1 MK1 Interior Mods & Upgrades 11 01-03-2010 07:36 AM
loss of power, hot ambient joshieboy87 General Technical Chat 2 02-02-2008 01:39 PM
Power loss, missfire? bad plugs? kl0kwUrk General Technical Chat 20 01-08-2008 03:16 PM
TREMENDOUS POWER LOSS need HELP..... jfkhan General Car Chat Lounge 9 10-28-2004 03:48 PM
A/C power loss Coastie SVT Performance (2002-2004) 11 05-07-2004 12:11 PM


All times are GMT -5. The time now is 01:06 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1