Engine runs like crap and battery lights on - Page 3 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > SPI Performance (2000-2004)

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply




 
LinkBack Thread Tools Display Modes
Old 12-10-2012, 04:37 PM   #21
Capt. Urn
 
crazy_urn's Avatar
 
Join Date: Dec 2003
Fan#: 1986
Location: Uncharted Waters, CO
What I Drive: 77 F-250, 10 HHR, 08 Outlook

Posts: 5,491
FF Reputation: 5 crazy_urn Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by swagfocuswagon View Post
Okay so I got my coil pack, installed it, major improvement for sure. Still has the light and runs a bit rough still. Gonna say it needs an alternator still. But it does run a lot nicer though!
Alternator is a fairly easy swap. (I should know, I have done three of them... lol) hardest part is getting the new belt on once the alternator is back in.

If you don't have a hanes manual, i would recommend it, they have a pretty good write up for the alternator.
__________________
Defending the reputation of the red-headed step-child of the focus world for far too long.
crazy_urn is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-10-2012, 10:33 PM   #22
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by crazy_urn View Post
Alternator is a fairly easy swap. (I should know, I have done three of them... lol) hardest part is getting the new belt on once the alternator is back in.

If you don't have a hanes manual, i would recommend it, they have a pretty good write up for the alternator.
Oh yeah problem with mine I found is I had to take off my PS pump. Other that that its just a few bolts and wire holding it on lol. The easiest ones are on FWD GM cars. Those are cake.
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Old 12-11-2012, 10:19 AM   #23
Capt. Urn
 
crazy_urn's Avatar
 
Join Date: Dec 2003
Fan#: 1986
Location: Uncharted Waters, CO
What I Drive: 77 F-250, 10 HHR, 08 Outlook

Posts: 5,491
FF Reputation: 5 crazy_urn Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by swagfocuswagon View Post
Oh yeah problem with mine I found is I had to take off my PS pump. Other that that its just a few bolts and wire holding it on lol. The easiest ones are on FWD GM cars. Those are cake.
I am assuming the wagon is not an SPI? I didn't have to remove PS pump on mine.

but the part itself could not be simpler... 4 bolts and an electrical connector, if I remember correctly.
__________________
Defending the reputation of the red-headed step-child of the focus world for far too long.
crazy_urn is offline  
    Reply With Quote Quick reply to this message
Old 12-11-2012, 07:04 PM   #24
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by crazy_urn View Post
I am assuming the wagon is not an SPI? I didn't have to remove PS pump on mine.

but the part itself could not be simpler... 4 bolts and an electrical connector, if I remember correctly.
Mines an SPI. I just had a hell of a time getting mine out for some reason.
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Old 12-11-2012, 07:24 PM   #25
Capt. Urn
 
crazy_urn's Avatar
 
Join Date: Dec 2003
Fan#: 1986
Location: Uncharted Waters, CO
What I Drive: 77 F-250, 10 HHR, 08 Outlook

Posts: 5,491
FF Reputation: 5 crazy_urn Good Standing Member
Buy-Sell-Trade Rating: (2)
Might be a difference in the years... I dunno
__________________
Defending the reputation of the red-headed step-child of the focus world for far too long.
crazy_urn is offline  
    Reply With Quote Quick reply to this message
Old 12-12-2012, 10:36 AM   #26
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by crazy_urn View Post
Might be a difference in the years... I dunno
What year was yours then?
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Old 12-12-2012, 10:42 AM   #27
Capt. Urn
 
crazy_urn's Avatar
 
Join Date: Dec 2003
Fan#: 1986
Location: Uncharted Waters, CO
What I Drive: 77 F-250, 10 HHR, 08 Outlook

Posts: 5,491
FF Reputation: 5 crazy_urn Good Standing Member
Buy-Sell-Trade Rating: (2)
03 sedan.

(still is actually, not just was, lol)
__________________
Defending the reputation of the red-headed step-child of the focus world for far too long.
crazy_urn is offline  
    Reply With Quote Quick reply to this message
Old 12-21-2012, 01:31 PM   #28
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by crazy_urn View Post
03 sedan.

(still is actually, not just was, lol)
Hmmm. Well thats wierd then. Damn Ford lol
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Old 01-11-2013, 03:23 PM   #29
Focus Enthusiast
 
swagfocuswagon's Avatar
 
Join Date: Sep 2012
Fan#: 103591
Location: Dayton, OH
What I Drive: '00 Focus wagon, 96 Cutlass Supreme

Posts: 117
FF Reputation: 1 swagfocuswagon Good Standing Member
Buy-Sell-Trade Rating: (0)
Found the source of my problem. It was a loose plug to one of the injectors. lol
swagfocuswagon is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:01 AM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1