engine light after imrc back on... - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > SPI Performance (2000-2004)

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Reply
 
LinkBack Thread Tools Display Modes
Old 09-09-2004, 01:18 AM   #1
Focus Enthusiast
 
Sohcrev's Avatar
 
Join Date: May 2004
Fan#: 8193
Location: EL PASO, TX
What I Drive: 2003 focus se

Posts: 223
FF Reputation: 1 Sohcrev Good Standing Member
Buy-Sell-Trade Rating: (0)
engine light after imrc back on...

after i had put the swab mod back to stock i had my engine light on.. i never diconnected anything.. it was on for bout two days. and yesterday it quit. should i still take it in to get dyognosed? or just leave it till it comes back on?


Sohcrev is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-09-2004, 02:10 PM   #2
Guest
 
Join Date: Dec 2003
Fan#: 2258
Location: Columbus, OH
What I Drive: 2k SPI-T, with Lentech automatic stuff on it

Posts: 1,326
FF Reputation: 1 waterboy Good Standing Member
Buy-Sell-Trade Rating: (4)
I have seen it do that if your IMRC motor can't return to the fully closed position. The code is something like "IMRC stuck open" . It is because the linkage is bound up or in my case I had misaligned the motor when I reinstalled it. Take it off, clear your codes, and reinstall it and make sure the tabs for the butterfly rod are securely in the notches on the motor flange. It could still be coming a\on because the adjustment screw is keeping the butterflies from fully closing. Try these two things before you freak out. it's not that bad, probably just out of alignment.

Jim
waterboy is offline  
    Reply With Quote Quick reply to this message
Old 09-09-2004, 08:46 PM   #3
Focus Rookie
 
Join Date: Jun 2004
Fan#: 9210
Location: Austin,TX.
What I Drive: 2000 Ford Focus Xtreme SE

Posts: 15
FF Reputation: 1 GOLDX Good Standing Member
Buy-Sell-Trade Rating: (0)
I had the same problem when going back to stock. My EXPERIENCE was a little worse not only did I get the engine light but a shaking or bogging down like no air was getting thru air intake. What I did was disconected the battery. Let it set for 5 to 10 min. and reconnected and no more check engine light. and know more shaking I don't know why that helped the shaking. But I'm not going to complain. I believe by doing that I rebooted the computer to stock parameters.
__________________
GoldXtreme
GOLDX is offline  
    Reply With Quote Quick reply to this message
Old 09-10-2004, 12:01 AM   #4
Focus Enthusiast
 
Sohcrev's Avatar
 
Join Date: May 2004
Fan#: 8193
Location: EL PASO, TX
What I Drive: 2003 focus se

Posts: 223
FF Reputation: 1 Sohcrev Good Standing Member
Buy-Sell-Trade Rating: (0)
i had the shaking and bogging to..... lol but my dumb ass didnt plug the mass air flow sensor back on... after i plugged it in, it was all good. but now it seems to have more power than before... it accelerates faster than ever. my girlfriend and friend noticed the diff.
Sohcrev is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Ultimate 03-09 Focus Thread, SUPER LARGE AMOUNTS OF INFO. honhon DURATEC Performance (2008-2011) 59 08-04-2013 10:41 PM
Replaced Engine and the Engine Light Came On VivaLizVegas Engine & Transmission Swap 4 05-18-2009 03:06 PM
Zetec Engine History microtonal ZETEC Performance (2000-2004) 28 03-30-2009 04:32 PM
Best song lyrics in the world turbovation Movies & Music Fanatics 118 04-11-2008 05:59 AM
Vehicle Maintenence Schedule S2 General Technical Chat 0 05-08-2006 10:57 AM


All times are GMT -5. The time now is 08:22 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.





Search Engine Optimization by vBSEO 3.6.1