instrument cluster problems - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 04-15-2006, 01:11 AM   #1
nobled
Focus Enthusiast
 
nobled's Avatar
 
Join Date: Jul 2004
Fan#: 10271
Location: Orem, Utah
What I Drive: 2003 Light Tundra SE

Posts: 187
FF Reputation: 1 nobled Good Standing Member
Buy-Sell-Trade Rating: (0)
instrument cluster problems

My instrament cluster started acting up. While I'm driving it will some times peg the needles (ie I'll be driving 35 mph and the speedometer will jump up to 140) and then turn off (ie the speedometer will read zero and the odometer turns off) or sometimes it will just turn off and then back on without pegging first. It always comes back on about a second after it does this and works like normal.

It just started doing this yesterday and I haven't changed anything or installed anything in the last month or 2. I was wondering if anyone has seen this or has any ideas on how to fix it.

BTW I have a 2003 Comfort SE without a tach. It has just under 32k miles on it.

Thanks,
Darren


nobled is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2006, 01:21 AM   #2
SkaAddict
Focus Fanatic
 
Join Date: Nov 2003
Fan#: 1690
Posts: 8,262
FF Reputation: 69 SkaAddict Excellent Standing Member
Buy-Sell-Trade Rating: (6)
Still in warranty? If so take it to the dealer...if not I'd say pull the cluster out and make sure its plugged in securely. Other than that...you might be looking at a wiring issue, or something wrong with the computer.
SkaAddict is offline  
    Reply With Quote
Old 04-15-2006, 01:24 AM   #3
nobled
Focus Enthusiast
 
nobled's Avatar
 
Join Date: Jul 2004
Fan#: 10271
Location: Orem, Utah
What I Drive: 2003 Light Tundra SE

Posts: 187
FF Reputation: 1 nobled Good Standing Member
Buy-Sell-Trade Rating: (0)
Unfortunatly my bumper to bumper warranty is up. I only have a powertrain warranty now. I'll try pulling it tomorrow to see if the connections are loose.

BTW I did check to see if any of the fuses are loose and they weren't

Thanks,
Darren
nobled is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:33 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.