P1090 CEL code - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-28-2006, 07:09 PM   #1
lwnslw
Focus Enthusiast
 
Join Date: Feb 2004
Fan#: 3640
Location: Hollywood,Fl, United States
What I Drive: F150

Posts: 302
FF Reputation: 1 lwnslw Good Standing Member
Buy-Sell-Trade Rating: (3)
Angry P1090 CEL code

Need some help from fellow SVT owners....
I have an 02 SVT with many bolt on's and a Predator tune from Tom. Everything has been great for the last year with my love BUT about 2 weeks ago she started losing power in the upper RPM range (5K to 7K) and stumbling real bad. The symptoms only start after the car has been driven for a long period of time. The CEL light came on and gave me a code of P0190 which is the Fuel Rail Pressure sensor. I took her into the dealer where a friend of mine works and no problems showed up on the computer. I went ahead and purchased a new Fuel Rail Pressure Sensor ($78) and installed it BUT the problem persist. I have had all TSB's performed on her in the past ( new manifold, fuel pump, injectors, AFM ) Any and all help/suggestions are welcomed.
Thanks Joe
lwnslw@bellsouth.net


lwnslw is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 10-28-2006, 07:16 PM   #2
SpeedOften
Focus Fanatic
 
SpeedOften's Avatar
 
Join Date: Dec 2003
Fan#: 2139
Location: NH, NY, ME and VA (NAVY), VA
What I Drive: E90 335i, 2002 E53 X5 4.4i

Posts: 2,257
FF Reputation: 28 SpeedOften Great Standing Member
Buy-Sell-Trade Rating: (5)
Did you check the DSI clip if it's losing power in the higher rpms...?
SpeedOften is offline  
    Reply With Quote
Old 10-28-2006, 08:52 PM   #3
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 21,432
FF Reputation: 153 1turbofocus Excellent Standing Member1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
you also may want to clean the MAF sensor carefully and some injector cleaner next

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote
Old 10-29-2006, 01:01 AM   #4
lwnslw
Focus Enthusiast
 
Join Date: Feb 2004
Fan#: 3640
Location: Hollywood,Fl, United States
What I Drive: F150

Posts: 302
FF Reputation: 1 lwnslw Good Standing Member
Buy-Sell-Trade Rating: (3)
Speedoften:
Checked DSI clip and it's fine.
1turbofocus:
Already ran injector cleaner, will try MAF tomorrow.
Thanks for the replys
lwnslw is offline  
    Reply With Quote
Old 10-29-2006, 01:38 PM   #5
edingeek
Focus Addict
 
edingeek's Avatar
 
Join Date: Oct 2003
Fan#: 1152
Location: Las Vegas, NV
What I Drive: 03 SVTf & 00 Xploder AWD 5.0

Posts: 913
FF Reputation: 4 edingeek Good Standing Member
Buy-Sell-Trade Rating: (0)
i dunno, maybe check that the fuel rail is screwed down properly and that all the injectors are pushed in correctly and not a little loose. ?
__________________
- 2003 SVTf ZX3 w/tons of bolt-ons (turbo eventually).
- 2000 Xploder XLT 5.0 AWD w/torquemonster headers, custom dual 2.5" exhaust, MAC CAI, and much more.
- 2010 E350 XLT Super Duty (the wife's bus).
edingeek is online now  
    Reply With Quote
Old 11-01-2006, 11:48 AM   #6
bryan200sx
Focus Enthusiast
 
Join Date: Oct 2005
Fan#: 28814
Location: Miami
What I Drive: 02 SVT

Posts: 90
FF Reputation: 1 bryan200sx Good Standing Member
Buy-Sell-Trade Rating: (2)
bump.........

same problem i already changed out the fuel rail pressure sensor, fuel filter, plugs, wires, and pvc valve.
__________________
1998 Nissan 200sx. - sold

2002 Focus SVT
bryan200sx is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:34 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.