"How To" Broken DSI Clip Fix - Page 4 - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-27-2005, 12:16 PM   #31
Charged SVTF
Was that our exit?!?
 
Charged SVTF's Avatar
 
Join Date: Apr 2005
Fan#: 22047
Location: Palm Beach Gardens, FL
What I Drive: 2002 Sonic Blue Supercharged SVT

Posts: 2,054
FF Reputation: 30 Charged SVTF Great Standing Member
Buy-Sell-Trade Rating: (2)
Well looks like ill be checking my DSI...gas milage has sucked last 3000 miles
__________________
2002 Sonic Blue SVT #246 of 4788 cardomain.com/ride/2483606
- JRSC BBK - Exhaust - Intake - Suspension -
First Place 2007 Season SJR-SCCA Solo and 2007 Rookie of the Year SJR-SCCA #20 SM
Charged SVTF is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-10-2005, 09:27 AM   #32
FORDSVTPARTS
Banned
 
FORDSVTPARTS's Avatar
 
Join Date: Jul 2005
Fan#: 26008
Location: WHITE BEAR LAKE
What I Drive: 2002 SVT FOCUS

Posts: 171
FF Reputation: 4 FORDSVTPARTS Good Standing Member
Buy-Sell-Trade Rating: (2)
One quick update to this repair..... I noticed last weekend that the stud I had made was beginning to pull out of the DSI lever.

I believe this was due to the epoxy I used, I pulled the stud out and cleaned it up and reinstalled it using "JB weld" I think this will result in a much stronger fix.

The regular two part epoxy did last for about 5 or 6 months so it was still not a bad fix.
FORDSVTPARTS is offline  
    Reply With Quote
Old 11-16-2005, 06:00 PM   #33
BCESVT1
Focus Enthusiast
 
Join Date: Jul 2005
Fan#: 25298
Location: Quad Cities, IL
What I Drive: 2004 Mustang Mach 1

Posts: 360
FF Reputation: 1 BCESVT1 Good Standing Member
Buy-Sell-Trade Rating: (1)
Does the ECU throw an error code if your DSI motor or clip is broken? I would think that the check engine light would come on if it senses that the DSI is not opening when it's supposed to.
__________________
2004 Mustang Mach 1
BCESVT1 is offline  
    Reply With Quote
Old 11-17-2005, 09:37 AM   #34
FORDSVTPARTS
Banned
 
FORDSVTPARTS's Avatar
 
Join Date: Jul 2005
Fan#: 26008
Location: WHITE BEAR LAKE
What I Drive: 2002 SVT FOCUS

Posts: 171
FF Reputation: 4 FORDSVTPARTS Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally posted by BCESVT1
Does the ECU throw an error code if your DSI motor or clip is broken? I would think that the check engine light would come on if it senses that the DSI is not opening when it's supposed to.
It will not throw a code if the stud breaks off the lever, At least mine didn't.

It will throw a code if the motor stops functioning.
FORDSVTPARTS is offline  
    Reply With Quote
Old 11-17-2005, 09:47 AM   #35
BCESVT1
Focus Enthusiast
 
Join Date: Jul 2005
Fan#: 25298
Location: Quad Cities, IL
What I Drive: 2004 Mustang Mach 1

Posts: 360
FF Reputation: 1 BCESVT1 Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally posted by FORDSVTPARTS
It will not throw a code if the stud breaks off the lever, At least mine didn't.

It will throw a code if the motor stops functioning.
I think mine is still fine then. It doesn't throw a code and it runs normal.
__________________
2004 Mustang Mach 1
BCESVT1 is offline  
    Reply With Quote
Old 12-15-2005, 12:40 PM   #36
..:: sleestak ::..
on thin air
 
..:: sleestak ::..'s Avatar
 
Join Date: Apr 2005
Fan#: 22528
Location: The Lou, MO
What I Drive: 04 Forester XTi

Posts: 3,596
FF Reputation: 80 ..:: sleestak ::.. Excellent Standing Member
Buy-Sell-Trade Rating: (15)
you should be able to hear that its not working. the sound of the engine changes when it switches over.
__________________
..:: sleestak ::..

"Our mother of blessed accelleration, dont fail us now!" -- Elwood Blues
..:: sleestak ::.. is offline  
    Reply With Quote
Old 01-25-2006, 07:11 PM   #37
mchedd
Focus Jr. Enthusiast
 
Join Date: Sep 2003
Fan#: 390
Location: Clearwater, FL
What I Drive: '02 SVTF #4241

Posts: 30
FF Reputation: 1 mchedd Good Standing Member
Buy-Sell-Trade Rating: (0)
FORDSVTPARTS - You have anymore clips in your inventory? I tried pm'ing you but no-joy.
__________________
Mike
'02 SVTF #4241
mchedd is offline  
    Reply With Quote
Old 01-26-2006, 11:01 AM   #38
FORDSVTPARTS
Banned
 
FORDSVTPARTS's Avatar
 
Join Date: Jul 2005
Fan#: 26008
Location: WHITE BEAR LAKE
What I Drive: 2002 SVT FOCUS

Posts: 171
FF Reputation: 4 FORDSVTPARTS Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally posted by mchedd
FORDSVTPARTS - You have anymore clips in your inventory? I tried pm'ing you but no-joy.
You can e-mail me at FORDSVTPARTS@HOTMAIL.COM I don't know why my PM's don't work.

I am not a vendor here so I can't quote prices.
FORDSVTPARTS is offline  
    Reply With Quote
Old 02-14-2006, 11:31 PM   #39
sveet03
Registered User
 
sveet03's Avatar
 
Join Date: Apr 2004
Fan#: 5810
Location: Londonderry NH
What I Drive: 2003 Infra Red SVT 5dr, 99 R6

Posts: 216
FF Reputation: 1 sveet03 Good Standing Member
Buy-Sell-Trade Rating: (0)
i am pretty sure i have jus fallen a victim to this problem as well. suddenly, while getting thru the "happy range", there was no "happy noise" anymore, not as much steady power, now the RPMs hang when coasting to a stop in neutral down the driveway, spitting/sputtering while idling...it will be ripped apart as soon as its not cold and dark..hopefully this lil quick fix will get me by until the part comes in..or should i say, hopefully this isnt another costly problem
sveet03 is offline  
    Reply With Quote
Old 02-18-2006, 05:27 PM   #40
CrispyBurn
Focus Addict
 
CrispyBurn's Avatar
 
Join Date: Nov 2004
Fan#: 15281
Location: Orlando FL
What I Drive: 2002 Ford Focus SVT / 07 gsx r600

Posts: 738
FF Reputation: 1 CrispyBurn Good Standing Member
Buy-Sell-Trade Rating: (7)
are we actually supposed to hear something when it kicks in? if so what does it sound like? I dont think I'm getting it... which should explain a few things... like why I have no top end...
__________________
Mach HID's, FC shorty antenna, Spec Stage 1, Fidanza flywheel, Kenwood HU, Kenwood Amp, NGK Iridium plugs, steeda tri-ax, tein s-tech springs, black enkei j10 rims, EBC greenstuff pads and rotors, diablo predator tuned by tom, AEM cai
CrispyBurn is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:14 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.