"How To" Broken DSI Clip Fix - Page 11 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 07-19-2009, 04:51 PM   #101
HaveBlue83
Guest
 
Join Date: Oct 2003
Fan#: 1358
Location: Southeast, PA
What I Drive: a car

Posts: 9,476
FF Reputation: 70 HaveBlue83 Excellent Standing Member
Buy-Sell-Trade Rating: (12)
yup, mine just went on the silver SVTF and the car runs crappy. out do to the screw thing i guess.

EDIT: it works. used a nice thick cap screw with wood threads and it's good to go. that lil securing washer is annoying! lol...

Last edited by HaveBlue83; 07-19-2009 at 05:56 PM.
HaveBlue83 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 08-10-2009, 06:02 PM   #102
michael1199
Focus Rookie
 
Join Date: Jul 2009
Fan#: 67491
Location: essex, United Kingdom
What I Drive: 2003 silver st170

Posts: 15
FF Reputation: 1 michael1199 Good Standing Member
Buy-Sell-Trade Rating: (0)
i have had my car for the last 3 months and makes that horrible noise constantly. i have checked the DSI clip and yes it has broken but also the noise is coming from the silver actuator box. If i buy the actuator will this come with the DSI clip? And how easy is it to fix? Will i have to take the whole manifold out? Thanks

Michael
michael1199 is offline  
    Reply With Quote
Old 09-21-2009, 07:33 PM   #103
indy_tony
Focus Rookie
 
Join Date: Mar 2009
Fan#: 63558
Location: Noblesville, Indiana
What I Drive: 2003 Red SVT 5 door

Posts: 4
FF Reputation: 1 indy_tony Good Standing Member
Buy-Sell-Trade Rating: (0)
Just got this noise today on the way home. After doing this fix, I got a just few seconds of the noise followed by the CEL. Looking at the cable, it was barely nudging the lever before it stopped trying to work after about 5 seconds. I later unhooked the cable to see what would happen, and upon start up, it seemed to move the normal amount (and it would keep going non-stop). Sooo, I figure I need a new IMRC. But I wonder, does the clip and IMRC fail at the same time very often? Could the failure of one of those cause the other to break?

Oh yeah, and I assume I'm not going to hurt anything besides my gas milage while driving it this way until I can get it fixed proper?
indy_tony is offline  
    Reply With Quote
Old 01-10-2010, 09:54 PM   #104
jp96921
Focus Rookie
 
jp96921's Avatar
 
Join Date: Nov 2005
Fan#: 29645
Location: Hendersonville, TN
What I Drive: 2003 Pitch Black ZX5 SVT

Posts: 10
FF Reputation: 1 jp96921 Good Standing Member
Buy-Sell-Trade Rating: (0)
Hi, do you still have it?
jp96921 is offline  
    Reply With Quote
Old 01-14-2010, 04:20 PM   #105
SquirrelZX3
your killing my fun
 
SquirrelZX3's Avatar
 
Join Date: Apr 2006
Fan#: 34544
Location: Dover, DE, DE
What I Drive: 1995 shitbox neon red

Posts: 3,090
FF Reputation: 18 SquirrelZX3 Great Standing Member
Buy-Sell-Trade Rating: (10)
my car came with a extra dsi clip in the glove box
__________________
United States Army Honorable Discharge
Attending UTI and driving a pos beater mopar
SquirrelZX3 is offline  
    Reply With Quote
Old 01-26-2010, 11:04 AM   #106
jp96921
Focus Rookie
 
jp96921's Avatar
 
Join Date: Nov 2005
Fan#: 29645
Location: Hendersonville, TN
What I Drive: 2003 Pitch Black ZX5 SVT

Posts: 10
FF Reputation: 1 jp96921 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by michael1199 View Post
i have had my car for the last 3 months and makes that horrible noise constantly. i have checked the DSI clip and yes it has broken but also the noise is coming from the silver actuator box. If i buy the actuator will this come with the DSI clip? And how easy is it to fix? Will i have to take the whole manifold out? Thanks

Michael
Hi Micheal, No the runner control module will not come with the clip. easy fix, and no you don't have to remove the intake runner. you can go to www.c-f-m.com and there you have 2 choices on DSI clips, one for $13 & the other high end is $40 of your choice.
jp96921 is offline  
    Reply With Quote
Old 03-13-2010, 11:27 AM   #107
focus bofus
Focus Rookie
 
Join Date: Mar 2010
Fan#: 73307
Location: Mason, TN
What I Drive: 2003 Dark Shadow Grey ZX3

Posts: 12
FF Reputation: 1 focus bofus Good Standing Member
Buy-Sell-Trade Rating: (0)
hey guys, i'm a newbie on FF, and new to the world of Ford Focus. what is a DSI ?
focus bofus is offline  
    Reply With Quote
Old 03-13-2010, 11:45 AM   #108
bmylez
Focus Fanatic
 
bmylez's Avatar
 
Join Date: Apr 2009
Fan#: 64637
Location: San Antonio, TX
What I Drive: 2003 350Z Track

Posts: 3,450
FF Reputation: 23 bmylez Great Standing Member
Buy-Sell-Trade Rating: (1)
You don't even have an SVT...

Google is your friend, but DSI stands for dual stage intake. You do not have one, so don't worry.
__________________
1992 Eagle Talon TSi - sold (POS)
2002 Mustang GT - sold
2002 SVTF - sold
2008.5 Mazdaspeed3 GT - cursed
2003 350Z Track - basically stock, and it runs
bmylez is offline  
    Reply With Quote
Old 03-14-2010, 04:59 AM   #109
MarshallPulham
Focus Rookie
 
Join Date: Mar 2010
Fan#: 73296
Location: victoria, Canada
What I Drive: 02 SVTF 06 Mustang GT Vortech

Posts: 7
FF Reputation: 1 MarshallPulham Good Standing Member
Buy-Sell-Trade Rating: (0)
Will having excess slack in the cable cuz them to not fully engage after 5,000? Girlfriends focus right before the clip the wire has a decent bit of slack in it ?
MarshallPulham is offline  
    Reply With Quote
Old 09-18-2010, 11:42 PM   #110
MexSVT
Focus Enthusiast
 
MexSVT's Avatar
 
Join Date: Mar 2010
Fan#: 73596
Location: Guadalajara, Mexico
What I Drive: 2002 CD silver SVT

Posts: 114
FF Reputation: 1 MexSVT Good Standing Member
Buy-Sell-Trade Rating: (0)
last evening I checked mine and found that someone else came up with the same idea, or read this thread before , there was a bolt in the clip but not in place, the shoulder on the lever of the DSI, where it was suposed to be attached to, was broken, I have my SVT for a bit more than a year, and I am pretty sure this thing has been broken ever-since, cause it feels so very different now that is fixed.

aprox 75% of the hole where the bolt has to be screwed was ok, so I screwed it in place and filled the missing plastic with epoxy/metal mix, a generous amount of it, let it cure ovenight, and assemble everything back this morning.

lets see how good it holds up in time this fixture since that part is under constant stress cause IMRC is pulling most of the time
MexSVT is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:53 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.