Low Drop of RPMs on SVTF - Page 3 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 04-03-2014, 11:09 AM   #21
Tdubbs1989
Focus Enthusiast
 
Join Date: Jul 2013
Fan#: 116903
Location: Geneva, IL
What I Drive: 2002 CD Silver SVT #695

Posts: 124
Points 114, Level 2
Points: 114, Level: 2 Points: 114, Level: 2 Points: 114, Level: 2
Level Up 28% Completed
Level up: 28% Level up: 28% Level up: 28%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 2 Tdubbs1989 Good Standing Member
Buy-Sell-Trade Rating: (0)
I just took a look at CFM just to see if they had a part number, they do and it's listed as 988Z-12029-A.

Hope that helps you find it.
__________________
2002 Focus SVT CD Silver/Blue Inserts
#695 of #4788
Tdubbs1989 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-03-2014, 11:27 AM   #22
Megagwar
Focus Enthusiast
 
Megagwar's Avatar
 
Join Date: May 2013
Fan#: 114192
Location: Cypress, TX
What I Drive: 2003 Faded Infra Red SVT

Posts: 73
Points 875, Level 15
Points: 875, Level: 15 Points: 875, Level: 15 Points: 875, Level: 15
Level Up 75% Completed
Level up: 75% Level up: 75% Level up: 75%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 Megagwar Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by Tdubbs1989 View Post
I just took a look at CFM just to see if they had a part number, they do and it's listed as 988Z-12029-A.

Hope that helps you find it.
thanks man! appreciate it.
Megagwar is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2014, 02:51 PM   #23
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,490
Points 6,360, Level 52
Points: 6,360, Level: 52 Points: 6,360, Level: 52 Points: 6,360, Level: 52
Level Up 5% Completed
Level up: 5% Level up: 5% Level up: 5%
Forum Activity 43%
Activity: 43% Activity: 43% Activity: 43%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
Well it's working way better now.
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2014, 07:13 PM   #24
Megagwar
Focus Enthusiast
 
Megagwar's Avatar
 
Join Date: May 2013
Fan#: 114192
Location: Cypress, TX
What I Drive: 2003 Faded Infra Red SVT

Posts: 73
Points 875, Level 15
Points: 875, Level: 15 Points: 875, Level: 15 Points: 875, Level: 15
Level Up 75% Completed
Level up: 75% Level up: 75% Level up: 75%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 Megagwar Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by freemind View Post
Well it's working way better now.
Is it not dropping real low anymore? Or is there some?

I did the restart, help just a tad. But still dropping. It's a bit more stable when it goes down.
Megagwar is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2014, 08:02 PM   #25
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,490
Points 6,360, Level 52
Points: 6,360, Level: 52 Points: 6,360, Level: 52 Points: 6,360, Level: 52
Level Up 5% Completed
Level up: 5% Level up: 5% Level up: 5%
Forum Activity 43%
Activity: 43% Activity: 43% Activity: 43%
FF Reputation: 24 freemind Great Standing Member
Buy-Sell-Trade Rating: (23)
After reloading my tune, it's holding at 880-930 RPM.
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2014, 10:23 PM   #26
shananigans89
Focus Enthusiast
 
shananigans89's Avatar
 
Join Date: Apr 2011
Fan#: 84576
Location: Clarksville, TN
What I Drive: 04 red 3dr SVT, 04 mazda 3, 04 R6

Posts: 85
FF Reputation: 1 shananigans89 Good Standing Member
Buy-Sell-Trade Rating: (0)
hmmm...i just happened to check in the forums today and saw this. i've had the same issues since i got my svt. i hadnt even considered replacing the coil... think ill give it a try and see how it goes.
__________________
K&N Typhoon SRI, Magstar 8.5mm plug wires, Denzo Iridium plugs, all VF Eng poly motor mounts, 2.5" Dominant Eng HFC & flex pipe, Trubendz 2.5" exhst w/ Borla muffler no resonator, SCT Xcal3 with Tom's Tune, CFM 67mm TB
shananigans89 is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2014, 10:40 PM   #27
Megagwar
Focus Enthusiast
 
Megagwar's Avatar
 
Join Date: May 2013
Fan#: 114192
Location: Cypress, TX
What I Drive: 2003 Faded Infra Red SVT

Posts: 73
Points 875, Level 15
Points: 875, Level: 15 Points: 875, Level: 15 Points: 875, Level: 15
Level Up 75% Completed
Level up: 75% Level up: 75% Level up: 75%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 Megagwar Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by freemind View Post
After reloading my tune, it's holding at 880-930 RPM.
What tune do you have?
Well that's good!
The reset didn't do anything for me after all. I'm gonna check my coil tomorrow.
Megagwar is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2014, 10:50 PM   #28
Tdubbs1989
Focus Enthusiast
 
Join Date: Jul 2013
Fan#: 116903
Location: Geneva, IL
What I Drive: 2002 CD Silver SVT #695

Posts: 124
Points 114, Level 2
Points: 114, Level: 2 Points: 114, Level: 2 Points: 114, Level: 2
Level Up 28% Completed
Level up: 28% Level up: 28% Level up: 28%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 2 Tdubbs1989 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Megagwar View Post
What tune do you have?
Well that's good!
The reset didn't do anything for me after all. I'm gonna check my coil tomorrow.
Was worth a shot, check that coil for cracks and double check the pigtail going to it.
__________________
2002 Focus SVT CD Silver/Blue Inserts
#695 of #4788
Tdubbs1989 is offline  
    Reply With Quote Quick reply to this message
Old 04-03-2014, 10:59 PM   #29
Megagwar
Focus Enthusiast
 
Megagwar's Avatar
 
Join Date: May 2013
Fan#: 114192
Location: Cypress, TX
What I Drive: 2003 Faded Infra Red SVT

Posts: 73
Points 875, Level 15
Points: 875, Level: 15 Points: 875, Level: 15 Points: 875, Level: 15
Level Up 75% Completed
Level up: 75% Level up: 75% Level up: 75%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 Megagwar Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by Tdubbs1989 View Post
Was worth a shot, check that coil for cracks and double check the pigtail going to it.
Yea. Will do.
I changed the pigtail not too long ago. A couple months ago. Was still having the issue before I changed it. I'm thinking it is the coil.
Megagwar is offline  
    Reply With Quote Quick reply to this message
Old 04-04-2014, 12:57 PM   #30
Megagwar
Focus Enthusiast
 
Megagwar's Avatar
 
Join Date: May 2013
Fan#: 114192
Location: Cypress, TX
What I Drive: 2003 Faded Infra Red SVT

Posts: 73
Points 875, Level 15
Points: 875, Level: 15 Points: 875, Level: 15 Points: 875, Level: 15
Level Up 75% Completed
Level up: 75% Level up: 75% Level up: 75%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 Megagwar Good Standing Member
Buy-Sell-Trade Rating: (1)
Took out coil just now, it's got cracks. You see the big one in the pic? Found a few more cracks after taking the pic too. Off to get a new one!
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	10
Size:	239.0 KB
ID:	38818  

Megagwar is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:22 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat