issues, issues...HELP - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > Focus Tuning Chat

Focus Tuning Chat Discuss performance tuning options for your Ford Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 12-14-2013, 11:40 AM   #1
alyantor
Focus Rookie
 
Join Date: Dec 2013
Fan#: 128634
Location: Conklin, MI
What I Drive: 2003, Ford Focus Se

Posts: 1
FF Reputation: 1 alyantor Good Standing Member
Buy-Sell-Trade Rating: (0)
Exclamation issues, issues...HELP

I own a 2003 Ford Focus SE 2.0L split port, and think it is a SOHC. Ever since I purchased my car the issue has gotten worse. When I start my car it makes noises, and shakes/vibrates all the time, whether it is in P, D, N, R..whatever gear and I took it in to get in diagnosed but of course they didn't help, I had a new torque strut put in, and have just put in a new air filter, spark plugs and wire set. So, my question is, does any one know ANYTHING that could help me, even a list of things would be appreciated! I don't want to get rid of my car, I like it, and would like to fix it so it runs good as new!


alyantor is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 12-14-2013, 02:34 PM   #2
gogo2.0
Focus Rookie
 
Join Date: Nov 2013
Fan#: 122449
Location: st.louis co., MO
What I Drive: 2000 saphireblue zts&03blackztw

Posts: 1
FF Reputation: 1 gogo2.0 Good Standing Member
Buy-Sell-Trade Rating: (0)
You might have bad motor mounts tried changing the upper passenger side mount first that is where I would do first deadlock from GO GO 2.0
gogo2.0 is offline  
    Reply With Quote
Old 12-14-2013, 08:16 PM   #3
Gav-O-SVT
Focus Addict
 
Gav-O-SVT's Avatar
 
Join Date: Apr 2013
Fan#: 113561
Location: Concord, CA
What I Drive: '02 Infra-Red SVT

Posts: 1,127
FF Reputation: 6 Gav-O-SVT Good Standing Member
Buy-Sell-Trade Rating: (2)
I agree, check your motor mounts if you are having excessive vibration... I would recomend just replacing all 3= passenger, drivers side and rear "dog bone" underneath.
Gav-O-SVT is online now  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:27 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.