Electrical Problems - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-26-2013, 01:46 PM   #1
Playhard
Focus Rookie
 
Join Date: Aug 2013
Fan#: 117683
Location: Cottage Grove, MN
What I Drive: 2003 Red focus

Posts: 1
FF Reputation: 1 Playhard Good Standing Member
Buy-Sell-Trade Rating: (0)
Electrical Problems

Sister has an 05 SE wagon. Long story short. When she's driving the car it will all of a sudden start to buck and hesitate, the dash lights will start coming on and off and she hears a clicking sound from under the dash. She has taken it in twice to a mechanic with nothing found. It will then go away for a few weeks before it happens again. If someone had a similar issue with an 05 what resolved the problem. Im thinking its a short somewhere. Car starts all the time so it's probably not the alternator itself. Anyone???


Playhard is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 11-26-2013, 04:31 PM   #2
fenderbass146
Focus Rookie
 
Join Date: Nov 2013
Fan#: 125161
Location: Highland, IN
What I Drive: 2010 Blue Focus SE

Posts: 4
FF Reputation: 1 fenderbass146 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Playhard View Post
Sister has an 05 SE wagon. Long story short. When she's driving the car it will all of a sudden start to buck and hesitate, the dash lights will start coming on and off and she hears a clicking sound from under the dash. She has taken it in twice to a mechanic with nothing found. It will then go away for a few weeks before it happens again. If someone had a similar issue with an 05 what resolved the problem. Im thinking its a short somewhere. Car starts all the time so it's probably not the alternator itself. Anyone???
I am having a nearly identical issue on my 2010... i haven't noticed clicking under dash, doesnt mean Its not there though. But the dash lights going on and off and the bucking is the exact same. Mine however stalls completly and won't come back on unless I let it sit for a few minutes...then maybe I can drive another block //bM
fenderbass146 is offline  
    Reply With Quote
Old 11-28-2013, 08:21 AM   #3
mmurphy
Focus Enthusiast
 
Join Date: Nov 2013
Fan#: 125417
Location: none, IA
What I Drive: 2001 blue se

Posts: 102
FF Reputation: 3 mmurphy Good Standing Member
Buy-Sell-Trade Rating: (0)
While looking through here to see common problems with a Focus, I thought I would suggest thorough examination on any ground you have from battery to inside the car. A ground can look pretty substantial but under point of contact could be corrosion. The clicking noise from the relays under the dash suggests to me losing either + or - temporarily. Being more then 1 clicking suggests ground. Always re clean battery cables as a first.
mmurphy is offline  
    Reply With Quote
Old 11-28-2013, 01:28 PM   #4
mikeeshaq
Focus Addict
 
Join Date: Jan 2010
Fan#: 72526
Location: Sugar Land,TX ex MN, TX
What I Drive: 2010 Transit Connect

Posts: 1,041
FF Reputation: 15 mikeeshaq Great Standing Member
Buy-Sell-Trade Rating: (0)
From the above poster


"Always re clean battery cables as a first. " so true

So after tightening the battery clamps, twist them sideways, they must not move at all,
if they do move your clamps are worn out

reply back here if that is the case
mikeeshaq is offline  
    Reply With Quote
Old 11-28-2013, 04:15 PM   #5
stromberg2
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 57480
Location: Monroe, United States
What I Drive: 2003 Red SVT

Posts: 81
FF Reputation: 1 stromberg2 Good Standing Member
Buy-Sell-Trade Rating: (1)
Where does one get the Big 3 update?

Stromberg2
stromberg2 is offline  
    Reply With Quote
Old 11-29-2013, 07:29 AM   #6
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 4,043
FF Reputation: 22 freemind Great Standing Member
Buy-Sell-Trade Rating: (20)
Quote:
Originally Posted by stromberg2 View Post
Where does one get the Big 3 update?

Stromberg2
http://www.focusfanatics.com/forum/showthread.php?t=217930
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is online now  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:08 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.