Looking for answers - dashboard EL lighting - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus SVT > SVT Interior Mods & Upgrades

SVT Interior Mods & Upgrades The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the 2002-204 SVT Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 11-23-2013, 12:47 AM   #1
VAfromMN
Focus Enthusiast
 
Join Date: Mar 2005
Fan#: 20592
Location: Fredericksburg, VA, VA
What I Drive: '13 Focus ST & '04 Focus SVT

Posts: 255
FF Reputation: 9 VAfromMN Good Standing Member
Buy-Sell-Trade Rating: (0)
Looking for answers - dashboard EL lighting

Folks, I need to take advantage of your collective experience with the SVTF's, specifically the dashboard electroluminescent lighting. My admittedly well used SVT, currently at 294,000 miles, has started to lose the dashboard lighting after about 30-60 minutes of travel.

While the dashboard EL lighting begins dimming and eventually going out, other portions like the odometer and radio remain bright and can be attenuated using the roller switch to dim or brighten.

I'm thinking it is probably a resistor or something similar that heating up and causing the problem. In my research, I noted other folks who had dashboard lighting problems, had reported loss of taillights also. In my case, stop/tail/turn lights are not affected.

Any suggestions?


VAfromMN is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 01-11-2014, 05:50 PM   #2
Jack The Ripper
Focus Enthusiast
 
Jack The Ripper's Avatar
 
Join Date: Dec 2010
Fan#: 81179
Location: Los Angeles, CA
What I Drive: '04 SVT ZX5 & '10 Mustang V6

Posts: 191
FF Reputation: 1 Jack The Ripper Good Standing Member
Buy-Sell-Trade Rating: (0)
Jesus, I hope I get that many miles out of my SVT. Holy crap. Yeah, I've had this same issue for about.. 3 years now? I've paid mechanics hundreds (if not at least a thousand over time) to "fix" this problem. I've done it all. Replaced the dimmer, battery, etc. Not a damn thing has changed. Would love to know the issue as well.
__________________
SoCal Crew #666
Jack The Ripper is offline  
    Reply With Quote
Old 01-11-2014, 07:34 PM   #3
ShadowFocus603
Focus Enthusiast
 
ShadowFocus603's Avatar
 
Join Date: Aug 2013
Fan#: 118448
Location: Littleton, NH
What I Drive: 2004 Pitch Black SVT EAP 2Dr #1878

Posts: 266
FF Reputation: 1 ShadowFocus603 Good Standing Member
Buy-Sell-Trade Rating: (1)
Mine has been doing this since I got it and I have chased grounds, battery cable ends, dimmer, the whole 9 yards. I think this is as common as the damn leaky thermostat housing.
ShadowFocus603 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:51 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.