2003 Focus Loss in Power - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus First Generation > SPI Performance (2000-2004)

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-09-2013, 10:00 AM   #1
machelis
Focus Jr. Enthusiast
 
Join Date: Oct 2006
Fan#: 40419
Location: mtl
Posts: 43
FF Reputation: 1 machelis Good Standing Member
Buy-Sell-Trade Rating: (0)
2003 Focus Loss in Power

Howdy,

For some reason when I hit the petal on my SPI, it makes noise, but doesn't speed up very quickly. It sounds like it's bogging. And when I rev it in neutral, it hesitates when the rpm's start to lower. I've replaced the coil and plugs recently as well as the egr valve and tube. Compression is around 230-240 in all cylinders. Could it be the egr solenoid or a vacuum leak somewhere?

Thanks.


machelis is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 09-09-2013, 10:06 AM   #2
joecicalese
Focus Enthusiast
 
Join Date: Nov 2012
Fan#: 105573
Location: Lakewood, NJ
What I Drive: 2001 Black ZTS

Posts: 369
FF Reputation: 4 joecicalese Good Standing Member
Buy-Sell-Trade Rating: (1)
No check engine light? Check filters (air & fuel) and PCV valve. Check the line coming off the PCV valve and make sure it's not cracked.
joecicalese is offline  
    Reply With Quote
Old 09-09-2013, 02:36 PM   #3
tryingtofixthis
Focus Enthusiast
 
Join Date: Aug 2013
Fan#: 118287
Location: Logan, OH
What I Drive: 00 blue FF, 91 black Volks Jetta

Posts: 145
FF Reputation: 1 tryingtofixthis Good Standing Member
Buy-Sell-Trade Rating: (0)
Hmmm.. This is how my problem started. And im not gonma say replace anything, but do the regular maintainance and of it does not resolve with that you may have the same issie that eveybody seems to encoumter with these engines. That bein said run a compression test
tryingtofixthis is offline  
    Reply With Quote
Old 09-10-2013, 09:47 AM   #4
machelis
Focus Jr. Enthusiast
 
Join Date: Oct 2006
Fan#: 40419
Location: mtl
Posts: 43
FF Reputation: 1 machelis Good Standing Member
Buy-Sell-Trade Rating: (0)
I do regular maintenance on it. And I did a compression test. Everything came out fine. My buddy plugged the car into his Snap-On super computer code reader and found the first O2 sensor to be off the charts, but not enough to throw a CEL.

Thanks for the help though guys.
machelis is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:28 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.