knocking sound after green filter - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Third Generation > DURATEC Ti-VCT Performance (2012-Current)

DURATEC Ti-VCT Performance (2012-Current) The place to chat about any Duratec 2.0L Ti-VCT engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 05-15-2014, 08:13 AM   #1
arcesala
Focus Jr. Enthusiast
 
Join Date: Mar 2012
Fan#: 96139
Location: Heredia, Costa Rica
What I Drive: 2012 Focus SE

Posts: 42
FF Reputation: 1 arcesala Good Standing Member
Buy-Sell-Trade Rating: (0)
knocking sound after green filter

Hi guys! Does anyone had any issues after installing a performance air filter?

I just dropped in a Green Filter in my Focus SE '12 and noticed a knocking sound while throttle in low revs and also when changing gear it revs up it self.

Any thoughts?


arcesala is online now  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 05-15-2014, 09:10 AM   #2
Eminaga
Focus Addict
 
Eminaga's Avatar
 
Join Date: Nov 2013
Fan#: 123953
Location: Waterloo, IA
What I Drive: 2014 Focus SE (Performance Blue)

Posts: 918
FF Reputation: 1 Eminaga Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by arcesala View Post
Hi guys! Does anyone had any issues after installing a performance air filter?

I just dropped in a Green Filter in my Focus SE '12 and noticed a knocking sound while throttle in low revs and also when changing gear it revs up it self.

Any thoughts?
Make sure you have everything connected correctly and the box is fully closed.
__________________
*Snorkel/Shroud Delete, ITG Filter, Full ST Exhaust, E-RMM, Steeda RSB, Vogtland Springs, 180* T-Stat, Custom SCT Tune by Tom @ Focus-Power*
Eminaga is online now  
    Reply With Quote
Old 05-15-2014, 09:25 AM   #3
arcesala
Focus Jr. Enthusiast
 
Join Date: Mar 2012
Fan#: 96139
Location: Heredia, Costa Rica
What I Drive: 2012 Focus SE

Posts: 42
FF Reputation: 1 arcesala Good Standing Member
Buy-Sell-Trade Rating: (0)
Everything is as is should be! Only mod was the new filter...
arcesala is online now  
    Reply With Quote
Old 05-15-2014, 09:28 AM   #4
arcesala
Focus Jr. Enthusiast
 
Join Date: Mar 2012
Fan#: 96139
Location: Heredia, Costa Rica
What I Drive: 2012 Focus SE

Posts: 42
FF Reputation: 1 arcesala Good Standing Member
Buy-Sell-Trade Rating: (0)
The knocking sound is exactly like on those old carburated cars when you move the dist to have an advance spark
arcesala is online now  
    Reply With Quote
Old 05-15-2014, 11:08 AM   #5
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 21,766
FF Reputation: 153 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
What octane fuel are you running ?

Go back to the stock filter and see if the issue goes away or if you may of got some bad gas ( low octane )

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote
Old 05-15-2014, 11:16 AM   #6
arcesala
Focus Jr. Enthusiast
 
Join Date: Mar 2012
Fan#: 96139
Location: Heredia, Costa Rica
What I Drive: 2012 Focus SE

Posts: 42
FF Reputation: 1 arcesala Good Standing Member
Buy-Sell-Trade Rating: (0)
That's what I tought... Issue is that I'm using the best gas here in CR :'( I might need to start using Torco to boost up the octane.

PS: this happened to me with a high compression engine I've had years ago in my beloved CRX...
arcesala is online now  
    Reply With Quote
Old 05-15-2014, 11:39 AM   #7
BetaDnB
Drum n Bass Lover
 
BetaDnB's Avatar
 
Join Date: Jul 2011
Fan#: 87466
Location: Buffalo, NY
What I Drive: 2012 Silver SE Sport

Posts: 1,964
FF Reputation: 11 BetaDnB Great Standing Member
Buy-Sell-Trade Rating: (0)
Did you touch the MAF at all? Check to see that you don't have a wire pinched between the air box and lid.
__________________
Sedan Revolution #249 - 2012 SE Sport - ╠╬╝ - Ingot Silver - 201A - K&N w/ snorkel delete - Blox Type R Knob
BetaDnB is online now  
    Reply With Quote
Old 05-15-2014, 11:57 AM   #8
arcesala
Focus Jr. Enthusiast
 
Join Date: Mar 2012
Fan#: 96139
Location: Heredia, Costa Rica
What I Drive: 2012 Focus SE

Posts: 42
FF Reputation: 1 arcesala Good Standing Member
Buy-Sell-Trade Rating: (0)
I'll check that too but I think that in case of any maf or any other peripheral malfunction the computer should display a check engine.. isn't?
arcesala is online now  
    Reply With Quote
Old 05-15-2014, 12:14 PM   #9
sailor
"Elder"
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 13,264
FF Reputation: 67 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Won't do that immediately, depending on the issue. Only displays immediately for MAJOR problems.

Last one I remember having this issue had a poor filter to air tube connection, but that was a partial aftermarket intake.
__________________
"Rubber Side Down"

S.R. #275
sailor is online now  
    Reply With Quote
Old 05-18-2014, 06:32 AM   #10
Elizabeth
Focus Fanatic
 
Elizabeth's Avatar
 
Join Date: Aug 2011
Fan#: 89280
Location: SouthEast, WI
What I Drive: '12 Yellow Focus SE stick, 17"rims

Posts: 2,867
FF Reputation: 15 Elizabeth Great Standing Member
Buy-Sell-Trade Rating: (0)
The 'ticking' sund is the fuel injectors. They are easy to hear and sound like clattering lifters. Just not as loud.
The pressure inside them is very high, and each time they release fuel into the cylinder they 'Ping!'
So that may be what you are hearing. It is totally normal. and you may have just not heard it before.
All MK3 make that noise.

As for the rpm. yes that too is normal. If you have a manual tranny, the engine will rev up slightly when you push in the clutch. though it does not do it all the time..
I heard about this and watched mine. And yes under some conditions it automatically revs up about 300rpm when the clutch is pushed in.
But under other conditions the car does not. So it is some sort of engine management stuff.
Elizabeth is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:40 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.