Loss of power/ stumble issue - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 06-11-2013, 01:45 PM   #1
lowzts
Focus Jr. Enthusiast
 
lowzts's Avatar
 
Join Date: Jun 2013
Fan#: 115627
Location: palm coast/ st augustine, FL
What I Drive: 02 liquid grey zts mach audio

Posts: 49
FF Reputation: 1 lowzts Good Standing Member
Buy-Sell-Trade Rating: (1)
Loss of power/ stumble issue

I drive a 02 zts mach audio edition, 5-speed zetec. I'm having problems with what I feel is loss of torque and a stumble under light to medium acceleration. Not sure if its me expecting too much out of my focus with 160xxx+ miles or if its fixable. Simple, cheap upgrades like k&n cone filter (stock intake tubing) and I hack- jobbed my exhaust just after the rear axle. Any advice or input is welcome and appreciated. I'm not a master mechanic but I'm pretty foci smart :-)

Sent from my ZTE N9120 using FF Mobile


lowzts is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 06-11-2013, 02:07 PM   #2
79mgb
Focus Enthusiast
 
79mgb's Avatar
 
Join Date: Oct 2012
Fan#: 105006
Location: Orlando, FL
What I Drive: 1979 MG MGB, 2008 Mazda 3

Posts: 151
FF Reputation: 3 79mgb Good Standing Member
Buy-Sell-Trade Rating: (4)
It would help to know what regular or interval maintenance has been done to the car.

Also, Have you replaced any other original parts on the engine? Does the engine have any issues while idling?

Just curious.
__________________
Driving a Zetec Powered MGB. :)
79mgb is offline  
    Reply With Quote
Old 06-11-2013, 02:11 PM   #3
lowzts
Focus Jr. Enthusiast
 
lowzts's Avatar
 
Join Date: Jun 2013
Fan#: 115627
Location: palm coast/ st augustine, FL
What I Drive: 02 liquid grey zts mach audio

Posts: 49
FF Reputation: 1 lowzts Good Standing Member
Buy-Sell-Trade Rating: (1)
New egr valve, plugs and wires, alternator, coil pack, clutch and flywheel, regular oil changes and fluid changes, and yes it seems to almost misfire at an idle. Thoufh its intermittant at an idle

Sent from my ZTE N9120 using FF Mobile
lowzts is offline  
    Reply With Quote
Old 06-11-2013, 03:03 PM   #4
bringler26
FUBARCUS
 
bringler26's Avatar
 
Join Date: Oct 2008
Fan#: 59705
Location: Mentor, OH
What I Drive: 03 ZX3 & 07 Impreza 2.5i

Posts: 5,659
FF Reputation: 29 bringler26 Great Standing Member
Buy-Sell-Trade Rating: (5)
I moved you to the general technical area of the forum. You should get some more answers to your question here.
__________________
2003 Ford Focus ZX3("FUBARCUS" was "Brokus") - old and still busted
2007 Subaru Impreza 2.5i - current DD
Quote:
Originally Posted by zetecDon View Post
I always moderate naked!
bringler26 is offline  
    Reply With Quote
Old 06-12-2013, 10:00 AM   #5
Kodyston
Focus Enthusiast
 
Kodyston's Avatar
 
Join Date: Mar 2013
Fan#: 112498
Location: Hillsville, VA
What I Drive: 2003 Sangria Red ZX3; Zetec; MTX-75

Posts: 411
FF Reputation: 3 Kodyston Good Standing Member
Buy-Sell-Trade Rating: (0)
My 2003 is kinda doing the same thing. With the intermittent missing at idle, and not wanting to get up and go from a stop. If you figure out what's up, I'd like to know so maybe I can get mine running a little better too.
Kodyston is offline  
    Reply With Quote
Old 06-12-2013, 10:04 AM   #6
lowzts
Focus Jr. Enthusiast
 
lowzts's Avatar
 
Join Date: Jun 2013
Fan#: 115627
Location: palm coast/ st augustine, FL
What I Drive: 02 liquid grey zts mach audio

Posts: 49
FF Reputation: 1 lowzts Good Standing Member
Buy-Sell-Trade Rating: (1)
For sure dude. I'm going to try flow testing my injectors... fuel pressure is good so imma start ruling things out. When I find something I will let u know

Sent from my ZTE N9120 using FF Mobile
lowzts is offline  
    Reply With Quote
Old 06-12-2013, 10:25 AM   #7
Kodyston
Focus Enthusiast
 
Kodyston's Avatar
 
Join Date: Mar 2013
Fan#: 112498
Location: Hillsville, VA
What I Drive: 2003 Sangria Red ZX3; Zetec; MTX-75

Posts: 411
FF Reputation: 3 Kodyston Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by lowzts View Post
For sure dude. I'm going to try flow testing my injectors... fuel pressure is good so imma start ruling things out. When I find something I will let u know
Okay, thanks lowzts!
Kodyston is offline  
    Reply With Quote
Old 06-14-2013, 10:20 AM   #8
xsuicidesn0wmanx
Focus Enthusiast
 
xsuicidesn0wmanx's Avatar
 
Join Date: May 2009
Fan#: 65239
Location: Sycamore, IL
What I Drive: 2001 Black Ford Focus SE Sedan

Posts: 260
FF Reputation: 1 xsuicidesn0wmanx Good Standing Member
Buy-Sell-Trade Rating: (2)
When I had a similar problem it ended up being the pcv hose had collapsed and was restricting airflow(bad vacuum). Feel around, if its real spongy, or feels flat around the 90 deg bend replace it. You can find the 'bend' that usually goes bad about 6 or so inches below the throttle body, and it should go around the back of the engine towards the drivers side and connect to a brief metal tube just below the thermostat/coil pack area. New hose should come with a heat shield on it, i recommend getting a cheap hose clamp to replace the oem clamp while you're at it.
xsuicidesn0wmanx is offline  
    Reply With Quote
Old 06-15-2013, 06:26 AM   #9
lowzts
Focus Jr. Enthusiast
 
lowzts's Avatar
 
Join Date: Jun 2013
Fan#: 115627
Location: palm coast/ st augustine, FL
What I Drive: 02 liquid grey zts mach audio

Posts: 49
FF Reputation: 1 lowzts Good Standing Member
Buy-Sell-Trade Rating: (1)
Going in to have injectors flow tested and possibly cleaned (properly cleaned not a quick lube cleaning). As well ad new pcv valve and hoses. I will let you know when I have results

Sent from my ZTE N9120 using FF Mobile
lowzts is offline  
    Reply With Quote
Old 06-15-2013, 06:59 AM   #10
Kodyston
Focus Enthusiast
 
Kodyston's Avatar
 
Join Date: Mar 2013
Fan#: 112498
Location: Hillsville, VA
What I Drive: 2003 Sangria Red ZX3; Zetec; MTX-75

Posts: 411
FF Reputation: 3 Kodyston Good Standing Member
Buy-Sell-Trade Rating: (0)
Sounds good. I'll be waiting on the results. :)
__________________
Steeda Louvered hood, Steeda Razzi body kit, carbon fiber dash trim, shift knob & Steeda door sill plates, American Racing chrome plated 16" wheels, SVT suspension, K&N lifetime drop in air filter and fog light modification.
Kodyston is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:42 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.