turn signal issue - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 04-12-2013, 09:45 PM   #1
Zellop
Focus Rookie
 
Join Date: Jul 2012
Fan#: 101788
Location: Sardinia, OH
What I Drive: 2005 focus zx4

Posts: 3
FF Reputation: 1 Zellop Good Standing Member
Buy-Sell-Trade Rating: (0)
turn signal issue

My front left turn signal an marker light went out a couple of days ago so I was looking around for any spare lights. I found a marker light an I put it in, it worked fine. Later that night I was leaving an when I got in my car and turned on my lights my left turn signal light on the cluster stays lite. Its only on when the lights are on. Then the marker light went out.

Does anyone ever heard of this? or had this problem?


Zellop is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2013, 07:01 AM   #2
02fordsvt
Meh.
 
02fordsvt's Avatar
 
Join Date: Apr 2011
Fan#: 84654
Location: Lowville, NY
What I Drive: 2002 SVT, 2001 SE (Rusty)

Posts: 9,631
FF Reputation: 49 02fordsvt Great Standing Member
Buy-Sell-Trade Rating: (11)
Make sure you headlight plug is in tight. I had this happen on my first gen Machs when I hadn't put the plug into the headlight tight enough.
__________________
Hatch Nation #13 : Rally Revolution #13 : ROTM Jan '13
It's Bryan, not Brian
RSVT-170 Build in Progress
Derusting Rusty Build in Progress
02fordsvt is offline  
    Reply With Quote
Old 04-13-2013, 03:21 PM   #3
Zellop
Focus Rookie
 
Join Date: Jul 2012
Fan#: 101788
Location: Sardinia, OH
What I Drive: 2005 focus zx4

Posts: 3
FF Reputation: 1 Zellop Good Standing Member
Buy-Sell-Trade Rating: (0)
I just changed my bulb and the light went off so it must of just been loose. Thanks.
Zellop is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:46 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.