Bluetooth with MFT and Android 4.0.4 - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Model Specific Discussions > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 08-27-2012, 12:03 AM   #1
MGbox
Focus Enthusiast
 
MGbox's Avatar
 
Join Date: Jul 2011
Fan#: 87878
Location: Winnipeg, Canada
What I Drive: 2012 Focus Titanium Hatchback

Posts: 547
FF Reputation: 1 MGbox Good Standing Member
Buy-Sell-Trade Rating: (0)
Bluetooth with MFT and Android 4.0.4

Since upgrading my Samsung Galaxy S2 LTE (SGH-I727R) from Android 2.3.4 to 4.0.4 a few months ago I've had trouble keeping my phone connected to the the bluetooth in my car.

Connects fine every start up. But every 2-3 minutes it randomly disconnects which prompts a large pop up on the MFT system saying it's trying to reconnect, which 20-30 seconds later it usually does. This is quite annoying if you're trying to do something else on the system like change radio station or browse music, etc, because it only gives you the option to cancel the attempt to reconnect instead of letting you minimize the popup.

The bluetooth has never dropped during an active call. But if it disconnects as you're approaching someones house and you wanna call to let them know you're here, it's quite annoying and defeats the whole purpose of having bluetooth in a car.

Anyone else experienced this or have a fix? I've searched other android related sites without finding a solution.


__________________
My signature was "too long" with all the revised ETAs I've received. Finally took delivery October 7th.
MGbox is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 08-27-2012, 12:28 AM   #2
oritpro
Focus Enthusiast
 
oritpro's Avatar
 
Join Date: Mar 2012
Fan#: 96148
Location: Portland, OR
What I Drive: 2012 Subaru Impreza Sport Limited

Posts: 439
FF Reputation: 2 oritpro Good Standing Member
Buy-Sell-Trade Rating: (0)
Yes, this happens to me once in a blue moon but usually corrects itself in a day or two without any action on my part.

I've found a couple of work-arounds though:
1. Turn bluetooth off on your phone for a few seconds, re-enable and it should re-connect automatically. If not, connect through the bluetooth menu on your phone.
2. Reboot phone.

I am running CM9 stable release (Android v4.04).
oritpro is online now  
    Reply With Quote
Old 08-27-2012, 12:30 AM   #3
Burns098356GX
Focus Enthusiast
 
Burns098356GX's Avatar
 
Join Date: Feb 2012
Fan#: 94777
Location: London, Canada
What I Drive: 2013 Focus ST

Posts: 270
FF Reputation: 1 Burns098356GX Good Standing Member
Buy-Sell-Trade Rating: (0)
Have you tried a different phone? I have Droid ICS and have no problems.
Burns098356GX is offline  
    Reply With Quote
Old 08-27-2012, 10:04 AM   #4
feta_mgp
Focus Fanatic
 
feta_mgp's Avatar
 
Join Date: Jul 2011
Fan#: 88210
Location: Vero Beach, FL
What I Drive: 2012 SGM Focus SEL

Posts: 2,406
FF Reputation: 7 feta_mgp Good Standing Member
Buy-Sell-Trade Rating: (0)
This is a phone issue not an MFT issue.

See the sticky MFT thread there's a good article on it in one of the last posts.

Basically... the Bluetooth interface the car uses is ubiquitous and allows for almost all compatible Bluetooth devices, in a phone however they use Bluetooth drivers specific to the hardware and sometimes those drivers aren't really tested well or written well, and lead to issues. So when you upgraded to 4.0, the Bluetooth driver probably updated as well, and that's giving you the issue, not the car.
__________________
2012 SGM SEL Sedan 303a w/o Nav | Job 1 built 6/2011
FSWERKS Cool-Flo w/ ITG Filter | FSWERKS Stealth Exhaust | 17x7.5 Axis Sport XMX Graphite wheels
Sonic Crew #28 | Rally Revolution #117
feta_mgp is offline  
    Reply With Quote
Old 08-31-2012, 11:15 AM   #5
FordIVTteam
Official Ford Rep
 
FordIVTteam's Avatar
 
Join Date: Jul 2011
Fan#: 87765
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 851
FF Reputation: 3 FordIVTteam Good Standing Member
Buy-Sell-Trade Rating: (0)
Hey everyone -

Like, feta_mgp said, this is an issue with the phone and not MyFord Touch. Many Android users have experienced concerns after the recent 4.0 (Ice Cream sandwich) update.

Any time an update is made to your phone or SYNC, we recommend resetting the system and pairing your phone again. Below are instructions for how to perform a Master Reset as well as Reverse Pair your phone. Certain phones hold the best connection when paired this way so I highly suggest giving it a try. Instead of the usual process where your phone finds SYNC, SYNC will find your phone:

http://Support.Ford.com/sync-technol...c-myford-touch

http://Support.Ford.com/sync-technol...c-myford-touch

Let me know if this helps or if you have any questions.

Jaclyn
__________________
FORD IN-VEHICLE TECHNOLOGY TEAM

p: 800.392.FORD (Prompts 1 then 3)
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordIVTteam is online now  
    Reply With Quote
Old 08-31-2012, 12:22 PM   #6
pozi240
Focus Enthusiast
 
Join Date: Feb 2012
Fan#: 94835
Location: Halifax, NS, Canada
What I Drive: 2012 Focus 5 door SEL Kona Blue

Posts: 356
FF Reputation: 4 pozi240 Good Standing Member
Buy-Sell-Trade Rating: (0)
Jaclyns advice is spot on. When I upgraded my Samsung Galaxy Nexus to 4.1 (Jellybean), I had the same issues, I actually called the tech support line and they suggested the above (erasing the phone in Sync and on the device) and pairing the phone from scratch again. Over a month later, it's still working fine in multiple Fords.
__________________
2012 Focus SEL 5 door 303a w/Lux pkg in KonaBlue
2012 Escape Limited w/park assist
2010 F150 Supercrew XTR 5.4 4x4
2008 Kawasaki Concours 14 (street)
2008 Kawasaki ZX10R (track only)
pozi240 is offline  
    Reply With Quote
Old 09-04-2012, 01:28 PM   #7
FordIVTteam
Official Ford Rep
 
FordIVTteam's Avatar
 
Join Date: Jul 2011
Fan#: 87765
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 851
FF Reputation: 3 FordIVTteam Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by pozi240 View Post
Jaclyns advice is spot on. When I upgraded my Samsung Galaxy Nexus to 4.1 (Jellybean), I had the same issues, I actually called the tech support line and they suggested the above (erasing the phone in Sync and on the device) and pairing the phone from scratch again. Over a month later, it's still working fine in multiple Fords.
Glad to hear it, pozi240, thanks for sharing!

Jaclyn
__________________
FORD IN-VEHICLE TECHNOLOGY TEAM

p: 800.392.FORD (Prompts 1 then 3)
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordIVTteam is online now  
    Reply With Quote
Old 09-05-2012, 08:06 AM   #8
Burns098356GX
Focus Enthusiast
 
Burns098356GX's Avatar
 
Join Date: Feb 2012
Fan#: 94777
Location: London, Canada
What I Drive: 2013 Focus ST

Posts: 270
FF Reputation: 1 Burns098356GX Good Standing Member
Buy-Sell-Trade Rating: (0)
Not to hijack the thread but I'm running android 4.3. Txt messages started showing up on my MFT screen, but after a master reset to the system, they no longer show up. Can I remedy this or change a setting to re-enable this? I rather like that feature.
Burns098356GX is offline  
    Reply With Quote
Old 09-05-2012, 08:30 AM   #9
pozi240
Focus Enthusiast
 
Join Date: Feb 2012
Fan#: 94835
Location: Halifax, NS, Canada
What I Drive: 2012 Focus 5 door SEL Kona Blue

Posts: 356
FF Reputation: 4 pozi240 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by Burns098356GX View Post
android 4.3.
? 4.0.3 maybe? Most users are on a version of 4.0.4 ICS, only a few devices (officially) are on 4.1 JellyBean, there is nothing above 4.1 ... yet. My wife had text capability on Android 2.3.4 (Gingerbread), upgraded to 4.0.3 IceCreamSandwich and lost that ability, but, just recently upgraded again to version 4.0.4 ICS and got it back again. I don't have the ability on 4.1 JB either.... but that could be the device itself (Galaxy Nexus)
__________________
2012 Focus SEL 5 door 303a w/Lux pkg in KonaBlue
2012 Escape Limited w/park assist
2010 F150 Supercrew XTR 5.4 4x4
2008 Kawasaki Concours 14 (street)
2008 Kawasaki ZX10R (track only)
pozi240 is offline  
    Reply With Quote
Old 09-05-2012, 10:06 AM   #10
Burns098356GX
Focus Enthusiast
 
Burns098356GX's Avatar
 
Join Date: Feb 2012
Fan#: 94777
Location: London, Canada
What I Drive: 2013 Focus ST

Posts: 270
FF Reputation: 1 Burns098356GX Good Standing Member
Buy-Sell-Trade Rating: (0)
Ya 4.0.3, my bad. I've for sure seen the text on the touch screen since updating to ICS. I'm just not sure how I've disabled it.
Burns098356GX is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:33 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.