Finally put back together - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-27-2013, 10:58 PM   #1
Svt03focus
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109595
Location: Columbus, OH
What I Drive: 2003 black ZX3

Posts: 17
FF Reputation: 1 Svt03focus Good Standing Member
Buy-Sell-Trade Rating: (0)
Finally put back together

I finally got my svt focus together(new rings bearings and head work). I went to start it and no start, not even a click. Is the some kind of ground wire I may be missing?


Svt03focus is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-27-2013, 11:28 PM   #2
ShoOff
Focus Addict
 
ShoOff's Avatar
 
Join Date: Feb 2013
Fan#: 109590
Location: Houston, TX
What I Drive: 2013 Performance Blue SE Hatchback

Posts: 802
Points 1,858, Level 25
Points: 1,858, Level: 25 Points: 1,858, Level: 25 Points: 1,858, Level: 25
Level Up 58% Completed
Level up: 58% Level up: 58% Level up: 58%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 16 ShoOff Great Standing Member
Buy-Sell-Trade Rating: (0)
Test lead FTW
ShoOff is offline  
    Reply With Quote Quick reply to this message
Old 02-28-2013, 04:16 AM   #3
Svt03focus
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109595
Location: Columbus, OH
What I Drive: 2003 black ZX3

Posts: 17
FF Reputation: 1 Svt03focus Good Standing Member
Buy-Sell-Trade Rating: (0)
I noticed that my feul pump wouldn't cycle and the mileage was just dots when turning the key on, for shits and giggles I disconnected the battery and tried again and the thing fired right up! Weird but I'm not complaining lol
Svt03focus is offline  
    Reply With Quote Quick reply to this message
Old 02-28-2013, 05:28 AM   #4
bluebullet
Focus Fanatic
 
bluebullet's Avatar
 
Join Date: Aug 2006
Fan#: 93387
Location: independence, MO
What I Drive: 2003 Twilight Blue zx5

Posts: 3,497
Points 4,667, Level 43
Points: 4,667, Level: 43 Points: 4,667, Level: 43 Points: 4,667, Level: 43
Level Up 59% Completed
Level up: 59% Level up: 59% Level up: 59%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 7 bluebullet Good Standing Member
Buy-Sell-Trade Rating: (4)
Quote:
Originally Posted by Svt03focus View Post
I noticed that my feul pump wouldn't cycle and the mileage was just dots when turning the key on, for shits and giggles I disconnected the battery and tried again and the thing fired right up! Weird but I'm not complaining lol
Awesome!!
Weir


Sent from Jeremy's iPhone
__________________
Hatch Nation #81
Mid-west Crew
2003 zx5 twilight blue
Quote:
Originally Posted by AvieF View Post
Bahahaha...bromance lol
Quote:
Originally Posted by pyroinsa View Post
when going Euro -always go full Euro
bluebullet is offline  
    Reply With Quote Quick reply to this message
Old 02-28-2013, 07:54 AM   #5
tukaniSVT
FF PHOTOG ENTHUSIAST
 
tukaniSVT's Avatar
 
Join Date: Mar 2004
Fan#: 5521
Location: SW Houston, TX
What I Drive: 2003 SVT Focus 2009 BMW 335i

Posts: 14,970
Points 36,339, Level 100
Points: 36,339, Level: 100 Points: 36,339, Level: 100 Points: 36,339, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 34 tukaniSVT Great Standing Member
Buy-Sell-Trade Rating: (1)
Interesting ... I guess you just needed to reset the ECU.

Did you not unplug the battery while the engine was apart?

Congrats either way of getting your car running. It's a great feeling. I have brought back my SVT in the past twice from engine failures.

Ray
__________________
Hatch Nation Member: #147

R.I.P - FELLOW FF MEMBER, IZZY, BLK2k3GTS, will always be remembered. We will compete on a different course again one day.
tukaniSVT is offline  
    Reply With Quote Quick reply to this message
Old 02-28-2013, 10:26 AM   #6
Svt03focus
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109595
Location: Columbus, OH
What I Drive: 2003 black ZX3

Posts: 17
FF Reputation: 1 Svt03focus Good Standing Member
Buy-Sell-Trade Rating: (0)
Nope I never unhooked it. I bought the thing for a steal thinking it was a timing belt but when I took off the belt cover it was not broken. Turns out the the previous owner over heated it so g bad the head gasket was actually inbeaded in the head, he fried all the valves and rings and I had to mill the head a lot, while I was at it I did new bearings, belt and water pump.
Svt03focus is offline  
    Reply With Quote Quick reply to this message
Old 02-28-2013, 08:09 PM   #7
Svt03focus
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109595
Location: Columbus, OH
What I Drive: 2003 black ZX3

Posts: 17
FF Reputation: 1 Svt03focus Good Standing Member
Buy-Sell-Trade Rating: (0)
So I have a few snags now, it's leaking oil. But not from anything I touched, there is a boxy looking thing in between the header and the block and there is a tube that goes into it from over the transmission. Idk what it is but it's leaking. Also I'm getting a cam over retarded bank 1 and cam over advanced bank 1 code. So I'm guessing the timing is off but it runs smooth. A little help here guys and girls
Svt03focus is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:34 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat