Mass Air Flow Sensor Question - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-15-2013, 07:45 PM   #1
Dardas
Focus Enthusiast
 
Dardas's Avatar
 
Join Date: Dec 2012
Fan#: 107673
Location: Glens Falls, NY
What I Drive: 2005 Saab 9-3 Turbo 5spd

Posts: 157
FF Reputation: 1 Dardas Good Standing Member
Buy-Sell-Trade Rating: (2)
Question Mass Air Flow Sensor Question

I had issues on startup with my car and found out that the mass air flow sensor was going wacky. I replaced it with an aftermarket sensor from Car Quest about a mounth ago.. it has been fine since i replaced it, except for tonight...

the same symptoms happened again when i started the car up tonight.. i start the car up and the rpms go up and down, then the car starts sputtering and shaking. it goes away after driving for a bit.

my question is, should i have gotten the motorcraft brand because im wondering if the MAFS i replaced is already gone bad.. its the same symptoms i had before unless there is another problem.

If you're wondering... i already replaced recently: air filter, fuel filter, plugs and wires, and added fuel injector cleaner about a month ago.

im wondering whats going on with my car...


Dardas is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-15-2013, 08:11 PM   #2
gonefhsn
BEWST AGAIN YAY!!!!!
 
gonefhsn's Avatar
 
Join Date: Apr 2007
Fan#: 45759
Location: Fort Knox, KY
What I Drive: 13 Tangerine Scream ST2,12 RAM 2500

Posts: 6,848
Points 95,704, Level 100
Points: 95,704, Level: 100 Points: 95,704, Level: 100 Points: 95,704, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 21 gonefhsn Great Standing Member
Buy-Sell-Trade Rating: (0)
It is possible you have a bad MAF again, I would check for vacuum leaks, or you have a bad connector or wire going to the MAF.
gonefhsn is offline  
    Reply With Quote Quick reply to this message
Old 02-15-2013, 08:41 PM   #3
Dardas
Focus Enthusiast
 
Dardas's Avatar
 
Join Date: Dec 2012
Fan#: 107673
Location: Glens Falls, NY
What I Drive: 2005 Saab 9-3 Turbo 5spd

Posts: 157
FF Reputation: 1 Dardas Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by gonefhsn View Post
It is possible you have a bad MAF again, I would check for vacuum leaks, or you have a bad connector or wire going to the MAF.
im almost positive its not a vacuum leak because they checked for that when i got it diagnosed.. im gonna get it checked out tomorrow. if that MAFS is bad im gonna be pissed cuz i paid $115 bucks for it.. i will bring it right back to car quest and tell them it didnt even last a month and they better do something for me. luckily i am friends with the owner of the store.
Dardas is offline  
    Reply With Quote Quick reply to this message
Old 02-15-2013, 09:13 PM   #4
1turbofocus
FF Affiliate
 
1turbofocus's Avatar
 
Join Date: Oct 2003
Fan#: 1123
Location: Belmont, NC
What I Drive: 2000 ZX3 / 2002 SVT Turbocharged

Posts: 22,205
Points 51,320, Level 100
Points: 51,320, Level: 100 Points: 51,320, Level: 100 Points: 51,320, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 32%
Activity: 32% Activity: 32% Activity: 32%
FF Reputation: 154 1turbofocus Excellent Standing Member 1turbofocus Excellent Standing Member
Buy-Sell-Trade Rating: (28)
Doesnt sound like a bad sensor at all to me , more like a bad o2 , I doubt you had a bad MAF sensor , I have seen on bad sensor in over 20 years of doing this and it got cracked some how then got water in it

Tom
__________________
Focus-Power: Your #1 Source for Ford Focus Speed, Tuning & Performance!

Customer Support
AIM: hpdyno
Email: hpdyno@aol.com
Phone: 704-249-3745
Site: focus-power.com

Elder 1turbofocus
1turbofocus is online now  
    Reply With Quote Quick reply to this message
Old 02-15-2013, 09:54 PM   #5
Dardas
Focus Enthusiast
 
Dardas's Avatar
 
Join Date: Dec 2012
Fan#: 107673
Location: Glens Falls, NY
What I Drive: 2005 Saab 9-3 Turbo 5spd

Posts: 157
FF Reputation: 1 Dardas Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by 1turbofocus View Post
Doesnt sound like a bad sensor at all to me , more like a bad o2 , I doubt you had a bad MAF sensor , I have seen on bad sensor in over 20 years of doing this and it got cracked some how then got water in it

Tom
im pretty sure it was the MAF cuz once i replaced it i had no problems with my car for almost 1 month.. and also the temp. was fluctuating from like 150-300 degrees the guy showed me with the diagnostic tool. if it was a bad O2 sensor which is possible, would the check light engine go on?? i didnt think an 02 sensor would cause the car to idle rough
Dardas is offline  
    Reply With Quote Quick reply to this message
Old 02-16-2013, 12:32 AM   #6
Deftmetal
Moderator
 
Deftmetal's Avatar
 
Join Date: Nov 2012
Fan#: 105884
Location: Pennant sk, Canada
What I Drive: 2014 Mazda 3

Posts: 7,444
Points 6,003, Level 50
Points: 6,003, Level: 50 Points: 6,003, Level: 50 Points: 6,003, Level: 50
Level Up 27% Completed
Level up: 27% Level up: 27% Level up: 27%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 9 Deftmetal Good Standing Member
Buy-Sell-Trade Rating: (3)
O2 sensors are cheep and they seem to me to be more important to the engine adjusting to different throttle positions. I'm no expert so just an opinion
__________________
Rally Revolution #14
Josh
Quote:
Originally Posted by dyn085 View Post
Don't hate on an amputee chick that's still playing with lego's.
Deftmetal is online now  
    Reply With Quote Quick reply to this message
Old 02-16-2013, 08:43 AM   #7
Dardas
Focus Enthusiast
 
Dardas's Avatar
 
Join Date: Dec 2012
Fan#: 107673
Location: Glens Falls, NY
What I Drive: 2005 Saab 9-3 Turbo 5spd

Posts: 157
FF Reputation: 1 Dardas Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by Deftmetal View Post
O2 sensors are cheep and they seem to me to be more important to the engine adjusting to different throttle positions. I'm no expert so just an opinion
Do you know if an aftermarket 02 sensor is ok to get vs. the ford brand?
Dardas is offline  
    Reply With Quote Quick reply to this message
Old 02-16-2013, 08:52 AM   #8
Deftmetal
Moderator
 
Deftmetal's Avatar
 
Join Date: Nov 2012
Fan#: 105884
Location: Pennant sk, Canada
What I Drive: 2014 Mazda 3

Posts: 7,444
Points 6,003, Level 50
Points: 6,003, Level: 50 Points: 6,003, Level: 50 Points: 6,003, Level: 50
Level Up 27% Completed
Level up: 27% Level up: 27% Level up: 27%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 9 Deftmetal Good Standing Member
Buy-Sell-Trade Rating: (3)
The last one I looked up for a focus was $40 and that was less than a month ago. Ford part. I don't know wether aftermarket is good or bad
__________________
Rally Revolution #14
Josh
Quote:
Originally Posted by dyn085 View Post
Don't hate on an amputee chick that's still playing with lego's.
Deftmetal is online now  
    Reply With Quote Quick reply to this message
Old 02-16-2013, 11:07 AM   #9
Milton
Focus Enthusiast
 
Join Date: Sep 2011
Fan#: 89715
Location: San Antonio, TX
What I Drive: 2007 Black Focus SES 2.0 L4 4 Door

Posts: 403
Points 302, Level 6
Points: 302, Level: 6 Points: 302, Level: 6 Points: 302, Level: 6
Level Up 4% Completed
Level up: 4% Level up: 4% Level up: 4%
Forum Activity 5%
Activity: 5% Activity: 5% Activity: 5%
FF Reputation: 8 Milton Good Standing Member
Buy-Sell-Trade Rating: (0)
Did you try cleaning the MAF?
Milton is offline  
    Reply With Quote Quick reply to this message
Old 02-16-2013, 11:43 AM   #10
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 Focus Wagon; 13 C-Max SEL

Posts: 20,272
Points 27,546, Level 98
Points: 27,546, Level: 98 Points: 27,546, Level: 98 Points: 27,546, Level: 98
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 13%
Activity: 13% Activity: 13% Activity: 13%
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member whynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
I don't personally recommend other brand O2 sensors.

Have you checked the price with our vendor Village Ford? Their prices are very low for factory parts. I would compare them with Rock Auto and go with the cheapest for the Motorcraft part. Really- you're not spending that much more for parts that you know will work well.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:28 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat