Catalytic Converter - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-15-2013, 10:14 PM   #1
cboeger
Focus Jr. Enthusiast
 
Join Date: Feb 2013
Fan#: 109912
Location: Olathe, KS
What I Drive: 2003 Ford Focus SE

Posts: 34
FF Reputation: 1 cboeger Good Standing Member
Buy-Sell-Trade Rating: (0)
Catalytic Converter

My light keeps coming on for Catalytic Converter Below Efficiency (Bank 1) or something (Code P0420), but I just drove 50 miles one way on the highway and looked under my hood and didn't see the CAT glowing red hot and then I just drove 50 miles back home on the highway again after the car sat for an hour or two driving the first 50 miles, and again i looked under the hood and the CAT wasn't glowing red still, do you think it's still the CAT that's bad or a faulty oxygen sensor?



Last edited by cboeger; 02-15-2013 at 10:15 PM. Reason: Better understanding
cboeger is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 02-15-2013, 10:18 PM   #2
sleepyboy
FF's Night Security
 
sleepyboy's Avatar
 
Join Date: Nov 2004
Fan#: 15335
Location: SW Houston, TX, United States
What I Drive: 01' Yellow ZX3 euro, 04' ZX5 SVT

Posts: 25,231
FF Reputation: 47 sleepyboy Great Standing Member
Buy-Sell-Trade Rating: (11)
I'd try the O2 sensor first and probably clean the Mass Airflow Sensor with mass airflow cleaner. Check out Rockauto they have great prices. I bought the NTK O2 sensor and it's identical to the OEM one.
__________________
I started out with nothing and I still have most of it left

Hatch Nation #15 (Ole' Yeller') & #150 (The SVT)
Moderator for
Technical Chat
Zetec Performance Chat
Southern Fanatics Chat
sleepyboy is online now  
    Reply With Quote
Old 02-15-2013, 10:32 PM   #3
cboeger
Focus Jr. Enthusiast
 
Join Date: Feb 2013
Fan#: 109912
Location: Olathe, KS
What I Drive: 2003 Ford Focus SE

Posts: 34
FF Reputation: 1 cboeger Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by sleepyboy View Post
I'd try the O2 sensor first and probably clean the Mass Airflow Sensor with mass airflow cleaner. Check out Rockauto they have great prices. I bought the NTK O2 sensor and it's identical to the OEM one.
its there an easy way to test if an O2 sensor is bad with a multimeter? Isn't it if you rev the engine and the O2 sensor doesn't move or goes above .9 or below .1 and doesnt stay between .1 and .9 then its bad?
cboeger is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:31 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.