04 instrument cluster flashes then goes out. - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus SVT > SVT Interior Mods & Upgrades

SVT Interior Mods & Upgrades The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the 2002-204 SVT Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-12-2013, 12:57 AM   #1
Sampsonite
Focus Jr. Enthusiast
 
Sampsonite's Avatar
 
Join Date: Oct 2010
Fan#: 79339
Location: Virginia Beach, VA
What I Drive: 2004 Black EAP SVT 5dr

Posts: 27
FF Reputation: 1 Sampsonite Good Standing Member
Buy-Sell-Trade Rating: (0)
04 instrument cluster flashes then goes out.

I have had this issue since I have had the car. My instrument cluster will flash in and out then eventually go out for a long time. Eventually it will com back on but goes right back out. The needles still have a glow but its the green glow that goes out. This also happens in sync with my oil press and oil temp gauge doing the same. Any idea's?????


Sampsonite is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 02-12-2013, 11:01 AM   #2
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, Ohio, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,663
Points 12,527, Level 73
Points: 12,527, Level: 73 Points: 12,527, Level: 73 Points: 12,527, Level: 73
Level Up 20% Completed
Level up: 20% Level up: 20% Level up: 20%
Forum Activity 26%
Activity: 26% Activity: 26% Activity: 26%
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Moved to "General Technical Chat".
zetecDon is offline  
    Reply With Quote
Old 06-27-2013, 12:14 AM   #3
Sampsonite
Focus Jr. Enthusiast
 
Sampsonite's Avatar
 
Join Date: Oct 2010
Fan#: 79339
Location: Virginia Beach, VA
What I Drive: 2004 Black EAP SVT 5dr

Posts: 27
FF Reputation: 1 Sampsonite Good Standing Member
Buy-Sell-Trade Rating: (0)
Still looking for a solution.
Sampsonite is offline  
    Reply With Quote
Old 03-24-2014, 02:09 AM   #4
VAfromMN
Focus Enthusiast
 
Join Date: Mar 2005
Fan#: 20592
Location: Fredericksburg, VA, VA
What I Drive: '13 Focus ST & '04 Focus SVT

Posts: 264
Points 1,002, Level 17
Points: 1,002, Level: 17 Points: 1,002, Level: 17 Points: 1,002, Level: 17
Level Up 2% Completed
Level up: 2% Level up: 2% Level up: 2%
Forum Activity 1%
Activity: 1% Activity: 1% Activity: 1%
FF Reputation: 9 VAfromMN Good Standing Member
Buy-Sell-Trade Rating: (0)
I'm having the same problem with mine, and I believe it's only the SVT's that have the electroluminescent lighting. If you search the Forums for the EL/electroluminescent lighting you should find reference to an inverter that lives in the small SVT oil temp/oil pressure cluster. That's what's slowly dying. One person did have a workaround with a replacement inverter from a home entertainment system I think. Did you ever find a solution?
VAfromMN is offline  
    Reply With Quote
Old 03-24-2014, 02:15 AM   #5
sailor
"Elder"
 
sailor's Avatar
 
Join Date: Jun 2008
Fan#: 57268
Location: Williamsville, NY
What I Drive: 2004 Pitch Black ZTS 2.3 5spd.

Posts: 14,471
Points 9,766, Level 66
Points: 9,766, Level: 66 Points: 9,766, Level: 66 Points: 9,766, Level: 66
Level Up 29% Completed
Level up: 29% Level up: 29% Level up: 29%
Forum Activity 99%
Activity: 99% Activity: 99% Activity: 99%
FF Reputation: 70 sailor Excellent Standing Member
Buy-Sell-Trade Rating: (0)
Moved this to the SVT section, 'cause you can find more info. here on fixing it.

You could look in the MkI section as well, for info. on installing the SVT cluster in other cars. Those threads sometimes list the inverters that can be used to power the lights.

Last post had it right on the power coming from the gauge cluster from the info. I've found here before.

Luck
__________________
"Rubber Side Down"

S.R. #275
sailor is online now  
    Reply With Quote
Old 03-24-2014, 02:53 PM   #6
Sniper Focus
Focus Addict
 
Sniper Focus's Avatar
 
Join Date: Mar 2011
Fan#: 84221
Location: IL, IL
What I Drive: '03 SVT EAP "Eurotrish"

Posts: 1,311
Points 1,956, Level 26
Points: 1,956, Level: 26 Points: 1,956, Level: 26 Points: 1,956, Level: 26
Level Up 56% Completed
Level up: 56% Level up: 56% Level up: 56%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 20 Sniper Focus Great Standing Member
Buy-Sell-Trade Rating: (13)
You can use any universal inverter like this.
http://www.ebay.com/itm/UNIVERSAL-EL...fe16e9&vxp=mtr
__________________
Fox Hound: Liquid Stang - Sniper Focus - Decoy Escort (or was it a Tracer...)
Sniper Focus is offline  
    Reply With Quote
Old 03-24-2014, 02:56 PM   #7
ShadowFocus603
Focus Enthusiast
 
ShadowFocus603's Avatar
 
Join Date: Aug 2013
Fan#: 118448
Location: Littleton, NH
What I Drive: 2004 Pitch Black SVT EAP 2Dr #1878

Posts: 266
Points 546, Level 10
Points: 546, Level: 10 Points: 546, Level: 10 Points: 546, Level: 10
Level Up 92% Completed
Level up: 92% Level up: 92% Level up: 92%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 ShadowFocus603 Good Standing Member
Buy-Sell-Trade Rating: (1)
I tried replacing my headlight switch which was the common answer I found all over and it worked for awhile but started acting up again. From what I have read there is an inverter or some such in the cluster up by the 2 auxiliary gauges that can be replaced as well though I haven't tried that yet. My car also has a tachometer that intermittently pegs up and down and jumps around. Both problems only occur when the car has been running for awhile (~30 minutes or more) so I am fairly certain the issues are caused by some unknown as of yet electrical component that glitches after it gets hot.
__________________
2004 Ford Focus SVT #1878
ShadowFocus603 is offline  
    Reply With Quote
Old 03-27-2014, 10:24 PM   #8
Ptreezx3
Focus Enthusiast
 
Ptreezx3's Avatar
 
Join Date: Apr 2012
Fan#: 97773
Location: Lorain, OH
What I Drive: 2003 red svt, 06 blue escape,

Posts: 63
Points 61, Level 1
Points: 61, Level: 1 Points: 61, Level: 1 Points: 61, Level: 1
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Ptreezx3 Good Standing Member
Buy-Sell-Trade Rating: (2)
Its your aux gauge either needs replaced or universal inverter. Mine hsd same issue and this site told me it was that and when I replaced aux gauge problem solved
Ptreezx3 is offline  
    Reply With Quote
Old 03-28-2014, 04:33 AM   #9
ShadowFocus603
Focus Enthusiast
 
ShadowFocus603's Avatar
 
Join Date: Aug 2013
Fan#: 118448
Location: Littleton, NH
What I Drive: 2004 Pitch Black SVT EAP 2Dr #1878

Posts: 266
Points 546, Level 10
Points: 546, Level: 10 Points: 546, Level: 10 Points: 546, Level: 10
Level Up 92% Completed
Level up: 92% Level up: 92% Level up: 92%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 ShadowFocus603 Good Standing Member
Buy-Sell-Trade Rating: (1)
When you say Aux gauge are you talking about the oil temp and pressure gauges in the corner of the cluster or?
__________________
2004 Ford Focus SVT #1878
ShadowFocus603 is offline  
    Reply With Quote
Old 03-28-2014, 07:26 AM   #10
Ptreezx3
Focus Enthusiast
 
Ptreezx3's Avatar
 
Join Date: Apr 2012
Fan#: 97773
Location: Lorain, OH
What I Drive: 2003 red svt, 06 blue escape,

Posts: 63
Points 61, Level 1
Points: 61, Level: 1 Points: 61, Level: 1 Points: 61, Level: 1
Level Up 22% Completed
Level up: 22% Level up: 22% Level up: 22%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 Ptreezx3 Good Standing Member
Buy-Sell-Trade Rating: (2)
Yea. The inverter is in the small gauge cluster. Thats what goes bad in it and without it no indiglow gauges
Ptreezx3 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:09 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.