Sohc help - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-06-2013, 03:40 PM   #1
Ledgerwood_joey
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109587
Location: Visalia, CA
What I Drive: 2000, black ford focus 2.0l sohc

Posts: 6
FF Reputation: 1 Ledgerwood_joey Good Standing Member
Buy-Sell-Trade Rating: (0)
Post Sohc help

My focus drives good and it has a check engine light on for the speed control sensore but it also vibrates the whole car as soon as I hit the gas pedal, it's quiet in nuetral and at really low rpms but it gets louder the faster I drive, and if I downshift and then push the clutch in it dies sometimes, only when I'm speedometers not working and I have no idea what would make it vibrate that bad


Ledgerwood_joey is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-06-2013, 03:49 PM   #2
crazy_urn
Capt. Urn
 
crazy_urn's Avatar
 
Join Date: Dec 2003
Fan#: 1986
Location: Uncharted Waters, CO
What I Drive: 77 F-250, 10 HHR, 08 Outlook

Posts: 5,491
FF Reputation: 5 crazy_urn Good Standing Member
Buy-Sell-Trade Rating: (2)
Since your CEL says speed control sensor, I would start there. that can cause vibrations and stalls, and other engine issues. Can also cause you to hit governor because the car thinks you are going over 108.

Then, see what problems that clears up and what problems remain. The vibration may be related, it may be separate.
__________________
Defending the reputation of the red-headed step-child of the focus world for far too long.
crazy_urn is offline  
    Reply With Quote Quick reply to this message
Old 02-06-2013, 06:30 PM   #3
Ledgerwood_joey
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109587
Location: Visalia, CA
What I Drive: 2000, black ford focus 2.0l sohc

Posts: 6
FF Reputation: 1 Ledgerwood_joey Good Standing Member
Buy-Sell-Trade Rating: (0)
Ya ill fix that and see cus my governor doesn't work I've gone 125 and it was still accelerating and it never cut out
Ledgerwood_joey is offline  
    Reply With Quote Quick reply to this message
Old 02-06-2013, 11:28 PM   #4
calebstubstad
Chef Boyardee
 
calebstubstad's Avatar
 
Join Date: Aug 2012
Fan#: 103240
Location: Fargo, ND
What I Drive: 2000 Atlantic Blue LX

Posts: 2,707
FF Reputation: 4 calebstubstad Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by Ledgerwood_joey View Post
Ya ill fix that and see cus my governor doesn't work I've gone 125 and it was still accelerating and it never cut out
with the SPI? not rippin on ya, i have the same engine..
__________________
Rally Revolution #43
[HOONIGAN]
Quote:
Originally Posted by matmatician View Post
Not the bear the zoo deserves, but the bear the zoo needs.
calebstubstad is offline  
    Reply With Quote Quick reply to this message
Old 02-07-2013, 03:21 AM   #5
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, Ohio, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,694
Points 12,566, Level 73
Points: 12,566, Level: 73 Points: 12,566, Level: 73 Points: 12,566, Level: 73
Level Up 29% Completed
Level up: 29% Level up: 29% Level up: 29%
Forum Activity 31%
Activity: 31% Activity: 31% Activity: 31%
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Moved to "General Technical Chat".
zetecDon is offline  
    Reply With Quote Quick reply to this message
Old 02-07-2013, 02:50 PM   #6
crazy_urn
Capt. Urn
 
crazy_urn's Avatar
 
Join Date: Dec 2003
Fan#: 1986
Location: Uncharted Waters, CO
What I Drive: 77 F-250, 10 HHR, 08 Outlook

Posts: 5,491
FF Reputation: 5 crazy_urn Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by Ledgerwood_joey View Post
Ya ill fix that and see cus my governor doesn't work I've gone 125 and it was still accelerating and it never cut out
Might be related to the problem with the speed sensor.... My needle has hit 140, but I definitely was not going that fast.

I know when I hit 108 in my SPI (legally on the track of course, moderators ) there did not seem to be a whole lot left. I could not image getting it up to 125.

Not calling you a liar, just saying it does not jive with my experience.

hope the sensor fixes your issues. let us know.
__________________
Defending the reputation of the red-headed step-child of the focus world for far too long.
crazy_urn is offline  
    Reply With Quote Quick reply to this message
Old 02-08-2013, 08:45 AM   #7
Ledgerwood_joey
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109587
Location: Visalia, CA
What I Drive: 2000, black ford focus 2.0l sohc

Posts: 6
FF Reputation: 1 Ledgerwood_joey Good Standing Member
Buy-Sell-Trade Rating: (0)
Well I'm ordering the part today and I'm almost positive it won't die when it drops rpms because that sensor is like the middle man of the engine and ecu, but my main problem is the really bad vibrating I checked the motor mounts and they seemed fine. Should I still replace them? And for the last 10000 miles the motors been making a ticking noise like the valve seats going out but it's still goin down the road
Ledgerwood_joey is offline  
    Reply With Quote Quick reply to this message
Old 02-08-2013, 08:47 AM   #8
Ledgerwood_joey
Focus Rookie
 
Join Date: Feb 2013
Fan#: 109587
Location: Visalia, CA
What I Drive: 2000, black ford focus 2.0l sohc

Posts: 6
FF Reputation: 1 Ledgerwood_joey Good Standing Member
Buy-Sell-Trade Rating: (0)
And the most important question is should I get the block and head rebuilt or should I just sell the car because its online for $2000 and no one wants it
Ledgerwood_joey is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:19 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.