Inside C-Pillar Fitment Issue - Focus Fanatics
Focus Fanatics Ford Focus Forums
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Model Specific Discussions > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 02-06-2013, 12:04 PM   #1
dragonpalm
Focus Enthusiast
 
dragonpalm's Avatar
 
Join Date: Sep 2012
Fan#: 104183
Location: San Antonio, TX
What I Drive: 2013 White Platinum Titanium Sedan

Posts: 180
FF Reputation: 3 dragonpalm Good Standing Member
Buy-Sell-Trade Rating: (0)
Inside C-Pillar Fitment Issue



My car is a 2013 titanium sedan.

I just noticed this today. It's the inside c-pillar on the left side of the car above the rear seat. Firmly pressing it will not keep the plastic together. It seems like the headliner is forcing the plastic apart and the tabs won't lock. My car is 5 months old and has not been in any accidents.

Has anyone else seen this before?


dragonpalm is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 02-06-2013, 12:17 PM   #2
cobie56
Focus Fanatic
 
Join Date: Mar 2011
Fan#: 84403
Location: northeastern, NY
What I Drive: '01 ZX3, '14 Civic XL '12 SEL

Posts: 1,553
FF Reputation: 2 cobie56 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by dragonpalm View Post


My car is a 2013 titanium sedan.

I just noticed this today. It's the inside c-pillar on the left side of the car above the rear seat. Firmly pressing it will not keep the plastic together. It seems like the headliner is forcing the plastic apart and the tabs won't lock. My car is 5 months old and has not been in any accidents.

Has anyone else seen this before?
i had a similiar thing on my sedan only w/ the passenger A pillar... turns out at the factory a clip was broken and so it would not stay in place... Dealer ordered a new one and now it's fine..
cobie56 is online now  
    Reply With Quote
Old 02-06-2013, 12:24 PM   #3
5characters
No Mo Fo Fo
 
5characters's Avatar
 
Join Date: Sep 2010
Fan#: 78897
Location: Pickerington, OH
What I Drive: 2012 M2 Touring

Posts: 3,242
FF Reputation: 2 5characters Good Standing Member
Buy-Sell-Trade Rating: (0)
Have the dealer fix it, should be under warrenty.
__________________
Just bring me coffee!
5characters is offline  
    Reply With Quote
Old 02-06-2013, 12:56 PM   #4
dragonpalm
Focus Enthusiast
 
dragonpalm's Avatar
 
Join Date: Sep 2012
Fan#: 104183
Location: San Antonio, TX
What I Drive: 2013 White Platinum Titanium Sedan

Posts: 180
FF Reputation: 3 dragonpalm Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by 5characters View Post
Have the dealer fix it, should be under warrenty.
I know it is but I want to know what caused it. Although I'm not 100% sure, I don't think it was like this when I bought it.
dragonpalm is offline  
    Reply With Quote
Old 02-06-2013, 01:01 PM   #5
RAF_S197
Focus Addict
 
RAF_S197's Avatar
 
Join Date: Nov 2011
Fan#: 91991
Location: Buffalo/Toronto, NY
What I Drive: 2014 Oxford white Sport Black Pack

Posts: 1,286
FF Reputation: 21 RAF_S197 Great Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by 5characters View Post
have the dealer fix it, should be under warrenty.
x2
_____
__________________
2014 Oxford white Focus SE Sport Black pack
Instagram: 5_POINTOH
RAF_S197 is online now  
    Reply With Quote
Old 02-06-2013, 01:16 PM   #6
cobie56
Focus Fanatic
 
Join Date: Mar 2011
Fan#: 84403
Location: northeastern, NY
What I Drive: '01 ZX3, '14 Civic XL '12 SEL

Posts: 1,553
FF Reputation: 2 cobie56 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by dragonpalm View Post
I know it is but I want to know what caused it. Although I'm not 100% sure, I don't think it was like this when I bought it.
see my post above.. probably the same issue.. broken clip from factory...
cobie56 is online now  
    Reply With Quote
Old 02-06-2013, 02:44 PM   #7
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,063
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by dragonpalm View Post

My car is a 2013 titanium sedan.

I just noticed this today. It's the inside c-pillar on the left side of the car above the rear seat. Firmly pressing it will not keep the plastic together. It seems like the headliner is forcing the plastic apart and the tabs won't lock...
Hi dragonpalm,

I encourage you to make an appointment so your dealership can inspect and repair your Focus. Additionally, I'm happy to get this issue into the hands of your regional customer service manager. To get the ball rolling, just send me a PM with your VIN, dealer, mileage, daytime phone number, and full name; I'll handle the rest!

Crystal
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordService is offline  
    Reply With Quote
Old 02-06-2013, 02:44 PM   #8
zehkaiser
Focus Enthusiast
 
Join Date: May 2012
Fan#: 98706
Location: Fletcher, NC
What I Drive: 2012 Tux Black Focus Titanium Hatch

Posts: 136
FF Reputation: 1 zehkaiser Good Standing Member
Buy-Sell-Trade Rating: (0)
Both rear pillars (C and D?) on my 2012 Ti Hatch were back. Dealer replaced both. I guess the manufacturing process is a bit weak there.
zehkaiser is offline  
    Reply With Quote
Old 02-06-2013, 02:48 PM   #9
dragonpalm
Focus Enthusiast
 
dragonpalm's Avatar
 
Join Date: Sep 2012
Fan#: 104183
Location: San Antonio, TX
What I Drive: 2013 White Platinum Titanium Sedan

Posts: 180
FF Reputation: 3 dragonpalm Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by zehkaiser View Post
Both rear pillars (C and D?) on my 2012 Ti Hatch were back. Dealer replaced both. I guess the manufacturing process is a bit weak there.
On mine, only the driver's side rear pillar is bad. The other is fine.
dragonpalm is offline  
    Reply With Quote
Old 02-07-2013, 07:22 AM   #10
zehkaiser
Focus Enthusiast
 
Join Date: May 2012
Fan#: 98706
Location: Fletcher, NC
What I Drive: 2012 Tux Black Focus Titanium Hatch

Posts: 136
FF Reputation: 1 zehkaiser Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by dragonpalm View Post
On mine, only the driver's side rear pillar is bad. The other is fine.
When I first bought the car only one was bad. After 6 months the other side came loose and wouldn't go back. Just keep an eye on them from your rear view mirror.
zehkaiser is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:44 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX. You can find all Ford Focus related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.