Problem with interior lighting - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 12-30-2013, 01:15 PM   #1
bdmc55
Focus Rookie
 
Join Date: Dec 2013
Fan#: 131721
Location: Cary, IL
What I Drive: 2013 Tuxedo Black Metallic Focus SE

Posts: 2
FF Reputation: 1 bdmc55 Good Standing Member
Buy-Sell-Trade Rating: (0)
Exclamation Problem with interior lighting

Hey guys. I have a 2013 Focus SE with a 5-speed. has 14k miles on it. The other day I noticed that the lighting on the visor for the mirror would not work. Upon further inspection, I realized that the overhead dome lighting wasn't working, and I have no backlighting behind my steering wheel controls, the manual climate control dials, the light on the rear window defroster (to tell you when it's on), and the Max Air/Recirculation and A/C buttons do not work and also do not have a functioning light. The light in the glovebox does not work either. In other words,the only lighting that actually is working correctly is my gauge cluster and the infotainment screen and radio control buttons in the center console. Also, the blower position is now stuck on defrost, no matter whether i set it to blow on feet or face. The knob for blower speed and air temp both work, however. I've already turned off and on the car quite a few times, hoping maybe it would just reset something. The temperature is quite cold here in Chicago (when i left for work today it was -6F), but i've never had a problem with this in any other car. I thought maybe it was a fuse, and tried swapping the fuse that controls the glove box lighting for another fuse of same amperage, no luck. My limited knowledge of electrical stuff stopped at that. Does anybody have any suggestions? It's really friggen cold when only the defroster works.


bdmc55 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 12-30-2013, 02:08 PM   #2
mittencuh
Focus Enthusiast
 
Join Date: Oct 2013
Fan#: 120274
Location: Colorado Springs, CO
What I Drive: 2013 Titanium hatch 5 speed

Posts: 89
FF Reputation: 1 mittencuh Good Standing Member
Buy-Sell-Trade Rating: (0)
I think with so many lights out that you should just take it to the dealer honestly. With so many lights out I feel it could be an electrical issue deeper than just a fuse or something.
mittencuh is offline  
    Reply With Quote
Old 12-30-2013, 10:07 PM   #3
dbenney
Focus Enthusiast
 
Join Date: Oct 2003
Fan#: 1195
Location: Lansing, MI
What I Drive: 2012 Tuxedo Black SEL

Posts: 273
FF Reputation: 5 dbenney Good Standing Member
Buy-Sell-Trade Rating: (0)
you have a light in the glove box???? i have a 2012 SEL loaded with almost every option and i dont have that.
dbenney is offline  
    Reply With Quote
Old 12-30-2013, 11:28 PM   #4
SilverPony2001
Focus Addict
 
SilverPony2001's Avatar
 
Join Date: Aug 2005
Fan#: 27073
Location: Naperville, IL
What I Drive: 2013 SGM Sedan SE

Posts: 1,358
FF Reputation: 8 SilverPony2001 Good Standing Member
Buy-Sell-Trade Rating: (2)
Quote:
Originally Posted by dbenney View Post
you have a light in the glove box???? i have a 2012 SEL loaded with almost every option and i dont have that.
As far as I know, NO Foci in the US have a lighted glovebox. It's a euro option I think. However, there is a fuse that says "lighted glovebox" that also controls a couple other lights in the interior.
SilverPony2001 is online now  
    Reply With Quote
Old 12-31-2013, 06:15 AM   #5
BetaDnB
Drum n Bass Lover
 
BetaDnB's Avatar
 
Join Date: Jul 2011
Fan#: 87466
Location: Buffalo, NY
What I Drive: 2012 Silver SE Sport

Posts: 1,947
FF Reputation: 11 BetaDnB Great Standing Member
Buy-Sell-Trade Rating: (0)
The light in the glove compartment is working exactly as designed.
__________________
Sedan Revolution #249 - 2012 SE Sport - ╠╬╝ - Ingot Silver - 201A - K&N w/ snorkel delete - Blox Type R Knob
BetaDnB is online now  
    Reply With Quote
Old 01-08-2014, 07:24 AM   #6
bdmc55
Focus Rookie
 
Join Date: Dec 2013
Fan#: 131721
Location: Cary, IL
What I Drive: 2013 Tuxedo Black Metallic Focus SE

Posts: 2
FF Reputation: 1 bdmc55 Good Standing Member
Buy-Sell-Trade Rating: (0)
Thanks for the advice guys. Took it to the dealer, ended up being a blown fuse for the rear defroster, and a pinched wire behind the dash that was causing a short for the lighting. Took them 2 hours to fix.
bdmc55 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:52 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.