2002 zx3 rpm drops and it turns off - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 05-20-2013, 12:11 PM   #1
Stitch518
Focus Enthusiast
 
Join Date: May 2013
Fan#: 114858
Location: Tampa, FL
What I Drive: 2002 Blue Zx3

Posts: 146
FF Reputation: 1 Stitch518 Good Standing Member
Buy-Sell-Trade Rating: (2)
2002 zx3 rpm drops and it turns off

Hey everyone just need some fresh ideas im really confused here i have a 2002 focus zx3 starts up fine everytime drives great except when i slow down it drops rpm too low and turns off whether im at a light or slowing to make a turn or what ever the reason is that i slow down it drops rpm then shuts off does anyone have any ideas at all it would be much appreiciated thank you very much!


Stitch518 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 05-20-2013, 06:15 PM   #2
JFrye
Focus Enthusiast
 
JFrye's Avatar
 
Join Date: Apr 2008
Fan#: 54896
Location: Mexico, MO
What I Drive: 2000 ZX3, 99 Dodge 3500 w/Cummins

Posts: 440
FF Reputation: 3 JFrye Good Standing Member
Buy-Sell-Trade Rating: (6)
Do you have a way to check codes? If not, you should be able to go to a local parts store, and they can read the codes for you. That way we can tell if you have a bad sensor somewhere. If you dont, then you might need to check for vacuum leaks.
__________________
2000 Silver ZX3. 2.0 Zetec, Auto trans with 3.90 gears. 14 inch steelies, P185/65R14 Firestone Affinity Touring Tires. Eibach Sportlines, Massive Upper Strut Bar, BBK 65mm Throttle Body, FSWerks 4 to 1 Header, Custom 2.5 inch into 3 inch exhaust.
JFrye is offline  
    Reply With Quote
Old 05-20-2013, 07:05 PM   #3
amc49
Focus Fanatic
 
Join Date: Mar 2012
Fan#: 96610
Location: Fort Worth, TX
What I Drive: 00 wagon, 02 sedan both zetec atx

Posts: 4,797
FF Reputation: 23 amc49 Great Standing Member
Buy-Sell-Trade Rating: (0)
Manifold pcv hose, IAC, TPS.
amc49 is online now  
    Reply With Quote
Old 05-20-2013, 09:09 PM   #4
Kodyston
Focus Enthusiast
 
Kodyston's Avatar
 
Join Date: Mar 2013
Fan#: 112498
Location: Hillsville, VA
What I Drive: 2003 Sangria Red ZX3; Zetec; MTX-75

Posts: 413
FF Reputation: 3 Kodyston Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by amc49 View Post
Manifold pcv hose, IAC, TPS.
amc49 beat me to it. Definitely check these. I would think mostly the IAC. Here are what the acronyms mean if you don't know. IAC (Idle Air Control sensor/valve). TPS (Throttle Positioning Sensor)
Kodyston is offline  
    Reply With Quote
Old 05-21-2013, 12:40 PM   #5
zetecDon
Where am I?
 
zetecDon's Avatar
 
Join Date: Feb 2009
Fan#: 62506
Location: east of Cincinnati, Ohio, OH
What I Drive: 02 ZX3, 02 MX-5

Posts: 7,547
FF Reputation: 28 zetecDon Great Standing Member
Buy-Sell-Trade Rating: (45)
Moved to "General Technical Chat".
zetecDon is offline  
    Reply With Quote
Old 05-21-2013, 12:56 PM   #6
my_beautious_ZX3
Focus Addict
 
Join Date: Feb 2006
Fan#: 32386
Location: Chicago, IL
What I Drive: 2002 charcoal XZ3

Posts: 745
FF Reputation: 5 my_beautious_ZX3 Good Standing Member
Buy-Sell-Trade Rating: (0)
...oh, and welcome to the forum!

__________________
"I'm jealous of girls because they get to wear dresses." (Todd Flanders)
my_beautious_ZX3 is offline  
    Reply With Quote
Old 05-23-2013, 01:18 PM   #7
cheap sleeper
Focus Enthusiast
 
cheap sleeper's Avatar
 
Join Date: Oct 2008
Fan#: 59848
Location: florida, FL
What I Drive: 2001 black zx3

Posts: 326
FF Reputation: 3 cheap sleeper Good Standing Member
Buy-Sell-Trade Rating: (0)
amc's post, and make sure you run out all the fuel you have in there now down to below 'E' and refill at a different gas station with 87 ONLY. Some people try and use 89 or 93, but your car will not idle very well (or at all) with higher octane fuels so it will exhibit this exact problem if you have anything higher than 87 in it as all foci (exc. SVT and F.I.'d) are tuned for 87. Or, depending on your mileage, you could have a clogged fuel filter or fuel screen inside the tank on the pump. Did you ever get the original pump replaced on recall? My original failed at 108k. Also I have heard of places that sell their higher octanes as 87 when they run out of it. You coulda possibly got gas at one of those places pulling a sneaky one to keep selling fuel when they run out of 87!
cheap sleeper is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:33 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.