After replacing my alternator, my airbag light went out. Huh??? - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 01-10-2008, 10:52 AM   #1
quick01
Focus Enthusiast
 
Join Date: May 2006
Fan#: 35405
Location: Woodstock GA
What I Drive: 05' Red ZX5 SE

Posts: 89
FF Reputation: 1 quick01 Good Standing Member
Buy-Sell-Trade Rating: (0)
After replacing my alternator, my airbag light went out. Huh???

Can anyone please explain this one to me? Had to have my original alternator replaced this week at the 75K mark. For the last 10K miles my Air Bag light has been flashing once and staying on intermittently. The car has never been in an accident, nor the seats removed. Since it was never on more than 2 or 3 times a week and I couldn’t afford the dealership diagnostic fee, I decided to just ignore it. After having the OEM alternator replaced on Monday the light has not come back on. Don't get me wrong, I'm glad it's staying off but has anyone had this happen or maybe can offer an explanation?


__________________
"War Eagle!"
quick01 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-10-2008, 11:29 AM   #2
290
Focus Enthusiast
 
290's Avatar
 
Join Date: Jan 2008
Fan#: 52633
Location: Sterling Heights, MI
What I Drive: 2008 Black SE

Posts: 117
FF Reputation: 1 290 Good Standing Member
Buy-Sell-Trade Rating: (0)
When the alternator was replaced you disconnected the battery and the ECU lost its engine tune data and any saved codes, say for instance... an airbag error code. If it hasnt come back on then the problem must have resolved itself or its waiting for the right moment to show itself again.
__________________
2008 Focus SE Deluxe MTX - The Mine
2008 Focus SES ATX - The Wifes
1995 Taurus SHO MTX - The For Sale
290 is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2008, 11:37 AM   #3
misfire
Moderator
 
misfire's Avatar
 
Join Date: Jan 2006
Fan#: 31379
Location: West Chester, PA
What I Drive: 2012 SEL Hatch, 2014 Mazda CX-5

Posts: 16,111
Points 16,915, Level 83
Points: 16,915, Level: 83 Points: 16,915, Level: 83 Points: 16,915, Level: 83
Level Up 13% Completed
Level up: 13% Level up: 13% Level up: 13%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 31 misfire Great Standing Member
Buy-Sell-Trade Rating: (13)
or if there wasn't enough voltage to the airbag module because of the bad alternator, it'll cause the light to come.
__________________
Will aka Misfire
2003 LX "traded in"/2010 SES "traded in"/2012 SEL Hatch "current"
misfire is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2008, 11:41 AM   #4
290
Focus Enthusiast
 
290's Avatar
 
Join Date: Jan 2008
Fan#: 52633
Location: Sterling Heights, MI
What I Drive: 2008 Black SE

Posts: 117
FF Reputation: 1 290 Good Standing Member
Buy-Sell-Trade Rating: (0)
^ or that
__________________
2008 Focus SE Deluxe MTX - The Mine
2008 Focus SES ATX - The Wifes
1995 Taurus SHO MTX - The For Sale
290 is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2008, 11:56 AM   #5
quick01
Focus Enthusiast
 
Join Date: May 2006
Fan#: 35405
Location: Woodstock GA
What I Drive: 05' Red ZX5 SE

Posts: 89
FF Reputation: 1 quick01 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by focusp71 View Post
or if there wasn't enough voltage to the airbag module because of the bad alternator, it'll cause the light to come.
Hmm...so maybe I could use this as troubleshooting tool to let me know when my amps have burned up another alternator.

If the light stays off, that is.
__________________
"War Eagle!"
quick01 is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2008, 11:59 AM   #6
quick01
Focus Enthusiast
 
Join Date: May 2006
Fan#: 35405
Location: Woodstock GA
What I Drive: 05' Red ZX5 SE

Posts: 89
FF Reputation: 1 quick01 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by 290 View Post
When the alternator was replaced you disconnected the battery and the ECU lost its engine tune data and any saved codes, say for instance... an airbag error code. If it hasnt come back on then the problem must have resolved itself or its waiting for the right moment to show itself again.
Actually the battery was disconnected for 4-6 hours while my two fosgate amps were installed 6 months ago.
__________________
"War Eagle!"
quick01 is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2008, 12:03 PM   #7
scalderon
Focus Enthusiast
 
scalderon's Avatar
 
Join Date: Jun 2004
Fan#: 9988
Location: Oceanside/Los Angeles, CA
What I Drive: 2001 silver zx3

Posts: 472
FF Reputation: 5 scalderon Good Standing Member
Buy-Sell-Trade Rating: (2)
my light is on and has been for about two years now, i just ignore it. i have disconnected the battery, although not longer than maybe an hour. I haven't checked my voltage lately but i'm sure its getting enough...glad that worked for you though.
__________________
Leatherneck
scalderon is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2008, 12:06 PM   #8
misfire
Moderator
 
misfire's Avatar
 
Join Date: Jan 2006
Fan#: 31379
Location: West Chester, PA
What I Drive: 2012 SEL Hatch, 2014 Mazda CX-5

Posts: 16,111
Points 16,915, Level 83
Points: 16,915, Level: 83 Points: 16,915, Level: 83 Points: 16,915, Level: 83
Level Up 13% Completed
Level up: 13% Level up: 13% Level up: 13%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 31 misfire Great Standing Member
Buy-Sell-Trade Rating: (13)
Quote:
Originally Posted by scalderon View Post
my light is on and has been for about two years now, i just ignore it. i have disconnected the battery, although not longer than maybe an hour. I haven't checked my voltage lately but i'm sure its getting enough...glad that worked for you though.
ignore it only if you don't care that in the event of an accident an airbag may not deploy if there is a problem.
__________________
Will aka Misfire
2003 LX "traded in"/2010 SES "traded in"/2012 SEL Hatch "current"
misfire is offline  
    Reply With Quote Quick reply to this message
Old 01-10-2008, 12:09 PM   #9
faster_than_u
anti svt
 
Join Date: Nov 2006
Fan#: 41017
Location: hell., United States
What I Drive: focus

Posts: 2,731
FF Reputation: 12 faster_than_u Great Standing Member
Buy-Sell-Trade Rating: (6)
mine came on a year ago. i just put electrical tape over the light.
__________________
ZC#200
faster_than_u is offline  
    Reply With Quote Quick reply to this message
Old 01-14-2008, 06:58 AM   #10
quick01
Focus Enthusiast
 
Join Date: May 2006
Fan#: 35405
Location: Woodstock GA
What I Drive: 05' Red ZX5 SE

Posts: 89
FF Reputation: 1 quick01 Good Standing Member
Buy-Sell-Trade Rating: (0)
-UPDATE-

Oops, spoke too soon! The light came on and stayed on for the first time all the way home from work on Friday. However, it did not come on Saturday or Sunday. Looks like I might be back to the status quo.

:( ...Oooh well...
__________________
"War Eagle!"

Last edited by quick01; 01-14-2008 at 08:36 AM.
quick01 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Airbag light won't turn off!! rabidcrow General Technical Chat 4 01-05-2005 09:01 PM
Airbag light won't turn off!! rabidcrow General Technical Chat 21 01-04-2005 08:59 PM
Key Won't Go In Ignition, Airbag Light On FocusOfRock General Technical Chat 5 09-29-2004 07:33 PM
Flashing Airbag Warning Light on Focus PlatinumPlug General Technical Chat 18 07-07-2004 11:11 PM
airbag light Fabster82 Ford Focus & General Car Chat 12 12-29-2003 02:41 PM


All times are GMT -5. The time now is 07:40 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat