Oil light stays on for 1-2sec - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Third Generation > MK3 Focus

MK3 Focus The place to chat about general questions, window tinting, exterior body, interior and lighting upgrades for the third generation 2012-Current Focus.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 06-29-2014, 02:07 PM   #1
GeorgeFocusmk3`
Focus Rookie
 
Join Date: Jun 2014
Fan#: 173209
Location: Athens, Greece
What I Drive: Ford Focus Ecoboost 1.0 125hp Black

Posts: 4
FF Reputation: 1 GeorgeFocusmk3` Good Standing Member
Buy-Sell-Trade Rating: (0)
Oil light stays on for 1-2sec

Hello guys i am a new member here in the forum. I bought a new Ford Focus 1.0cc with the 125hp.The car has about 14.000km and lately i notice that in the morning the oil pressure light stays on for about one or two secs and then goes off. Because i know that oil(Castrol ecoboost 5w 20) is the blood of the engine i have made two changes of oil and filter every 6000km.I have mention to the dealer the above problem with the oil pressure light and told me that is nothing to worry about.Does anyone have a similar problem?


GeorgeFocusmk3` is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 06-29-2014, 05:15 PM   #2
wavsine
Focus Addict
 
wavsine's Avatar
 
Join Date: Sep 2013
Fan#: 118470
Location: DFW, TX
What I Drive: 2013 Focus SE Oxford White Hatch 5m

Posts: 665
FF Reputation: 9 wavsine Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by GeorgeFocusmk3` View Post
Hello guys i am a new member here in the forum. I bought a new Ford Focus 1.0cc with the 125hp.The car has about 14.000km and lately i notice that in the morning the oil pressure light stays on for about one or two secs and then goes off. Because i know that oil(Castrol ecoboost 5w 20) is the blood of the engine i have made two changes of oil and filter every 6000km.I have mention to the dealer the above problem with the oil pressure light and told me that is nothing to worry about.Does anyone have a similar problem?
Hi George, I do not have experience with that particular engine but as a rule, the only time an oil light should stay on for 2 seconds is after an oil change when the oil filter is filling.

The oil light on my 2.0 GDI engine goes out almost instantly.

I would investigate this.
__________________
Use a Motorcraft FL-400S filter to increase filtration media and oil quantity. (Drop in for FL-910S)

Synthetic oil in GDI engines
www.focusfanatics.com/forum/showthread.php?t=324396
wavsine is online now  
    Reply With Quote
Old 06-29-2014, 05:56 PM   #3
chemistkremer
Focus Enthusiast
 
Join Date: Dec 2013
Fan#: 131121
Location: York, PA
What I Drive: 2012 Oxford White SEL

Posts: 121
FF Reputation: 1 chemistkremer Good Standing Member
Buy-Sell-Trade Rating: (0)
It's harder to tell on a car that has a turbocharger, as the turbo is lubricated and cooled by the engine oil. Since the turbo is at the top of the engine, there is the possibility that it's taking the pump that extra second or two to get the system up to pressure.

Like wavsine, I don't have much experience with the 1.0 as we don't get it over here in our Foci. The biggest question I would have it for you is whether you have it parked on a level surface or if it's on an incline. If it is parked on an incline where more oil than usual is ending up in the pan, then coupled with the turbo, it could just be that the pump is taking slightly longer to bring the system to pressure.

If you have it parked level, and since you are using Ford-approved oil, it may be something to keep an eye on in the future. Unfortunately, there isn't much a dealership can do to fix it unless a bigger problem surfaces.
chemistkremer is online now  
    Reply With Quote
Old 06-30-2014, 02:54 AM   #4
GeorgeFocusmk3`
Focus Rookie
 
Join Date: Jun 2014
Fan#: 173209
Location: Athens, Greece
What I Drive: Ford Focus Ecoboost 1.0 125hp Black

Posts: 4
FF Reputation: 1 GeorgeFocusmk3` Good Standing Member
Buy-Sell-Trade Rating: (0)
hi chemistkremer .The car is parked on a level surface. Sometimes also the battery light stays on as well and i am thinking maybe i have a bad battery and it causes that delay.
GeorgeFocusmk3` is offline  
    Reply With Quote
Old 06-30-2014, 09:21 AM   #5
Squad-G
Focus Enthusiast
 
Join Date: Feb 2014
Fan#: 141457
Location: Montréal, Canada
What I Drive: 2013 Ruby Red Hatchback Titanium

Posts: 153
FF Reputation: 1 Squad-G Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by GeorgeFocusmk3` View Post
hi chemistkremer .The car is parked on a level surface. Sometimes also the battery light stays on as well and i am thinking maybe i have a bad battery and it causes that delay.
I don't know about you in Greece, but us in Canada we have 5 years warranty. You say your car is new, do not worry about it for now. If it has to break, it will before the 5 years end. However, if it can work for 5 years without changing habits, it's because its "normal"...
Squad-G is offline  
    Reply With Quote
Old 06-30-2014, 11:31 AM   #6
cbdallas
Focus Addict
 
cbdallas's Avatar
 
Join Date: Jun 2012
Fan#: 100296
Location: Wylie, TX
What I Drive: 2014 Titanium 5-speed

Posts: 802
FF Reputation: 2 cbdallas Good Standing Member
Buy-Sell-Trade Rating: (0)
What kind of oil filter did you install at your last oil change?
cbdallas is offline  
    Reply With Quote
Old 06-30-2014, 11:50 AM   #7
wavsine
Focus Addict
 
wavsine's Avatar
 
Join Date: Sep 2013
Fan#: 118470
Location: DFW, TX
What I Drive: 2013 Focus SE Oxford White Hatch 5m

Posts: 665
FF Reputation: 9 wavsine Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by GeorgeFocusmk3` View Post
Hello guys i am a new member here in the forum. I bought a new Ford Focus 1.0cc wyith the 125hp.The car has about 14.000km and lately i notice that in the morning the oil pressure light stays on for about one or two secs and then goes off. Because i know that oil(Castrol ecoboost 5w 20) is the blood of the engine i have made two changes of oil and filter every 6000km.I have mention to the dealer the above problem with the oil pressure light and told me that is nothing to worry about.Does anyone have a similar problem?
Did some research on this. The 1.0 Ecoboost has a horizontal oil filter unlike the vertical arrangement on the normally aspirated 2.0. It is possible that you have a defective anti drain back valve in your oil filter and that means that every time you start your car, your oil filter has to refill before you get full oil pressure.

Are you running a OEM or an aftermarket filter?
Attached Images
 
__________________
Use a Motorcraft FL-400S filter to increase filtration media and oil quantity. (Drop in for FL-910S)

Synthetic oil in GDI engines
www.focusfanatics.com/forum/showthread.php?t=324396
wavsine is online now  
    Reply With Quote
Old 06-30-2014, 02:00 PM   #8
GeorgeFocusmk3`
Focus Rookie
 
Join Date: Jun 2014
Fan#: 173209
Location: Athens, Greece
What I Drive: Ford Focus Ecoboost 1.0 125hp Black

Posts: 4
FF Reputation: 1 GeorgeFocusmk3` Good Standing Member
Buy-Sell-Trade Rating: (0)
Hello again.The filter that i used both times is from the ford dealer and is original.Also here in Greece we have 5 years warranty.The service for the 20.000km is coming and i will tell to the dealer to check it again .Also i found on youtube some videos ,from others ecoboost engines that also have this delay.
i found this one that despite the engine management the oil light stays on for a while like mine.
https://www.youtube.com/watch?v=canWMk8L96c
GeorgeFocusmk3` is offline  
    Reply With Quote
Old 06-30-2014, 02:43 PM   #9
cobrajet429
Focus Enthusiast
 
Join Date: Oct 2012
Fan#: 105085
Location: Davenport, FL
What I Drive: 2012 candy blue manual SE

Posts: 52
FF Reputation: 1 cobrajet429 Good Standing Member
Buy-Sell-Trade Rating: (0)
Besides this issue . How do you like this engine?
cobrajet429 is offline  
    Reply With Quote
Old 06-30-2014, 02:55 PM   #10
GeorgeFocusmk3`
Focus Rookie
 
Join Date: Jun 2014
Fan#: 173209
Location: Athens, Greece
What I Drive: Ford Focus Ecoboost 1.0 125hp Black

Posts: 4
FF Reputation: 1 GeorgeFocusmk3` Good Standing Member
Buy-Sell-Trade Rating: (0)
beside that issue it is a very good car with a lot of torque when you need it.It gives you the feeling that you are driving a 1.8lt.Good power and nice acceleration.Also you can not understand that you are driving a 3cylinder car when i test drive the car before i bought it i was very sure that was a 4 cylinder engine.You cannot feel any vibration and also a very quiet engine.Worth the money !
GeorgeFocusmk3` is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:53 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.