Squeak after replacing Passenger Mount - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 12-10-2012, 02:03 PM   #1
C00P88
Focus Jr. Enthusiast
 
Join Date: Mar 2007
Fan#: 45208
Location: Denver CO
What I Drive: 2003 Pitch Black ZX3

Posts: 41
FF Reputation: 1 C00P88 Good Standing Member
Buy-Sell-Trade Rating: (0)
Question Squeak after replacing Passenger Mount

I've replaced the passenger engine mount on my 03' zx3. I now get a squeaking noise from the engine bay while accelerating, usually going uphill. It's worse if I'm going over bumps, accelerating uphill. No noise if I'm cruising at a steady speed or rolling with the clutch engaged.

I've triple-checked the mount bolts and nuts, nothing is loose. I've tried changing the position of the engine, bolting it down with it pushed forward, all the way back, in the center position but the squeak continues.

I noticed today that the squeak appears AFTER the engine warms up.

I used thread locker blue on the nuts and bolts of the engine mount.

I've also replaced the lower mount - I started with a poly mount but didn't like the vibration so I'm back to rubber.

I'm wondering if this is really the mount, or something else was loosened by moving the engine around? I don't see anything obviously loose. If it's the mount then I guess my solution will be to turn the radio up. I can't get the bolts any tighter. Any suggestions?


C00P88 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 12-10-2012, 02:24 PM   #2
bringler26
FUBARCUS
 
bringler26's Avatar
 
Join Date: Oct 2008
Fan#: 59705
Location: Mentor, OH
What I Drive: 03 ZX3 & 07 Impreza 2.5i

Posts: 5,672
FF Reputation: 29 bringler26 Great Standing Member
Buy-Sell-Trade Rating: (5)
Moved to Gen. Tech Chat should get more responses here.
__________________
2003 Ford Focus ZX3("FUBARCUS" was "Brokus") - old and still busted
2007 Subaru Impreza 2.5i - current DD
Quote:
Originally Posted by zetecDon View Post
I always moderate naked!
bringler26 is offline  
    Reply With Quote
Old 12-10-2012, 10:56 PM   #3
amc49
Focus Fanatic
 
Join Date: Mar 2012
Fan#: 96610
Location: Fort Worth, TX
What I Drive: 00 wagon, 02 sedan both zetec atx

Posts: 4,497
FF Reputation: 23 amc49 Great Standing Member
Buy-Sell-Trade Rating: (0)
Depending on brand and by extension how it's made inside, could be mount internals. Some can make some funky noises. If old mount made noises they could have also covered say suspension loosening up to make noise, you didn't hear that for the bad mount. Check the sway bar endlinks for play.
amc49 is online now  
    Reply With Quote
Old 12-11-2012, 09:53 AM   #4
C00P88
Focus Jr. Enthusiast
 
Join Date: Mar 2007
Fan#: 45208
Location: Denver CO
What I Drive: 2003 Pitch Black ZX3

Posts: 41
FF Reputation: 1 C00P88 Good Standing Member
Buy-Sell-Trade Rating: (0)
Hello,

The mount is a regular factory replacement from Napa. The suspension was replaced this year with the ford svt kit, ball joints as well. I hadn't thought about the endlinks. I'll check them for play. Maybe they just need some grease (autozone links, installed 3-4 yrs ago).
C00P88 is offline  
    Reply With Quote
Old 12-31-2012, 09:24 PM   #5
C00P88
Focus Jr. Enthusiast
 
Join Date: Mar 2007
Fan#: 45208
Location: Denver CO
What I Drive: 2003 Pitch Black ZX3

Posts: 41
FF Reputation: 1 C00P88 Good Standing Member
Buy-Sell-Trade Rating: (0)
Fixed

It turns out my napa mount was the culprit. I replaced it and the squeak went away.
C00P88 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:27 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.