P0041 and P0123 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 12-04-2012, 11:54 AM   #1
simo10
Focus Rookie
 
Join Date: Dec 2012
Fan#: 106962
Location: florida, FL
What I Drive: 2002 ford focus

Posts: 4
FF Reputation: 1 simo10 Good Standing Member
Buy-Sell-Trade Rating: (0)
P0041 and P0123

My girlfriends car is throwing these two codes.

Check Engine Light Code P0041

Downstream O2 Sensors Swapped Bank To Bank

P0123 Code - Throttle Position Sensor/Switch A Circuit High Input

It's a stock 02 Focus, SPI engine, 5 speed manual. 151,xxx miles

It seems to run ok, minus some vibrations (mounts are new) and the speedometer sometimes decides to quit.

Any idea what could cause these codes, especially P0041? I can't find much info on it. I have never touched the oxygen sensor wiring and it didn't used to have this code.


simo10 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 12-07-2012, 08:06 PM   #2
simo10
Focus Rookie
 
Join Date: Dec 2012
Fan#: 106962
Location: florida, FL
What I Drive: 2002 ford focus

Posts: 4
FF Reputation: 1 simo10 Good Standing Member
Buy-Sell-Trade Rating: (0)
Anyone?
simo10 is offline  
    Reply With Quote
Old 12-07-2012, 09:54 PM   #3
freemind
Vince your Moderator
 
freemind's Avatar
 
Join Date: Jul 2009
Fan#: 67513
Location: Seattle, WA
What I Drive: 2002 ZX3 and a 2010 Focus SE (Work)

Posts: 3,856
FF Reputation: 21 freemind Great Standing Member
Buy-Sell-Trade Rating: (20)
Clear the codes and see if they come back.

Then we will talk about replacing stuff.
__________________
133whp-126ftlbsTQ Eclipse CD8443,Eclipse PA5422, JBL GTO751EZ, PPI 356cs(Rebranded A/D/S 346cs), JBL p1024, SubThump enclosure, RAAmat BXT, Damplifier Pro

Hatch Nation #140
Caeci caecos ducentes
freemind is offline  
    Reply With Quote
Old 12-08-2012, 02:55 PM   #4
simo10
Focus Rookie
 
Join Date: Dec 2012
Fan#: 106962
Location: florida, FL
What I Drive: 2002 ford focus

Posts: 4
FF Reputation: 1 simo10 Good Standing Member
Buy-Sell-Trade Rating: (0)
What is the proper procedure for this? oi unplugged the battery for 10 min and it came back withing a few days.
simo10 is offline  
    Reply With Quote
Old 12-09-2012, 10:11 AM   #5
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,851
FF Reputation: 86 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Your P0041 code is non-sensical because the 4 cylinder Focus only has a single bank of cylinders (V6s and V8s have two). It may be indicative of a wiring harness short. The only way to tell is to do a visual inspection of the downstream O2 sensor connectors and wires.

If the speedo sometimes quits as well it would be suggesting you have an electrical short somewhere.

If the DTC codes reappear, the problem is persistent. Your method of clearing the codes is correct, although using a proper OBDII code scanning device would be better.
BC_ZX3 is offline  
    Reply With Quote
Old 12-09-2012, 01:43 PM   #6
simo10
Focus Rookie
 
Join Date: Dec 2012
Fan#: 106962
Location: florida, FL
What I Drive: 2002 ford focus

Posts: 4
FF Reputation: 1 simo10 Good Standing Member
Buy-Sell-Trade Rating: (0)
All O2 connections seem solid, although the connector for the downstream sensor is kind of floating around and very close to the axle. I couldn't see anything out of the ordinary.

Could it be a bad O2 sensor?
simo10 is offline  
    Reply With Quote
Old 12-09-2012, 08:39 PM   #7
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,851
FF Reputation: 86 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
An internal short in the O2 sensor is possible although not probable.
Simply disconnect the rear O2 sensor harness connector, wire it up out of the way, clear your DTC codes and see what codes (other than P0420) appear. If your P0041 fails to reappear, the O2 sensor needs replacement. If P0041 reappears, the O2 sensor is not the problem source.
Are you in a hatchback or a sedan?
BC_ZX3 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:15 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.