Fixed a couple of problems...and potentially added a new one. Help please. - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 12-14-2012, 05:53 PM   #1
SWEGER
Focus Enthusiast
 
SWEGER's Avatar
 
Join Date: Aug 2011
Fan#: 88926
Location: Fort Leonard Wood, MO
What I Drive: 2003 Infra-Red ZX5 SVT

Posts: 193
FF Reputation: 1 SWEGER Good Standing Member
Buy-Sell-Trade Rating: (1)
Fixed a couple of problems...and potentially added a new one. Help please.

Ok, so this evening I received my upgraded thermostat housing kit from Tousley Ford (great people...got it out and to me in 3 days).

I put that on and fixed the dreaded leaking thermostat housing in my 2003 SVT, and also put on a new PCV tube since mine was being held together by duct tape for the last 5 months. As I was filling up the radiator and letting it cycle as I did before, I heard something fall and rattle around. Turns out, my poorly-placed radiator reservoir cover had fallen down into the belts. It is fine, however now I have a squeaking sound. Any idea what this is? It changes with RPMs and isn't always the same. Did I mess up a tensioner? It sounds a lot like a bearing or something, but I cannot see any obvious damage or anything.


__________________
2003 Infra-Red ZX5 SVT - Cheap Spectre intake (don't judge, was on there when I got it), Hawk HPS pads front/rear, Russell SS lines, Goodyear Eagle GT 215/45/17

"If guns cause violence, then all of mine are defective" - Ted Nugent
SWEGER is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 12-15-2012, 09:02 AM   #2
SWEGER
Focus Enthusiast
 
SWEGER's Avatar
 
Join Date: Aug 2011
Fan#: 88926
Location: Fort Leonard Wood, MO
What I Drive: 2003 Infra-Red ZX5 SVT

Posts: 193
FF Reputation: 1 SWEGER Good Standing Member
Buy-Sell-Trade Rating: (1)
Update

Went out this morning and started her up, let her warm up and then run with the heat and defrost on full blast. Everything is good, no more squeaking noise and no leaks.
__________________
2003 Infra-Red ZX5 SVT - Cheap Spectre intake (don't judge, was on there when I got it), Hawk HPS pads front/rear, Russell SS lines, Goodyear Eagle GT 215/45/17

"If guns cause violence, then all of mine are defective" - Ted Nugent
SWEGER is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:37 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.