New IMRC Actuator Still Get Code P1518 - Page 5 - Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 08-15-2013, 04:48 PM   #41
PNWSVT
Focus Rookie
 
PNWSVT's Avatar
 
Join Date: Jan 2013
Fan#: 108900
Location: Tacoma, WA
What I Drive: 2004 Infared SVT ZX3

Posts: 21
Points 141, Level 2
Points: 141, Level: 2 Points: 141, Level: 2 Points: 141, Level: 2
Level Up 82% Completed
Level up: 82% Level up: 82% Level up: 82%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 PNWSVT Good Standing Member
Buy-Sell-Trade Rating: (0)
So I had this issue and bought a new IMRC module from tousley ford and replaced the old one. Everything was fine for about 7 months and now I have the same issue again

I cleaned the MAF and checked the DSI clip and its good. So this IMRC unit is basically new so it couldn't be coroded already so Im stumped...
PNWSVT is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-16-2013, 12:10 PM   #42
bbcobra
Focus Enthusiast
 
bbcobra's Avatar
 
Join Date: Aug 2011
Fan#: 88400
Location: Elkin, NC
What I Drive: 2003 SVT Competition Orange EAP ZX3

Posts: 149
Points 407, Level 8
Points: 407, Level: 8 Points: 407, Level: 8 Points: 407, Level: 8
Level Up 14% Completed
Level up: 14% Level up: 14% Level up: 14%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 bbcobra Good Standing Member
Buy-Sell-Trade Rating: (1)
I was ready buy a new one if needed but thought I'd try the IMRC from a cougar. Still working. Of course these cars have several miles on them too so it's just a matter of time till a new one will be the only replacement.
I would check with them on warranty on the IMRC.
__________________
03 SVT Focus, Comp Orange, EAP, Eibach sway bars, H&R Race Springs, Koni Sports, steeda shifter, Massive camber arms, toe links, engine mount bushings, sway bar end links.

other car: 2004 SVT Cobra Coupe, Screaming Yellow, 2.76/2lb lower...
bbcobra is offline  
    Reply With Quote Quick reply to this message
Old 08-21-2013, 09:42 AM   #43
AndrewM6097
Focus Rookie
 
Join Date: Jun 2013
Fan#: 115615
Location: worcester, MA
What I Drive: 2002 CD Silver SVT

Posts: 8
FF Reputation: 1 AndrewM6097 Good Standing Member
Buy-Sell-Trade Rating: (0)
I also just installed a spare IMRC I had from my svt contour on to the focus. Been working great. And theyre a dime a dozen at scrap yards.
AndrewM6097 is offline  
    Reply With Quote Quick reply to this message
Old 08-24-2013, 04:18 PM   #44
SVT_DAEMON
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 57618
Location: Nassau County, NY, NY
What I Drive: 2004 SVT EAP Focus

Posts: 64
FF Reputation: 1 SVT_DAEMON Good Standing Member
Buy-Sell-Trade Rating: (5)
Any update on this? I didnt see a true fix.

I am getting my car ready to sell and changed the acutator from tousley ford. I still get P1518 after driving the car for 3 miles since the swap. Brand new battery (3 weeks old) so I know theres no acid.

The car has been sitting under a cover in my garage for a year. installed new O2 sensor as well and nada. still P1518 with a new actuator

anyone?
SVT_DAEMON is offline  
    Reply With Quote Quick reply to this message
Old 08-24-2013, 08:00 PM   #45
SVT_DAEMON
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 57618
Location: Nassau County, NY, NY
What I Drive: 2004 SVT EAP Focus

Posts: 64
FF Reputation: 1 SVT_DAEMON Good Standing Member
Buy-Sell-Trade Rating: (5)
ok so I just re-read the thread....I'm going to change the Idle Air Controller. She does idle like shit... It got a lot smoother after the new IMRC Actuator but still something is not right. At times she purrs beautiful then she sounds like shit.... I'll keep you posted
SVT_DAEMON is offline  
    Reply With Quote Quick reply to this message
Old 08-26-2013, 11:48 AM   #46
SVT_DAEMON
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 57618
Location: Nassau County, NY, NY
What I Drive: 2004 SVT EAP Focus

Posts: 64
FF Reputation: 1 SVT_DAEMON Good Standing Member
Buy-Sell-Trade Rating: (5)
ok so p1518 is gone after driving a bit more....but now p1131 is on that explains the idle. cant wait to fix it now that i feel better its not the acutator anymore

Last edited by SVT_DAEMON; 09-03-2013 at 11:28 PM.
SVT_DAEMON is offline  
    Reply With Quote Quick reply to this message
Old 09-03-2013, 11:27 PM   #47
SVT_DAEMON
Focus Enthusiast
 
Join Date: Jul 2008
Fan#: 57618
Location: Nassau County, NY, NY
What I Drive: 2004 SVT EAP Focus

Posts: 64
FF Reputation: 1 SVT_DAEMON Good Standing Member
Buy-Sell-Trade Rating: (5)
OK RESOLVED! 3 things!

1 - the o-ring in the MAF broke. - (replaced o-ring)
2 - the hose to the PCV was dry rotted and broken - (Ford charged 9 bucks for the hose.)
3 - the PCV was clogged - ($28 for a new one.)

140 miles since the repair and no light!!
SVT_DAEMON is offline  
    Reply With Quote Quick reply to this message
Old 09-04-2013, 12:29 PM   #48
bbcobra
Focus Enthusiast
 
bbcobra's Avatar
 
Join Date: Aug 2011
Fan#: 88400
Location: Elkin, NC
What I Drive: 2003 SVT Competition Orange EAP ZX3

Posts: 149
Points 407, Level 8
Points: 407, Level: 8 Points: 407, Level: 8 Points: 407, Level: 8
Level Up 14% Completed
Level up: 14% Level up: 14% Level up: 14%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 1 bbcobra Good Standing Member
Buy-Sell-Trade Rating: (1)
good news
__________________
03 SVT Focus, Comp Orange, EAP, Eibach sway bars, H&R Race Springs, Koni Sports, steeda shifter, Massive camber arms, toe links, engine mount bushings, sway bar end links.

other car: 2004 SVT Cobra Coupe, Screaming Yellow, 2.76/2lb lower...
bbcobra is offline  
    Reply With Quote Quick reply to this message
Old 12-17-2013, 10:57 PM   #49
dman25
Focus Jr. Enthusiast
 
Join Date: Mar 2012
Fan#: 95916
Location: Los Angeles, CA
What I Drive: 2000, Red, SVT Lightning

Posts: 36
FF Reputation: 1 dman25 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by SVT_DAEMON View Post
OK RESOLVED! 3 things!

1 - the o-ring in the MAF broke. - (replaced o-ring)
2 - the hose to the PCV was dry rotted and broken - (Ford charged 9 bucks for the hose.)
3 - the PCV was clogged - ($28 for a new one.)

140 miles since the repair and no light!!
Hey SVT DAEMON, so this is what you did to fix your P1518 code? My IMRC looks likes its working fine but I'm still getting a code.
dman25 is offline  
    Reply With Quote Quick reply to this message
Old 03-28-2014, 01:09 AM   #50
josephmurray85
Focus Rookie
 
Join Date: Dec 2013
Fan#: 130306
Location: clarksville, TN
What I Drive: 2003 ford focus svt black

Posts: 6
FF Reputation: 1 josephmurray85 Good Standing Member
Buy-Sell-Trade Rating: (0)
ive been having the same code. ive been to the junk yards and pulled as many of the imrc valves i could find. i checked all solders and fixed them replaced the transistor put new heat sink compound and cleaned the switch. my flap moves like its suppose to and the clip isnt broken. the cable moves freely. when i put one i fixed up back in the car it works for a couple days then stops and i get the code. and when i did put on in i would test to see if the motor turned on and it did. but now that i got the code it doesnt move anymore. ive already put 3 different ones in it hoping i would get a good one but i doubt that all 3 of them are bad. and i made sure to get the right transistor to put back on it. the cable and gears in the box are good too. im lost and from what i can see on the thread that no one has come up with a solid fix. any help would be greatly appreciated. and im new to the forum.
josephmurray85 is offline  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:21 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat