02 Sensor WTF's, CELs, and more - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 10-16-2012, 06:42 PM   #1
matmatician
Cars&Corgis
 
matmatician's Avatar
 
Join Date: Dec 2010
Fan#: 81361
Location: Mill Creek, WA
What I Drive: A ONE COLOR FOCUS, Ducatis

Posts: 4,365
FF Reputation: 4 matmatician Good Standing Member
Buy-Sell-Trade Rating: (1)
02 Sensor WTF's, CELs, and more

Hey guys,

Just trying to get this sorted out so I can get an ECU tune. I have the FSwerks header, which means I have 1 02 sensor. This needs to be the upstream sensor, unless i'm mistaken, which my livelink software can't read for some reason right now. The Upstream sensor should be the blue connector, right? Not the grey one? The 02 sensor in the exhaust manifold is plugged into the blue one currently... Here's a pic if I've lost anyone:



I'm getting codes P0135 (o2 sensor heater circuit bank 1 sensor 1) and P0147 (o2 sensor heater circuit bank 1 sensor 3). So, is the upstream sensor bank 2? Tom thinks that the o2 sensor in the exhaust manifold needs to be replaced. Does that sound like a good place to start to all of you? this all is making my brain hurt.


__________________
Quote:
Originally Posted by matmatician View Post
What spare tire? The one that adds weight? Psh. Its wherever my A/C is.
ROTM June '13, PNW Crew #42, SR #245, Rally Rev #02
matmatician is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 10-16-2012, 09:26 PM   #2
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,851
FF Reputation: 86 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
The "bank" is referring to the number of cylinder banks. An inline four engine only has a single bank; a V6, V8 or V12 has two banks. So any Focus will only generate DTC codes that refer to bank 1.
BC_ZX3 is offline  
    Reply With Quote
Old 10-16-2012, 09:47 PM   #3
matmatician
Cars&Corgis
 
matmatician's Avatar
 
Join Date: Dec 2010
Fan#: 81361
Location: Mill Creek, WA
What I Drive: A ONE COLOR FOCUS, Ducatis

Posts: 4,365
FF Reputation: 4 matmatician Good Standing Member
Buy-Sell-Trade Rating: (1)
Right, I meant to ask if sensor 1 bank 2 was the one I should be using, and if that corresponds to the blue harness.
__________________
Quote:
Originally Posted by matmatician View Post
What spare tire? The one that adds weight? Psh. Its wherever my A/C is.
ROTM June '13, PNW Crew #42, SR #245, Rally Rev #02
matmatician is offline  
    Reply With Quote
Old 10-16-2012, 10:13 PM   #4
iminhell
C2H5OH
 
iminhell's Avatar
 
Join Date: Jun 2006
Fan#: 36222
Location: Darwin, MN
What I Drive: 2000 & 2001 ZX3's

Posts: 10,275
FF Reputation: 48 iminhell Great Standing Member
Buy-Sell-Trade Rating: (4)
Quote:
Originally Posted by matmatician View Post
Right, I meant to ask if sensor 1 bank 1 was the one I should be using, and if that corresponds to the blue harness.

Yes you should be using bank 1 sensor 1.
This should be the blue connector.
__________________
Don't "think outside the box".
There is no box.
Do it correct, or do it twice.
iminhell is online now  
    Reply With Quote
Old 10-16-2012, 10:20 PM   #5
matmatician
Cars&Corgis
 
matmatician's Avatar
 
Join Date: Dec 2010
Fan#: 81361
Location: Mill Creek, WA
What I Drive: A ONE COLOR FOCUS, Ducatis

Posts: 4,365
FF Reputation: 4 matmatician Good Standing Member
Buy-Sell-Trade Rating: (1)
It's weird. Im plugged into the blue harness, and bank one sensor 2 is the only one with no cel. The grey harness doesn't even have anything hooked up into it.
__________________
Quote:
Originally Posted by matmatician View Post
What spare tire? The one that adds weight? Psh. Its wherever my A/C is.
ROTM June '13, PNW Crew #42, SR #245, Rally Rev #02
matmatician is offline  
    Reply With Quote
Old 10-16-2012, 10:22 PM   #6
BC_ZX3
DTC P0606
 
BC_ZX3's Avatar
 
Join Date: Jul 2007
Fan#: 48751
Location: Vancouver, BC, Canada
What I Drive: 2001 Red ZX3 Turbo

Posts: 2,851
FF Reputation: 86 BC_ZX3 Excellent Standing Member
Buy-Sell-Trade Rating: (3)
Use the wiring harness colours to confirm the correct sensor.

In the diagram H02S 11 is the first sensor, H02S 12 is the second, H02S 13 is the third as one travels down the exhaust.

BC_ZX3 is offline  
    Reply With Quote
Old 10-16-2012, 10:25 PM   #7
matmatician
Cars&Corgis
 
matmatician's Avatar
 
Join Date: Dec 2010
Fan#: 81361
Location: Mill Creek, WA
What I Drive: A ONE COLOR FOCUS, Ducatis

Posts: 4,365
FF Reputation: 4 matmatician Good Standing Member
Buy-Sell-Trade Rating: (1)
You rock man, I've been looking for this. Chiltons manual doesn't have it. Thanks!
__________________
Quote:
Originally Posted by matmatician View Post
What spare tire? The one that adds weight? Psh. Its wherever my A/C is.
ROTM June '13, PNW Crew #42, SR #245, Rally Rev #02
matmatician is offline  
    Reply With Quote
Old 10-16-2012, 11:03 PM   #8
matmatician
Cars&Corgis
 
matmatician's Avatar
 
Join Date: Dec 2010
Fan#: 81361
Location: Mill Creek, WA
What I Drive: A ONE COLOR FOCUS, Ducatis

Posts: 4,365
FF Reputation: 4 matmatician Good Standing Member
Buy-Sell-Trade Rating: (1)
I'm wondering if maybe when they installed the new engine, they mis-wired it. That maybe they plugged the grey 02 sensor cable into where the blue one should be on the ECU. It doesnt make sense that sensor 2 isnt getting and sensor 1 isnt, when its sensor 2 that should be disconnected. Am I overthinking this?
__________________
Quote:
Originally Posted by matmatician View Post
What spare tire? The one that adds weight? Psh. Its wherever my A/C is.
ROTM June '13, PNW Crew #42, SR #245, Rally Rev #02
matmatician is offline  
    Reply With Quote
Old 10-27-2012, 10:59 PM   #9
matmatician
Cars&Corgis
 
matmatician's Avatar
 
Join Date: Dec 2010
Fan#: 81361
Location: Mill Creek, WA
What I Drive: A ONE COLOR FOCUS, Ducatis

Posts: 4,365
FF Reputation: 4 matmatician Good Standing Member
Buy-Sell-Trade Rating: (1)
Ok, found out there was a burnt 02 sensor extension cable.



Replaced it. Still getting bank 1 sensor 1 CEL (P0135) but bank 1 sensor 2 doesnt have a CEL anymore. *sigh* This is getting frustrating. Help?? Do you think I may need to replace the 02 sensor as well? I have one handy if I do.
__________________
Quote:
Originally Posted by matmatician View Post
What spare tire? The one that adds weight? Psh. Its wherever my A/C is.
ROTM June '13, PNW Crew #42, SR #245, Rally Rev #02
matmatician is offline  
    Reply With Quote
Old 10-28-2012, 07:55 PM   #10
felixthecat
Focus Fanatic
 
felixthecat's Avatar
 
Join Date: Nov 2010
Fan#: 80663
Location: Renton, WA
What I Drive: '05 Silver Sport Technologies

Posts: 8,106
FF Reputation: 52 felixthecat Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by matmatician View Post
I'm wondering if maybe when they installed the new engine, they mis-wired it. That maybe they plugged the grey 02 sensor cable into where the blue one should be on the ECU. It doesnt make sense that sensor 2 isnt getting and sensor 1 isnt, when its sensor 2 that should be disconnected. Am I overthinking this?
It would work anyhow. 2 different style of connecters.
__________________
Introduce Mr. Torsen to the mix D23 crew- D-Tech- Sedan Revolution= #131
felixthecat is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:23 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.