Motor Mounts - Duralast & Anchor Brand - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace



Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
FocusFest Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 08-27-2012, 12:43 AM   #1
AlexCA
Focus Rookie
 
Join Date: Aug 2012
Fan#: 102754
Location: Inland Empire, CA
What I Drive: 2003 Charcoal Grey ZX3

Posts: 24
FF Reputation: 1 AlexCA Good Standing Member
Buy-Sell-Trade Rating: (0)
Motor Mounts - Duralast & Anchor Brand

I can buy some Anchors online for a lot cheaper. My local Autozone carries mounts as well, but they are double the price. The part number on the autozone website is the same as the Anchors. Does anyone know if they are the same part, but packaged/sold as Duralst?

Thanks


AlexCA is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 08-27-2012, 07:02 AM   #2
GreySkorpion
saved from the grave
 
GreySkorpion's Avatar
 
Join Date: Feb 2012
Fan#: 94674
Location: B'game, KS
What I Drive: 2004 LG ZX5 2.3D

Posts: 6,079
FF Reputation: 11 GreySkorpion Great Standing Member
Buy-Sell-Trade Rating: (5)
They both suck, so many people buy those 2 brands, only to have them fail in just a couple months. Go OEM and get another 8 or 9 years from them.
GreySkorpion is offline  
    Reply With Quote
Old 08-27-2012, 07:44 AM   #3
IH84DZ
Focus Enthusiast
 
Join Date: Jul 2012
Fan#: 101801
Location: Champaign, IL
What I Drive: 03 CD silver SVT 5 door

Posts: 170
FF Reputation: 5 IH84DZ Good Standing Member
Buy-Sell-Trade Rating: (0)
They are junk. Textbook example of getting what you pay for
IH84DZ is offline  
    Reply With Quote
Old 08-27-2012, 10:26 AM   #4
VEGAS
Focus Enthusiast
 
VEGAS's Avatar
 
Join Date: Jun 2010
Fan#: 75680
Location: Las Vegas, NV
What I Drive: 2007 Focus

Posts: 537
FF Reputation: 4 VEGAS Good Standing Member
Buy-Sell-Trade Rating: (0)
the rubber is not as good in the cheaper versions.. they sit on a shelf for 8 to 10 years and dry out and crack fast..
VEGAS is offline  
    Reply With Quote
Old 08-27-2012, 02:46 PM   #5
malim
Focus Enthusiast
 
malim's Avatar
 
Join Date: Apr 2008
Fan#: 55004
Location: Toronto, Canada
What I Drive: 2007 Ford Focus ST - Black

Posts: 469
FF Reputation: 4 malim Good Standing Member
Buy-Sell-Trade Rating: (0)
DO NOT REPLACE WITH AFTERMARKET GARBAGE. I thought at the least the dog bone mount would be okay aftermarket, but there was so much engine play when I installed it brand new out of the box, that it was ridiculous. Go with OEM, don't waste money and time.
malim is offline  
    Reply With Quote
Old 08-27-2012, 03:47 PM   #6
TerryB
Focus Fanatic
 
TerryB's Avatar
 
Join Date: Apr 2006
Fan#: 34559
Location: Riverside, RI
What I Drive: Red '01 ZX3

Posts: 2,917
FF Reputation: 68 TerryB Excellent Standing Member
Buy-Sell-Trade Rating: (2)
It hasn't been mentioned. But NAPA mounts suck too. Probably Anchor. I blew one out in about 2 weeks. The whole top exploded and fell into my belts and pulleys. Luckily it bounced around and didn't do any damage.
TerryB is offline  
    Reply With Quote
Old 08-27-2012, 06:18 PM   #7
xxMichaelAnthony
Focus Fanatic
 
xxMichaelAnthony's Avatar
 
Join Date: Aug 2008
Fan#: 58459
Location: Orange County, CA, CA
What I Drive: 2001 CD Silver ZX3

Posts: 2,480
FF Reputation: 20 xxMichaelAnthony Great Standing Member
Buy-Sell-Trade Rating: (2)
Blah blah blah get motorcraft blah blah blah...

After market OE mounts go out because people dont do the work right. I had a problem with one passenger side mount, fixed what was making it bind and no problems since. Same thing in my brothers Focus. If youre doing all 3 I suggest getting the poly inserts for it found here. http://focus.c-f-m.com/prothanepolyu...0-06focus.aspx

Read this before you do the work. http://www.focusfanatics.com/forum/showthread.php?t=276167
__________________
http://effyeahfordcars.tumblr.com
[HOONIGAN]
iTroll
xxMichaelAnthony is offline  
    Reply With Quote
Old 08-27-2012, 08:59 PM   #8
CotyM
Focus Addict
 
CotyM's Avatar
 
Join Date: May 2011
Fan#: 85558
Location: woodsfield, OH
What I Drive: blue, y2k, 5spd ZX3, zetec inside

Posts: 748
FF Reputation: 3 CotyM Good Standing Member
Buy-Sell-Trade Rating: (0)
I have to agree with xxMichaelAnthony... I've had my car for over a year and a half now, I'm pretty sure the passenger side motor mount was an anchor that I took out last weekend (Looked Identical and didn't look quite like the motorcraft picture) The mount was still good when I replaced it, or so I found out after I saw it didn't fix my problem... Hard to tell how long it's been in there, but well over a year and a half AFAIK unless the anchor fairy changed it when I was at work.
CotyM is offline  
    Reply With Quote
Old 08-28-2012, 04:53 AM   #9
whynotthinkwhynot
Captain TMI
 
whynotthinkwhynot's Avatar
 
Join Date: Jan 2005
Fan#: 18416
Location: the armpit of TN, Memphis, TN
What I Drive: 05 ZXW; 02 Windstar; 13 C-Max SEL

Posts: 20,060
FF Reputation: 270 whynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Memberwhynotthinkwhynot Outstanding Standing Member
Buy-Sell-Trade Rating: (1)
I can say nothing because I drove on factory mounts until 140k then put on poly mounts. I don't know how long the factory mounts were bad, but they were. I didn't replace them on purpose because I wanted poly mounts. The vibration increase doesn't bother me, and it can't be felt once the car is moving anyway. Cost is much higher though- mine were about $500, and it would be probably just over $400 for a Zetec.
__________________
Be eclectic.
---The Complete How-To Archive--

Moderating everything now, let me know if I can help.

Quote:
Originally Posted by the user formerly known as ZX3_Chick View Post
You're special aren't you.
whynotthinkwhynot is offline  
    Reply With Quote
Old 08-28-2012, 12:37 PM   #10
Ecoh72
Focus Enthusiast
 
Join Date: Feb 2009
Fan#: 62507
Location: Agoura Hills CA, CA
What I Drive: 2003 Toredor Red ZX3

Posts: 478
FF Reputation: 3 Ecoh72 Good Standing Member
Buy-Sell-Trade Rating: (12)
There are only two companies that make aftermarket stock replacement motor mounts and they both are terrible, spend the money to get Motorcraft. Trust me I've been through many mounts and work for an aftermarket parts company, I see the cheap ones coming in broken on a weekly basis.
__________________
"Straight roads are for fast cars, turns are for fast drivers." -Colin McRae
SoCal Crew #72
www.facebook.com/ecohphoto
'03 Toredor Red ZX3 (DD)
'67 VW Bug Cal Look
Ecoh72 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:54 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.