SYNC Update Available on Focus!!! - Page 40 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > Car Audio, SYNC, MyFord Touch & Electronics

Car Audio, SYNC, MyFord Touch & Electronics The Forum for the Ford Focus audiophiles. The place to chat about automobile sound systems, security systems, or show off your I.C.E.!
Sponsored By: GT Sound Control


Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-28-2012, 09:43 AM   #391
raptor1956
Focus Addict
 
Join Date: Apr 2012
Fan#: 97725
Location: Taylorsville, UT
What I Drive: 2012, Sonic Blue, Focus Titanium

Posts: 1,191
FF Reputation: 1 raptor1956 Good Standing Member
Buy-Sell-Trade Rating: (0)
OK, I installed the update (3.2.2) a few days ago and just as with 3.0.2 I have no major issues.

1. My phone pairs reliably

2. I have a 32GB thumbdrive with 16GB of music and it plays as it should -- Sirius and AM/FM works to (haven't tried BT yet)

3. Navigation works including download via Destinations

4. Climate works via manual controls, touch screen or voice


Why the difference?


Brian
__________________
2012 FF Ti HB Sonic Blue, Built 5/7/12, 401A + Parking Technology Package and MFT w/NAV 3.0.2 -> 3.2.2 -> 3.5.1 -> 3.6.2
raptor1956 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 09-28-2012, 09:51 AM   #392
csvt2060
Focus Addict
 
csvt2060's Avatar
 
Join Date: Mar 2011
Fan#: 84122
Location: Northwest Indiana, IN
What I Drive: 2013 Ford Escape Titanium

Posts: 772
FF Reputation: 2 csvt2060 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by copernicium112 View Post
Yeah, this completely baffles me. I've seen Jaclyn respond to other threads since this all started but she is apparently avoiding this thread like the plague. When they had to remove the first update from SMR they made an announcement with regard to the fact. At least that was some form of acknowledgement of an issue. This update just quietly disappeared followed by absolute silence.
This is what makes the whole MFT debacle even worse....they hide and tighten up so there are no answers and people get even more upset.

Apple just came out and admitted to their mistake on their maps program in the new iOS. In this case, a large company admits fault, takes the blame for their actions, gives alternative means to get by until they can resolve the issue.

Ford: Releases and update, recends the update, releases the same update, recends the update. People have broken their system from the update. No word what happened to the update. You can't get any answers from Ford customer service, than if you do they say "take it to your dealer" or do a "master reset" and we all know the story after that. Put those poor people out of their misery and man up Ford!
csvt2060 is offline  
    Reply With Quote
Old 09-28-2012, 09:54 AM   #393
lewisra
Focus Addict
 
Join Date: Dec 2011
Fan#: 93289
Location: Howell, MI
What I Drive: 2012 Tuxedo Black SEL

Posts: 567
FF Reputation: 3 lewisra Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by raptor1956 View Post
OK, I installed the update (3.2.2) a few days ago and just as with 3.0.2 I have no major issues.


Why the difference?


Brian

You don't have an iPhone, don't use BT, your USB doesn't have folders or playlists, the manner in which you use Nav was fixed with 3.2.2, and your build date and/or your APIM/BCM was replaced in 2012.
lewisra is offline  
    Reply With Quote
Old 09-28-2012, 09:54 AM   #394
treoless
Focus Enthusiast
 
Join Date: Mar 2012
Fan#: 96715
Location: Nashua, NH
What I Drive: 2012 Focus Titanium

Posts: 99
FF Reputation: 1 treoless Good Standing Member
Buy-Sell-Trade Rating: (0)
Took my car to the dealership yesterday and they couldn't re-flash the software after 6 tries. They were told by Ford that the update on SMR was corrupted. They finally fixed it by taking the MFT unit (APIM?) out and forced the update.
treoless is offline  
    Reply With Quote
Old 09-28-2012, 10:06 AM   #395
PratoN
Focus Fanatic
 
PratoN's Avatar
 
Join Date: Jul 2011
Fan#: 88058
Location: Milwaukee, WI
What I Drive: 2012 Kona Blue Ti Hatchback, DCT

Posts: 3,749
FF Reputation: 10 PratoN Great Standing Member
Buy-Sell-Trade Rating: (0)
I know what I'm doing tomorrow....
PratoN is offline  
    Reply With Quote
Old 09-28-2012, 10:18 AM   #396
lewisra
Focus Addict
 
Join Date: Dec 2011
Fan#: 93289
Location: Howell, MI
What I Drive: 2012 Tuxedo Black SEL

Posts: 567
FF Reputation: 3 lewisra Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by treoless View Post
Took my car to the dealership yesterday and they couldn't re-flash the software after 6 tries. They were told by Ford that the update on SMR was corrupted. They finally fixed it by taking the MFT unit (APIM?) out and forced the update.
Camera working now?
lewisra is offline  
    Reply With Quote
Old 09-28-2012, 10:26 AM   #397
raptor1956
Focus Addict
 
Join Date: Apr 2012
Fan#: 97725
Location: Taylorsville, UT
What I Drive: 2012, Sonic Blue, Focus Titanium

Posts: 1,191
FF Reputation: 1 raptor1956 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by lewisra View Post
You don't have an iPhone, don't use BT, your USB doesn't have folders or playlists, the manner in which you use Nav was fixed with 3.2.2, and your build date and/or your APIM/BCM was replaced in 2012.
I do have an iPhone (iP4) but I have not attempted to pair it -- yet. I do have a SGNexus and it is paired.

I tried BT with 3.0.2 and it worked but have not tried it -- yet, with 3.2.2.

My USB DOES have folders but no playlists.

My build date (see sig) is 2012 but all that means is the APIM and BCM are newer than those that bought cars built earlier -- what differences are there in the hardware (APIM/BCM) between earlier and later builds?


Brian
__________________
2012 FF Ti HB Sonic Blue, Built 5/7/12, 401A + Parking Technology Package and MFT w/NAV 3.0.2 -> 3.2.2 -> 3.5.1 -> 3.6.2
raptor1956 is offline  
    Reply With Quote
Old 09-28-2012, 11:56 AM   #398
paul21
Focus Enthusiast
 
Join Date: Jul 2011
Fan#: 87707
Location: Murfreesboro, TN
What I Drive: 2012 SEL Hatchback

Posts: 181
FF Reputation: 0 paul21 Newbie
Buy-Sell-Trade Rating: (0)
I will try to provide some insight into the issue, complete speculation.

A typical CAN communicates like this, values not exact:
<Module Address 8 bits>+<Control 8 bits>+<Payload/Data 32bits>

The control will be read/write, CRC values, etc.
The module address will be a number assigned to each part (APIM, BCM, etc) on the network, similar to a static IP.

The payload is then broken into two parts:
<Register Address 16bits>+<Data Value 16bits>

The register address is a number that indexes which values to read/write from. Some examples would be:
0x00 Module Version/Info
0x01 Module Status
...
0x10 HVAC Status
0x11 Driver Temp
...

These register addresses are defined by each module maker and typically change from vendor to vendor with exception being 0x00 for version. So what you may have is
0x00 = 1 (Version)
...
0x10 = (Hvac status)
0x11 = (Driver Temp)

or

0x00 = 2 (version
...
0x30 = (HVAC status)
0x40 = (Driver Temp)

so that the address for the HVAC changes between APIMs.

It's completely arbitrary after the version info. So what a programmer for MFT would do is something like this:
if (readData(Version) == 1)
HVAC_STATUS=0x10;
else if (readData(Version) == 2)
HVAC_STATUS=0x30;

to select between versions. Then whenever the climate control section is used, it just uses getData(HVAC_STATUS) and that maps into the right register.


So whenever BSQUARE is responsible for "system integration", they read the data specs for each APIM and determine what version maps with what register address for the HVAC, etc. It's my opinion that they omitted the versions that are specific to the Focus in their latest build.

What's actually more likely is that instead of programming modular code, they just statically define each address when they use it, ie getData(0x10) for hvac and then they have to compiled a different set of code for each car (bad practice).

What seems somewhat obvious to me is that the earlier versions of MFT did something like this:
1: Read some data from the CAN
2: Wait until the full data is received

Then there would be an error in communication and it would be stuck at step 2, waiting for data it would never receive, until the system was reset instead of detecting and correcting the error. This aligns with most sporadic behaviors in these systems. With poor hardware design, the communication system will have glitches from time to time and it's important to design error correction into the modules.
paul21 is offline  
    Reply With Quote
Old 09-28-2012, 12:22 PM   #399
lewisra
Focus Addict
 
Join Date: Dec 2011
Fan#: 93289
Location: Howell, MI
What I Drive: 2012 Tuxedo Black SEL

Posts: 567
FF Reputation: 3 lewisra Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by raptor1956 View Post
-- what differences are there in the hardware (APIM/BCM) between earlier and later builds?


Brian
Don't know if there's any difference, but it seems to be the only common thread between those that have a working climate control display.
lewisra is offline  
    Reply With Quote
Old 09-28-2012, 12:59 PM   #400
oritpro
Focus Enthusiast
 
oritpro's Avatar
 
Join Date: Mar 2012
Fan#: 96148
Location: Portland, OR
What I Drive: 2012 Subaru Impreza Sport Limited

Posts: 441
FF Reputation: 2 oritpro Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by treoless View Post
Took my car to the dealership yesterday and they couldn't re-flash the software after 6 tries. They were told by Ford that the update on SMR was corrupted. They finally fixed it by taking the MFT unit (APIM?) out and forced the update.
If the update was truly corrupted then that would mean that there's no data integrity checks during the update process which a pretty damn scary thought.

It's likely that the update it was just improperly packaged. e.g. wrong package applied to the wrong part.

So I guess at this point I'll schedule a service appointment with my dealer to have the oil changed and the CC problem fixed since they're ignoring my emails and SMR won't answer my question.
oritpro is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:06 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.