Do Fuel Shut Off switches go bad or is it something else??? - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-20-2012, 02:14 PM   #1
Mystic544
Focus Enthusiast
 
Mystic544's Avatar
 
Join Date: Jan 2005
Fan#: 17917
Location: Peoria, AZ
What I Drive: 2003 Pitch Black SVT

Posts: 120
FF Reputation: 1 Mystic544 Good Standing Member
Buy-Sell-Trade Rating: (1)
Question Do Fuel Shut Off switches go bad or is it something else???

2003 SVT Focus 76K miles

OK - so three times over the last month after going to the gym (about 5 mile trip) the SVT won't start.... twice the pump would kick in and she would start only to die after a couple seconds, the other time no fuel pump noise/no start.
On the 1st two times I checked the fuses (OK) and fiddled with the Fuel Shut Off Switch and followed the ignition to on, wait three seconds, turn off - then wait a couple seconds and turn back over. Both times (it did take a couple tries, but) she started back up and ran with no issues - for about a week.

Today she wouldn't start at home so I once again checked the fuses and fuel pump relay (no idea how to tell if the relay is bad or not???) anyway they checked out, so I pulled the side pannel and pulled that Fuel Shut Off Switch. Wires all looked good and clean and connected. I did notice that something inside the switch does flop around and it made the middle copper bridge thing pop up...anyway I push the "switch" back down, the moving parts go up and down, copper bridge middle part stays in place (not sure if that is how it is supossed to work). OK so I put the keys in and the SVT starts right up...

Any Thoughts????
Oh - She has Never been in any accident.

Another question - still has the original battery and the eye kind of goes green/red and I toss a battery tender on it like once a week over night. Does a weak battery mess with things a lot?

Thanks for the Input/Answers/Suggestions ... I appreciate it!
TimmaY


__________________
TimmaY
2003 Pitch Black SVT Focus
1996 Mystic Cobra #544
VP www.midwestfords.org
Mystic544 is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 09-20-2012, 04:44 PM   #2
Mystic544
Focus Enthusiast
 
Mystic544's Avatar
 
Join Date: Jan 2005
Fan#: 17917
Location: Peoria, AZ
What I Drive: 2003 Pitch Black SVT

Posts: 120
FF Reputation: 1 Mystic544 Good Standing Member
Buy-Sell-Trade Rating: (1)
Question

the switch says "Inertia Switch" - guessing that there is a weight or something that moves around inside....I wonder if it makes some sort of electrical or ground connection? Maybe it is corroded or just not making the connection?

As far as the FSOS is concerned - When I called a couple local Ford Dealer Service depts they said they haven't really heard of the FSOS going bad - their 1st thought was the fuel pump :( Just odd that when I mess around with the switch the fuel pump kicks on (when she decides to start)

Hmmmm, a weak battery and/or bad grounds could maybe cause a lot of start and run problems - Possible that it is causing my start issues???
* She does currently turn over with no issue (has been doing a lot of that all day today Arrgh)
__________________
TimmaY
2003 Pitch Black SVT Focus
1996 Mystic Cobra #544
VP www.midwestfords.org
Mystic544 is offline  
    Reply With Quote
Old 09-20-2012, 11:03 PM   #3
Mystic544
Focus Enthusiast
 
Mystic544's Avatar
 
Join Date: Jan 2005
Fan#: 17917
Location: Peoria, AZ
What I Drive: 2003 Pitch Black SVT

Posts: 120
FF Reputation: 1 Mystic544 Good Standing Member
Buy-Sell-Trade Rating: (1)
... so I had The Original Ford OEM battery tested - came back only 180 Cranking Amps, Hmmm that might be a part of problem lol The new NAPA Legend Premium battery has 740 Cranking Amps ;)
Still had to hit the FSOS after putting in the new battery ... but she has started up OK the last three times tonight. Guess I will see if things are back to normal going forward!
__________________
TimmaY
2003 Pitch Black SVT Focus
1996 Mystic Cobra #544
VP www.midwestfords.org
Mystic544 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:16 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.