svt delayed throttle response??????? - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus SVT > SVT Performance (2002-2004)

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 07-31-2012, 09:10 AM   #1
Buhda420
Focus Enthusiast
 
Buhda420's Avatar
 
Join Date: May 2011
Fan#: 85611
Location: waddell, AZ
What I Drive: 2003 svt, silver. 5dr

Posts: 189
FF Reputation: 1 Buhda420 Good Standing Member
Buy-Sell-Trade Rating: (1)
svt delayed throttle response???????

Okay I have had my svt for 4 months now and so far done,,,,,,
Timing belt kit
Accessory belt
Flush all fluids
New transmission
Clutch and master cylinder
Speed sensor
Pcv valve
Plugs and wires
K & n drop in filter
And others I can't think of

And it seems like she's running worse and worse..... When I'm at a light stopped ready to take off.... I let out clutch and go to accelerate and I just sit there pettle to the floor and no response and maybe 3 seconds go by and then she takes off like a the little honey bee she is.......... Soo what could be the delay in response?????????


__________________
#2158
Mr.Snay's bone stock svtf.... Well a few minor appearance upgrades;)
Buhda420 is offline  
    Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-31-2012, 09:46 AM   #2
6SPD_soul
Focus Addict
 
6SPD_soul's Avatar
 
Join Date: Feb 2008
Fan#: 53637
Location: Soldiers Grove, WI
What I Drive: 2003 Comp Orange EAP SVT

Posts: 1,468
Points 2,489, Level 30
Points: 2,489, Level: 30 Points: 2,489, Level: 30 Points: 2,489, Level: 30
Level Up 26% Completed
Level up: 26% Level up: 26% Level up: 26%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 24 6SPD_soul Great Standing Member
Buy-Sell-Trade Rating: (1)
The engine doesn't rev accordingly with the throttle? As a first step I'd take the take the MAF/air filter tube (don't really know the stock setup at all) off the throttle body and have somebody else push the throttle while you watch the throttle body and see if there's a noticeable lag between the two things, I've never heard or read about that here but it sounds like the throttle cable could be binding or something on initial throttle tip in.

The throttle blade could also be sticking but I think you can usually feel that as a slight resistance in the gas pedal.
6SPD_soul is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 03:53 PM   #3
Buhda420
Focus Enthusiast
 
Buhda420's Avatar
 
Join Date: May 2011
Fan#: 85611
Location: waddell, AZ
What I Drive: 2003 svt, silver. 5dr

Posts: 189
FF Reputation: 1 Buhda420 Good Standing Member
Buy-Sell-Trade Rating: (1)
It revs when I give gas accordingly just not when I need to take of fast from a stopped at a light....... If I rev like for a launch its good most of the time..... But like foot from brake to let's take off, no..... I will step on the gas and it like makes bogging sound then the power kicks in and she takes off.......
__________________
#2158
Mr.Snay's bone stock svtf.... Well a few minor appearance upgrades;)
Buhda420 is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 04:07 PM   #4
Sniper Focus
Focus Addict
 
Sniper Focus's Avatar
 
Join Date: Mar 2011
Fan#: 84221
Location: IL, IL
What I Drive: '03 SVT EAP "Eurotrish"

Posts: 1,320
Points 1,989, Level 26
Points: 1,989, Level: 26 Points: 1,989, Level: 26 Points: 1,989, Level: 26
Level Up 89% Completed
Level up: 89% Level up: 89% Level up: 89%
Forum Activity 2%
Activity: 2% Activity: 2% Activity: 2%
FF Reputation: 20 Sniper Focus Great Standing Member
Buy-Sell-Trade Rating: (13)
I'm thinking you're experiencing what all SVTs do. I hear a tune is supposed to fix it, but I don't know firsthand since I don't have a tune. I feather the gas a little before I clutch and I usually get a smooth take off.
__________________
Fox Hound: Liquid Stang - Sniper Focus - Decoy Escort (or was it a Tracer...)
Sniper Focus is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 04:37 PM   #5
Buhda420
Focus Enthusiast
 
Buhda420's Avatar
 
Join Date: May 2011
Fan#: 85611
Location: waddell, AZ
What I Drive: 2003 svt, silver. 5dr

Posts: 189
FF Reputation: 1 Buhda420 Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by Sniper Focus View Post
I'm thinking you're experiencing what all SVTs do. I hear a tune is supposed to fix it, but I don't know firsthand since I don't have a tune. I feather the gas a little before I clutch and I usually get a smooth take off.
U know I was thinking tune....... I mean there has just been soo my h work done to it over the past few months it feels like the cars off a bit and my gas mileage has even declined dramatically...........man I wanted to get new tires and shocks n springs because those are all worn, befor I got the tune........ Wow when I upgraded from zx3 to svtf I thought I was saving money to get those hp gains but wow the maintenance has becom a lot........... I will never ever sell this car now...... I'm way too much into her!!!!!!! Thank you!!!!!!! Now to save 500$$$$ for live wire tune...........
__________________
#2158
Mr.Snay's bone stock svtf.... Well a few minor appearance upgrades;)
Buhda420 is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 07:52 PM   #6
NJSVTGUY
Focus Addict
 
NJSVTGUY's Avatar
 
Join Date: Apr 2007
Fan#: 46519
Location: NJ, United States
What I Drive: 86 GN, 11.1@128, 20 psi

Posts: 893
Points 4,355, Level 42
Points: 4,355, Level: 42 Points: 4,355, Level: 42 Points: 4,355, Level: 42
Level Up 3% Completed
Level up: 3% Level up: 3% Level up: 3%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 8 NJSVTGUY Good Standing Member
Buy-Sell-Trade Rating: (10)
All the symptoms of a bad intake manifold controller. Do a search I think it's called a IMRC it's real easy to check it it is. On start up the cable pulls taunt.
If this is it you are in for a surprise when it's fixed because it really kills performance and mileage.
__________________
http://www.youtube.com/watch?v=3LcXP3kQsGw
NJSVTGUY is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 09:26 PM   #7
Buhda420
Focus Enthusiast
 
Buhda420's Avatar
 
Join Date: May 2011
Fan#: 85611
Location: waddell, AZ
What I Drive: 2003 svt, silver. 5dr

Posts: 189
FF Reputation: 1 Buhda420 Good Standing Member
Buy-Sell-Trade Rating: (1)
Are u talking about the dyi clip or the thread where you actually take out the imrc, open it up and clean the metal connection part??????? Are those actually easy to do cause I have been hesitating to try and remove the clip and box!!!!!!!!!
__________________
#2158
Mr.Snay's bone stock svtf.... Well a few minor appearance upgrades;)
Buhda420 is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 09:46 PM   #8
NJSVTGUY
Focus Addict
 
NJSVTGUY's Avatar
 
Join Date: Apr 2007
Fan#: 46519
Location: NJ, United States
What I Drive: 86 GN, 11.1@128, 20 psi

Posts: 893
Points 4,355, Level 42
Points: 4,355, Level: 42 Points: 4,355, Level: 42 Points: 4,355, Level: 42
Level Up 3% Completed
Level up: 3% Level up: 3% Level up: 3%
Forum Activity 3%
Activity: 3% Activity: 3% Activity: 3%
FF Reputation: 8 NJSVTGUY Good Standing Member
Buy-Sell-Trade Rating: (10)
Just locate the cable end then have someone start the car. The motor pulls the cable and the flapper on the intake moves toward the radiator. This is sooo comon. If it doesn't work then I would check fuse first then consider repair or replacement. But check it first, it's free.
__________________
http://www.youtube.com/watch?v=3LcXP3kQsGw
NJSVTGUY is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 10:42 PM   #9
tukaniSVT
FF PHOTOG ENTHUSIAST
 
tukaniSVT's Avatar
 
Join Date: Mar 2004
Fan#: 5521
Location: SW Houston, TX
What I Drive: 2003 SVT Focus 2009 BMW 335i

Posts: 14,969
Points 36,161, Level 100
Points: 36,161, Level: 100 Points: 36,161, Level: 100 Points: 36,161, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 34 tukaniSVT Great Standing Member
Buy-Sell-Trade Rating: (1)
Interesting. I am experiencing the same problem. Now for me, I have had my car since it first hit 2 miles on the clock back in 2003.

And I have also gone through 2 engines in the car.

But now that I think about it, I have not changed out my IMRC. (Moved over from engine to engine) That does sound like something that would be stopping the acceleration.

Good suggestion, NJSVTGUY.

-Ray-
__________________
Hatch Nation Member: #147

R.I.P - FELLOW FF MEMBER, IZZY, BLK2k3GTS, will always be remembered. We will compete on a different course again one day.
tukaniSVT is offline  
    Reply With Quote Quick reply to this message
Old 07-31-2012, 10:46 PM   #10
sleepyboy
FF's Night Security
 
sleepyboy's Avatar
 
Join Date: Nov 2004
Fan#: 15335
Location: SW Houston, TX, United States
What I Drive: 01' Yellow ZX3 euro, 04' ZX5 SVT

Posts: 26,115
Points 133,769, Level 100
Points: 133,769, Level: 100 Points: 133,769, Level: 100 Points: 133,769, Level: 100
Level Up 0% Completed
Level up: 0% Level up: 0% Level up: 0%
Forum Activity 99%
Activity: 99% Activity: 99% Activity: 99%
FF Reputation: 48 sleepyboy Great Standing Member
Buy-Sell-Trade Rating: (11)
Seriously Raymond? I asked you about it and you said it was fine months darn near years ago of course it wasn't no where near this bad back then. Could have been on it's way out?
__________________
I started out with nothing and I still have most of it left

Hatch Nation #15 (Ole' Yeller') & #150 (The SVT)
Moderator for
Technical Chat
Zetec Performance Chat
Southern Fanatics Chat
sleepyboy is online now  
    Reply With Quote Quick reply to this message
Reply

Bookmarks & Social Networks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:13 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Cadillac ATS-V, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.