NUMEROUS 2012 Ford Focus issues... someone please help! - Page 2 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 09-10-2012, 03:50 PM   #11
suss6052
Focus Addict
 
suss6052's Avatar
 
Join Date: Feb 2012
Fan#: 95752
Location: ..., MI
What I Drive: 2013 Ford Focus ST2 Ingot Silver

Posts: 12,179
FF Reputation: 23 suss6052 Great Standing Member
Buy-Sell-Trade Rating: (3)
[QUOTE=B-lou;4346332]
Quote:
Originally Posted by mac.mogul View Post
Well obviously because so many people have died from driving a new Focus.[/QUOTE
You obviously have not been making a left turn into oncoming traffic when the car just decides to just quit going foward so until it happens to you (numerous times) just shut up.....and how many people died because of the design failures of the pinto before ford had a recall.....and we wont even go into the design failures of the explorer cause that was firestones fault........B-lou
I don't know how you're managing to confuse the car right before a turn such that it will fall flat on its face. Every single time I've made a left hand turn at the base of the freeway off ramp on to city streets with any sort of desire to accelerate after slowing down or coasting down the ramp are met with the car holding onto the current low gear and pulling quickly and smoothly around the corner. If I'm too agressive with it it will give me a chirp of wheel spin during the event, but never have I found myself stuck and hoping that it would make up its mind under those conditions. Maybe mine just works better so far, but I doubt they are all as bad as you claim.

Of course I try not to have to tear the tires from the wheel if possible, but it can and will light them up going around a corner.
suss6052 is online now  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 09-10-2012, 04:18 PM   #12
mac.mogul
Focus Fanatic
 
mac.mogul's Avatar
 
Join Date: Oct 2011
Fan#: 90409
Location: Wichita, KS
What I Drive: 2011 Sterling Grey SES Sedan

Posts: 3,665
FF Reputation: 13 mac.mogul Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by b-lou
You obviously have not been making a left turn into oncoming traffic when the car just decides to just quit going foward so until it happens to you (numerous times) just shut up.....and how many people died because of the design failures of the pinto before ford had a recall.....and we wont even go into the design failures of the explorer cause that was firestones fault........B-lou
Are you dead? Posting from the grave?

My 2011 Focus is my first manual transmission car and while getting used to it I stalled in several intersections and I, too, am still alive.

by the way, it was 27. 27 deaths were attributed to Pinto fires. Over 2 million sold while it was produced.
__________________
2011 SES 5spd #006 >> SR #213

What other people think of me is none of my business.
mac.mogul is offline  
    Reply With Quote
Old 09-10-2012, 04:28 PM   #13
mac.mogul
Focus Fanatic
 
mac.mogul's Avatar
 
Join Date: Oct 2011
Fan#: 90409
Location: Wichita, KS
What I Drive: 2011 Sterling Grey SES Sedan

Posts: 3,665
FF Reputation: 13 mac.mogul Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by B-lou View Post
You must just be a complete idiot....ours was a titanium automatic read the posts moron...B-lou
I read very clearly. You said your car stalled while turning in an intersection.

Mine did too! What a miracle we are both still alive and well.
__________________
2011 SES 5spd #006 >> SR #213

What other people think of me is none of my business.
mac.mogul is offline  
    Reply With Quote
Old 09-11-2012, 10:32 AM   #14
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,096
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by B-lou View Post
I traded my 2012 focus titanium in at 10000 miles for another brand of car and have not looked back...
No; we'll miss you, dearly! Have fun in your new ride and always remember us.

Quote:
Originally Posted by mac.mogul View Post
Well obviously because so many people have died from driving a new Focus.
Quote:
Originally Posted by suss6052 View Post
...Every single time I've made a left hand turn at the base of the freeway off ramp on to city streets with any sort of desire to accelerate after slowing down or coasting down the ramp are met with the car holding onto the current low gear and pulling quickly and smoothly around the corner. If I'm too agressive with it it will give me a chirp of wheel spin during the event, but never have I found myself stuck and hoping that it would make up its mind under those conditions...
Let's wish B-lou all the best! I see you've been pretty busy, suss6052. Your CSM has a follow-up scheduled with you on September 17th.

Thomas
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordService is offline  
    Reply With Quote
Old 09-13-2012, 03:12 PM   #15
6769MOPARS
Focus Enthusiast
 
6769MOPARS's Avatar
 
Join Date: May 2011
Fan#: 86108
Location: Powder Springs, GA
What I Drive: PB Focus ST2 and 67 426 Hemi GTX

Posts: 431
FF Reputation: 1 6769MOPARS Good Standing Member
Buy-Sell-Trade Rating: (1)
Quote:
Originally Posted by jrharder4 View Post
Okay... this is going to sound very tacky but this has been my dream car since I was in high school. I started working at a dealership a while back (I no longer work there) so in May of 2012 while still working there, I decided to get a 2012 Ford Focus SL light blue in color because of the AWSOME price. I want SO much to love it... but I hate it right now with the NUMEROUS issues I am having. I'd really love to hear if anyone else is having these issues, especially since my car only has a little over 13,000 miles on it...

FIRST, my car back in August of last year started making a grinding noise when I turned the steering wheel in drive AND reverse. When I took it in to have my oil changed (I worked there) they swore up and down that they didn't hear what I was talking about and that everything was okay. Since then it has gotten way worse and I finally asked them to look at it AGAIN when they did the last safety issue updates (updating the computer system and the windshield wiper piece). They FINALLY told me that after digging for a while, there are known issues with the steering column. They didn't explain it very well but they said that a piece that should be lubricated isn't lubricated anymore due to another part and it is causing to rub and mine is about to snap in half. Wonderful, right? Well parts are 3-5 days out (luckily it is under warranty so we don't have to pay anything) but is ANYONE else having this issue? I have been searching for it and am not seeing anything else about it online.

SECOND, this past Saturday I was heading back home (about 70 miles away from where I live) to see family and I got 20 miles away from the town I am living in and ALL of my lights came on, my car beeped, and then ALL of the lights went off other than the light with the exclamation point and also the tire pressure light. I pulled over upon my screen on my dash showing "Low Tire Pressure". I had my 2 little girls with me so it showing me that was no messing around matter. I got out, and upon checking my tires, none of them even looked low and I didn't spot anything in any of the tires. I called the dealership close to where I was driving and they told me that it should be okay and that I should just bring it to them when I get into town. I took it to them, and after 40 minutes of waiting around in the dealership (a Ford dealership) they came back to tell me that more than likely it was the alternator and that if it is, I might have to leave it there. They explained that they tried resetting the light and it wouldn't reset over and over. They said that they had attempted it 3 times and it didn't work. They said that they checked the tire pressures and everything was okay there. After thoroughly freaking me out, they came BACK in 20 minutes later to tell me that on the SIXTH time they got it to reset. On the reciept that they gave me, they put, "Customer requests electrical system diag, customer driving down interstate all warning lamps came on and then went off. Now tire light is on -ADVISE- could not duplicate concern at present time. Retrieved cont memory dtc u0140. Performed pinpoint test and couldn't duplicate concern. No problem found." I find this very strange that they didn't put a thing about the alternator on it like they advised me. Anyhow, later that night, I quickly realized that NONE of my lights were coming on (my headlights were on and the green headlight light wasn't coming on and my friend wasn't wearing her seatbelt in the passenger seat and the "no seatbelt" light didn't come on either. Well, the very next day I went out to start my car and low and behold, the same tire pressure light was on and my screen was telling me that I had low tire pressure. I called the dealership in my town today and they seemed to know nothing of the issue but told me to bring it in in the morning. I'm almost embarrased to take the reciept in from them because it makes them look like idiots that they put that there was no issue when there OBVIOUSLY was. Now the dealership I am taking it to tomorrow has NO idea what was done by them to it, either. SCARY!!!

THIRD, when I start the car and put it in reverse OR drive, it goes either backwards/forwards before driving. In reverse, it often goes forward and in drive it ALWAYS goes backwards like a manual car would. It wasn't too terrible at first but now it is getting worse and worse. Is this something I should be concerned about? Anyone else having this issue?

FOURTH, for a new car, you shouldn't have to SLAM your trunk down to get the light to go off, correct? If I shut my trunk like you normally would, not too hard, it "shuts" (to where I have to use my button to open it) but the "Trunk Compartment Open" warning comes on and is quite annoying until I pop the trunk back open and SLAM it shut. Anyone else having this issue?

I would appreciate any feedback. Like I said, with so little of miles... this is scaring the daylight out of me. We did not get the extended warranty with it.. and with how many issues it is having NOW, I can only imagine how many it will have AFTER the warranty is up. HELP!!!
Sounds like you and your dealer are working out the mechanical electrical issues.

For the trunk, you can adjust the striker where the latch locks it closed. Just loosen the two bolts that hold it in place and move it back a little. The hatch should close with minimal effort now. I've adjusted this on both my Fiesta hatch and my wife's Focus hatch. It's a five minute job. Let me know if you have any questions.
6769MOPARS is offline  
    Reply With Quote
Old 09-15-2012, 01:32 PM   #16
WrenthamMA
Focus Rookie
 
Join Date: Sep 2012
Fan#: 103849
Location: Wrentham, MA
What I Drive: 2012 White SE

Posts: 2
FF Reputation: 1 WrenthamMA Good Standing Member
Buy-Sell-Trade Rating: (0)
Has anyone else experienced sudden, near total electrical failure, including loss of instruments, and accompanied by the loss of:
-Turn signals
-Brake lights & headlamps
-Horn, etc?
Radio was functioning, though the display was dim. The main display read "Put Transmission in Park" (or something to that effect).
This occurred while driving "normally," and during the day. Had it occurred at night, consequences could have been very serious.
Dealer, after 2.5 days of repairs, replaced a body control module. Have not experienced recurrence after two days.
Please reply if you've had a similar experience. Thanks.
WrenthamMA is offline  
    Reply With Quote
Old 09-17-2012, 01:55 PM   #17
suss6052
Focus Addict
 
suss6052's Avatar
 
Join Date: Feb 2012
Fan#: 95752
Location: ..., MI
What I Drive: 2013 Ford Focus ST2 Ingot Silver

Posts: 12,179
FF Reputation: 23 suss6052 Great Standing Member
Buy-Sell-Trade Rating: (3)
Freaking scum of a lying dealer. FML, the customer care representative now is trying to tell me that the dealer claimed that the seat heater was reading 125F at the element via the temperature sensor and that everything was fine. When the dealer told me that it was only ever at 90-100F. And now they believe the issue to be resolved/ claim it wasn't broken in the first place despite never reaching more than 88 degrees this morning when it was 55-57F out. That's operating within tolerance allegedly. WTF??????????

Heat transfer doesn't work that way that in such a small amount of space between the heater mat and the seat cover that you would lose over 30-40+ degrees and be considered within tolerance as far as I'm concerned with engineering. Thats a weak excuse and I want the car to reach at least 100+ on a 30F day because that's when I need the heat the most but it just gets weaker the colder it is.
suss6052 is online now  
    Reply With Quote
Old 09-17-2012, 02:35 PM   #18
WiscoGTI
Turböner
 
WiscoGTI's Avatar
 
Join Date: Nov 2009
Fan#: 70225
Location: Watertown, WI
What I Drive: 2002 VW GTI

Posts: 9,342
FF Reputation: 32 WiscoGTI Great Standing Member
Buy-Sell-Trade Rating: (9)
Tire pressure sensors are the dumbest thing ever installed in a car. Get your lazy ass out and look at your tires. You'll know when they're low.

Sent from my man cannon via FF Mobile.
WiscoGTI is online now  
    Reply With Quote
Old 10-26-2012, 04:14 PM   #19
bassingal56
Focus Rookie
 
Join Date: Oct 2012
Fan#: 105330
Location: Chesterfield, VA
What I Drive: 2012 Red Ford Focus Titanium

Posts: 3
FF Reputation: 1 bassingal56 Good Standing Member
Buy-Sell-Trade Rating: (0)
I have a 2012 Ford Focus Titamium. It started making a clunking noise when turning right couple months after I bought it. Took it to dealer they could not find anything. Second time it starting making same noise more often, took it to dealer, they had tech guy ride with me he heard it very clearly. They called two days later said great news we found problem. They said it had a bad bearing on the strut. Got it back no noise for two whole weeks. Then, same noise, same turning right came back. Dealer has had it now for the third time for one full week. We just called them, they never called us or offered a rental, said they could not really hear it anymore and to come get car. ( Guess they would have just kept the car without calling us and I was borrowing someones car all week if I had not called them) They also said some cars just have some noises. I am wishing I had never bought this car. Very dissapointed. Want to get rid of it now, with only 4,800 miles on it. Beautiful car with great sound system. Guess I am supposed to just turn up the music and forget the noise. :(((((((
bassingal56 is offline  
    Reply With Quote
Old 10-29-2012, 09:25 AM   #20
FordService
Official Ford Rep
 
FordService's Avatar
 
Join Date: Oct 2010
Fan#: 79824
Location: Dearborn, MI
What I Drive: Ford Focus

Posts: 4,096
FF Reputation: 18 FordService Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by bassingal56 View Post
I have a 2012 Ford Focus Titamium. It started making a clunking noise when turning right couple months after I bought it. Took it to dealer they could not find anything. Second time it starting making same noise more often, took it to dealer, they had tech guy ride with me he heard it very clearly. They called two days later said great news we found problem. They said it had a bad bearing on the strut. Got it back no noise for two whole weeks. Then, same noise, same turning right came back...(
Hi bassingal56,

Just a heads up - I responded to your PM with some next steps. Please let me know if you have any additional questions or concerns.

Have a great day,
Crystal
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordFocus @Ford
f: facebook.com/FordFocus facebook.com/Ford
FordService is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:15 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.