Replaced Head - Now a couple issues - Page 4 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus First Generation > SPI Performance (2000-2004)

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 07-01-2012, 09:11 AM   #31
IA_Chiefs_fan
Focus Jr. Enthusiast
 
Join Date: May 2012
Fan#: 99008
Location: Lamoni, IA
What I Drive: 2001, Black, Sedan

Posts: 27
FF Reputation: 1 IA_Chiefs_fan Good Standing Member
Buy-Sell-Trade Rating: (0)
So far, so good with the head. The car does still have some sort of miss but it is minor. I notice it most when the car is cold. As the RPMs wind up, just before I up-shift, it seems to kind of bog. There are no error codes. Overall it runs very well though.
IA_Chiefs_fan is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:27 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information : Site Map

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.