Very frustrated! - Page 6 - Ford Focus Forum, Ford Focus ST Forum
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 06-05-2012, 10:05 PM   #51
nekoashide
Focus Enthusiast
 
Join Date: Sep 2007
Fan#: 50156
Location: Dallas
What I Drive: 2010 Ford Focus S

Posts: 108
FF Reputation: 1 nekoashide Good Standing Member
Buy-Sell-Trade Rating: (0)
Sounds like the EGR Vacuum Solenoid on the firewall. It's supossed to open/close depending on RPM. Mine started going bad and it had a horrible idle/dies when stopped at lights or coming to a stop. No CEL and it was about the only thing i hadnt replaced because it acted just like a vacuum leak.
nekoashide is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 06-05-2012, 10:54 PM   #52
Mother Focus
Focus Addict
 
Mother Focus's Avatar
 
Join Date: Mar 2010
Fan#: 73292
Location: San Juan, PR
What I Drive: 2001 Money Pit

Posts: 1,428
Points 4,667, Level 43
Points: 4,667, Level: 43 Points: 4,667, Level: 43 Points: 4,667, Level: 43
Level Up 59% Completed
Level up: 59% Level up: 59% Level up: 59%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 13 Mother Focus Great Standing Member
Buy-Sell-Trade Rating: (9)
Zetec's don't have a fuel pressure regulator and are return less fuel system. EGR possibly, but should do vacuum and hoses check or replace first, which are not much $$$ and is the most common.
__________________
PTE 6262CEA
Pump Gas 385whp 319wtq
Race Gas 551whp 439wtq
Tuned by Fernando@RacingPartsSolution.com
Mother Focus is offline  
    Reply With Quote
Old 06-06-2012, 12:22 AM   #53
RICHARD2238
Focus Rookie
 
Join Date: Jul 2011
Fan#: 88329
Location: MURRIETA, CA
What I Drive: 2002 ZTS

Posts: 11
FF Reputation: 1 RICHARD2238 Good Standing Member
Buy-Sell-Trade Rating: (0)
any luck with it yet let me ask a basic question how long has it been running like this did it start over night or has it been going on for some time ????
RICHARD2238 is offline  
    Reply With Quote
Old 06-06-2012, 04:47 AM   #54
cma8302000
Focus Jr. Enthusiast
 
cma8302000's Avatar
 
Join Date: Jun 2012
Fan#: 99700
Location: Moreland, GA
What I Drive: 2000, silver SE SPORT

Posts: 42
FF Reputation: 1 cma8302000 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by RICHARD2238 View Post
any luck with it yet let me ask a basic question how long has it been running like this did it start over night or has it been going on for some time ????
It's been going on quite some time...I would bring it to a mechanic and he would change something ..it would still do it , I would wait a while bring it back and he would change something..it would still do it...it's been an ongoing thing....I just can't believe how many things can cause the same symptoms..it's enough to make your head spin...
cma8302000 is offline  
    Reply With Quote
Old 06-06-2012, 06:23 AM   #55
malim
Focus Enthusiast
 
malim's Avatar
 
Join Date: Apr 2008
Fan#: 55004
Location: Toronto, Canada
What I Drive: 2007 Ford Focus ST - Black

Posts: 469
Points 938, Level 16
Points: 938, Level: 16 Points: 938, Level: 16 Points: 938, Level: 16
Level Up 38% Completed
Level up: 38% Level up: 38% Level up: 38%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 4 malim Good Standing Member
Buy-Sell-Trade Rating: (0)
Maybe it's time to go see another mechanic?
malim is offline  
    Reply With Quote
Old 06-06-2012, 01:35 PM   #56
cma8302000
Focus Jr. Enthusiast
 
cma8302000's Avatar
 
Join Date: Jun 2012
Fan#: 99700
Location: Moreland, GA
What I Drive: 2000, silver SE SPORT

Posts: 42
FF Reputation: 1 cma8302000 Good Standing Member
Buy-Sell-Trade Rating: (0)
Posted via FF Mobile

its with another mechanic...not going back to the one i used before
cma8302000 is offline  
    Reply With Quote
Old 06-08-2012, 03:55 PM   #57
DrkKnight614
GO Green
 
DrkKnight614's Avatar
 
Join Date: Oct 2004
Fan#: 14522
Location: Long Island, NY, United States
What I Drive: 2003 2.0L Grabber Green Zx3

Posts: 11,143
FF Reputation: 47 DrkKnight614 Great Standing Member
Buy-Sell-Trade Rating: (0)
Posted via FF Mobile Any update on this?
DrkKnight614 is offline  
    Reply With Quote
Old 06-08-2012, 05:07 PM   #58
cma8302000
Focus Jr. Enthusiast
 
cma8302000's Avatar
 
Join Date: Jun 2012
Fan#: 99700
Location: Moreland, GA
What I Drive: 2000, silver SE SPORT

Posts: 42
FF Reputation: 1 cma8302000 Good Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by DrkKnight614 View Post
Posted via FF Mobile Any update on this?
last i heard , and I am not rushing the guy is that he has checked everything and replaced parts...He's been online to ford forums and focus forums ( probable even saw this) but nothing he's tried fixed it...he said he thinks maybe the computer?...I think he tried the reset thing you suggested... I haven't heard from him yet today so I dont' know the outcome yet...I will let y'all know when I know....OH YEAH, DID I MENTION MY AIRBAG LIGHT IS ON AND MY HORN DOESN'T WORK... that's another thing that's been going on for a while too but the first issue was happening way before the airbag light came on....Sorry y'all but that particular car is a piece of crap...So, once I get it back a For Sale sign will be going up on it.....I will keep y'all posted...AND THANKS SO MUCH FOR ALL THE INPUT... be back soon.....
cma8302000 is offline  
    Reply With Quote
Old 06-09-2012, 10:29 AM   #59
DrkKnight614
GO Green
 
DrkKnight614's Avatar
 
Join Date: Oct 2004
Fan#: 14522
Location: Long Island, NY, United States
What I Drive: 2003 2.0L Grabber Green Zx3

Posts: 11,143
FF Reputation: 47 DrkKnight614 Great Standing Member
Buy-Sell-Trade Rating: (0)
Quote:
Originally Posted by cma8302000 View Post
last i heard , and I am not rushing the guy is that he has checked everything and replaced parts...He's been online to ford forums and focus forums ( probable even saw this) but nothing he's tried fixed it...he said he thinks maybe the computer?...I think he tried the reset thing you suggested... I haven't heard from him yet today so I dont' know the outcome yet...I will let y'all know when I know....OH YEAH, DID I MENTION MY AIRBAG LIGHT IS ON AND MY HORN DOESN'T WORK... that's another thing that's been going on for a while too but the first issue was happening way before the airbag light came on....Sorry y'all but that particular car is a piece of crap...So, once I get it back a For Sale sign will be going up on it.....I will keep y'all posted...AND THANKS SO MUCH FOR ALL THE INPUT... be back soon.....
Grab another Focus if you can. Gremlings seem to be the problem.
__________________
My 2003 Ford Focus ZX3 - Finally realized it's a 4cyl
DrkKnight614 is offline  
    Reply With Quote
Old 06-09-2012, 11:17 PM   #60
agentmaroon108
Focus Rookie
 
Join Date: Feb 2012
Fan#: 94633
Location: Apex, NC
What I Drive: 2002 snow white ZX3 5-speed

Posts: 4
Points 6, Level 1
Points: 6, Level: 1 Points: 6, Level: 1 Points: 6, Level: 1
Level Up 11% Completed
Level up: 11% Level up: 11% Level up: 11%
Forum Activity 0%
Activity: 0% Activity: 0% Activity: 0%
FF Reputation: 1 agentmaroon108 Good Standing Member
Buy-Sell-Trade Rating: (0)
same issues...

seems like every focus nowadays is having a rough idle problem. i drive an 02 zx3 5 speed. i previously had an '00 zx3 5 speed, but totaled it. it had the same rough idle problem but due to being cross-eyed at the end of its poor life, i had no opportunity to fix this problem at all. anyways, the issue at hand i'm having is that when i come to a redlight or any prolonged stop, the car stalls. it sputters, bucks, and shakes until it eventually stalls unless you constantly give it gas. if i do decide to play the battle and give it gas, it will stay running until i am able to take off and shift into 1st. otherwise, as soon as i decide not to give it any gas, or start to and then stop, the car will either stall or dip down to about 100-300 rpms. it constantly tries to fix itself, and jump back to a normal idling rpm, but usually is unsuccessful. i recently changed the pcv hose in an effort to fix this, as well as running seafoam. neither seemed to change the problem. seems as though there are about 15 different things that supposedly remedy the problem but the main question is where do i start? ive heard egr valve, fuel filter changes, regular oil changes, spark plugs, crankshaft sensor, iacv, pcv, any other vacuum leaks, spark plugs, ecu, replacing the recalled fuel pump and fuel injectors.... to name a few. seeing as things add up quick and half are ford parts, other half aftermarket, im trying to start with the most successful first. i've looked on hundreds of sites, and hundreds of forums but no one has an answer. is this a mythical solution? i really hope i dont have to find out by my beloved focus dying of one last final stall out.... please help!
agentmaroon108 is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:18 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.