ZETEC Engine stumble - SOLVED - Page 5 - Focus Fanatics
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Focus Fanatics > Ford Focus Tech Discussions > General Technical Chat

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Reply
 
Thread Tools Display Modes
Old 12-20-2004, 02:43 PM   #41
bwojdyla
Focus Fanatic
 
bwojdyla's Avatar
 
Join Date: Feb 2004
Fan#: 3589
Location: Royal Oak, aka Detroit Metro Area
What I Drive: Red 2000 ZX3

Posts: 1,508
FF Reputation: 1 bwojdyla Good Standing Member
Buy-Sell-Trade Rating: (0)
Its nice isn't it.

And don't complain about being cold at 31 degrees. It's 17 here. wind chill puts it at 4. Its so cold that my huge office buildings HVAC unit can't keep up with the heat loss. It's like 55 in here.
__________________
Those who control the present control the past, those who control the past, control the future. - George Orwell, 1984.
bwojdyla is offline  
    Reply With Quote
Sponsored Links
Advertisement
 
Old 12-20-2004, 06:46 PM   #42
InfraredZTW
Focus Enthusiast
 
InfraredZTW's Avatar
 
Join Date: Nov 2004
Fan#: 15867
Location: Canada, Canada
What I Drive: 2002 Infra-Red ZTW

Posts: 57
FF Reputation: 1 InfraredZTW Good Standing Member
Buy-Sell-Trade Rating: (0)
"Most useful thread... everrrr" - The Comic Book Store Guy from Simpsons
__________________
Just keep driving...
InfraredZTW is offline  
    Reply With Quote
Old 12-20-2004, 07:00 PM   #43
tension001
Focus Addict
 
tension001's Avatar
 
Join Date: Dec 2003
Fan#: 2278
Location: Hickory, NC
What I Drive: 2001 Infra-Red 5sp ZX3

Posts: 1,309
FF Reputation: 1 tension001 Good Standing Member
Buy-Sell-Trade Rating: (0)
ahha wow, pretty cold. Its supposed to be getting down to 17 here tonight....
__________________
2001 Red ZX3 5spd

OBX 4-2-1 Race Header; Borla 2.5" SVT Catback; MAC Short Ram; FC 65mm TB; FC Race Shifter; Gear Concepts Aluminum Pedals; Painted Interior; SVT Front Bumper and grille
tension001 is offline  
    Reply With Quote
Old 12-21-2004, 12:16 PM   #44
InfraredZTW
Focus Enthusiast
 
InfraredZTW's Avatar
 
Join Date: Nov 2004
Fan#: 15867
Location: Canada, Canada
What I Drive: 2002 Infra-Red ZTW

Posts: 57
FF Reputation: 1 InfraredZTW Good Standing Member
Buy-Sell-Trade Rating: (0)
I'm having problems with the idling when i'm trying to keep my ATX at 30km/h in traffic with the brake. It feels like it's gonna die. And always if i am stopped and i press the brake, when the lights come on the engine stumbles.
BWO, any idea bulbs?
__________________
Just keep driving...
InfraredZTW is offline  
    Reply With Quote
Old 12-21-2004, 01:20 PM   #45
bwojdyla
Focus Fanatic
 
bwojdyla's Avatar
 
Join Date: Feb 2004
Fan#: 3589
Location: Royal Oak, aka Detroit Metro Area
What I Drive: Red 2000 ZX3

Posts: 1,508
FF Reputation: 1 bwojdyla Good Standing Member
Buy-Sell-Trade Rating: (0)
nope. I was going to take a shot, but it would have been 100% pulled out of my rear end bullshit.
I can tell you some things to do though. First is to reset. Unplug the battery for an hour or so. This will clear the fuel trims stored in the ECU. Your programming will be reset to factory default and the computer will relearn the appropriate fuel curves. try cleaning out the upper intake (cleaning the MAF, filter, check the PCV valve itself). It's probably not any of the servo's like EGR or IAC since those would throw a quick CEL. check your spark plugs for fouling, check to make sure your spark plug wires are in good shape and the ends make strong contact on the coil and the plug, check all the vacuum hoses, not just the one that was bad in this case. that's about all I can think of that would amount to rough running as an easy fix.
__________________
Those who control the present control the past, those who control the past, control the future. - George Orwell, 1984.
bwojdyla is offline  
    Reply With Quote
Old 12-21-2004, 03:32 PM   #46
InfraredZTW
Focus Enthusiast
 
InfraredZTW's Avatar
 
Join Date: Nov 2004
Fan#: 15867
Location: Canada, Canada
What I Drive: 2002 Infra-Red ZTW

Posts: 57
FF Reputation: 1 InfraredZTW Good Standing Member
Buy-Sell-Trade Rating: (0)
"Damn rookies" I can't seem to find the PCV valve, on my Probe is right on top alive and clicking in a pool of mobil1 (btw what brands do you guys think are best in PCV-ing, also what would be the best sparks to use - i know not bosch)
I have a K&N flat filter almost new- so i won;t try to clean it yet
and what do you mean by cleaning the massAF, just some dust blowing? or real clean wiping?
__________________
Just keep driving...
InfraredZTW is offline  
    Reply With Quote
Old 12-21-2004, 04:13 PM   #47
bwojdyla
Focus Fanatic
 
bwojdyla's Avatar
 
Join Date: Feb 2004
Fan#: 3589
Location: Royal Oak, aka Detroit Metro Area
What I Drive: Red 2000 ZX3

Posts: 1,508
FF Reputation: 1 bwojdyla Good Standing Member
Buy-Sell-Trade Rating: (0)
The PVC is on top of the oil seperator. look down at your engine, under the right side of the exhaust manifold is a rubber hose that makes a 90 into the top of the oil seperator (which is nestled up to the crankcase). That hose attches to the PCV valve, which supposedly just pulls out. I've never even been able to get the darn hose off to try.

To clean the MAF, first unplug it and take it out, as in out of its housing. There are two torx screws that hold it to the housing (you don't have to take the intake apart). look into it, there are two wires, one mounted low and in front, the other mounted high and in the back. the back one tends to get really dirty cause thats the one in stagnation. use a cotton swab and some rubbing alcohol to clean them both. it really smooths the idle if its dirty.
__________________
Those who control the present control the past, those who control the past, control the future. - George Orwell, 1984.
bwojdyla is offline  
    Reply With Quote
Old 12-30-2004, 03:59 PM   #48
InfraredZTW
Focus Enthusiast
 
InfraredZTW's Avatar
 
Join Date: Nov 2004
Fan#: 15867
Location: Canada, Canada
What I Drive: 2002 Infra-Red ZTW

Posts: 57
FF Reputation: 1 InfraredZTW Good Standing Member
Buy-Sell-Trade Rating: (0)
Kewl.
I'll try today maybe.
Thanks
__________________
Just keep driving...
InfraredZTW is offline  
    Reply With Quote
Old 12-30-2004, 09:38 PM   #49
InfraredZTW
Focus Enthusiast
 
InfraredZTW's Avatar
 
Join Date: Nov 2004
Fan#: 15867
Location: Canada, Canada
What I Drive: 2002 Infra-Red ZTW

Posts: 57
FF Reputation: 1 InfraredZTW Good Standing Member
Buy-Sell-Trade Rating: (0)
Grrr.
I tried...The two torx screws on top of the maf are "secure"-torx with an extra pin in the center and after fiddling with a series of drivers for a while i got mad and took the intake pipe out, then found two regular torx on the side of the MAF assy and took the full maf assy out.
the resistor-like wires were one high and in the front and one low and in the back, the one in the back was (i would say a little corroded) darker and due to a lack of iso-prop alcohol i cleaned them with a drop of water.It didn't seem to do much to the darker wire and i managed to get some cotton stuck in the 4 pins that hold the wires(darn).
I cleaned everything and reinstalled.
It seems that the idle is better (5% better) i would say but only after the engine is heated.
I used the test mode and the rpm goes from 670 to 720 at hot idle with no accessories on.
When the flickering issue goes on the rpm goes down at least 50.
I also checked the PCV hose with my hand and it feels pretty firm.Could it still be broken ?
Anyway.
Ideas?
__________________
Just keep driving...
InfraredZTW is offline  
    Reply With Quote
Old 12-31-2004, 09:57 PM   #50
InfraredZTW
Focus Enthusiast
 
InfraredZTW's Avatar
 
Join Date: Nov 2004
Fan#: 15867
Location: Canada, Canada
What I Drive: 2002 Infra-Red ZTW

Posts: 57
FF Reputation: 1 InfraredZTW Good Standing Member
Buy-Sell-Trade Rating: (0)
hmm.. i guess u'r partying hard till 2005..
Waiting for the 05 ZX3 to be on sale?
:)
__________________
Just keep driving...
InfraredZTW is offline  
    Reply With Quote
Reply

Bookmarks & Social Networks
-->
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zetec engine identification mr_force ZETEC Performance (2000-2004) 15 09-05-2007 04:00 PM
Vehicle Maintenence Schedule S2 General Technical Chat 0 05-08-2006 10:57 AM
New Engine Technology 2004SVTAutoXer Ford Focus & General Car Chat 8 04-26-2006 06:06 PM
Zetec Stumble Fix...Help? jcarian General Technical Chat 1 03-11-2005 11:00 PM


All times are GMT -5. The time now is 04:41 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.